?
Solved

Ping server name returns wrong/old ip address

Posted on 2007-10-10
9
Medium Priority
?
2,825 Views
Last Modified: 2009-06-14
When trying to ping a server using the server name, brings up the wrong ip address. We have DNS, DHCP, and WINS setup in our domain. All workstations can resolve the server name with the correct ip address, but have a problem with one laptop that is connected to our domain.
0
Comment
Question by:ecardio
  • 3
  • 2
  • 2
  • +2
9 Comments
 
LVL 3

Expert Comment

by:jkpc21
ID: 20051278
Go into the Command Prompt and do a ipconfig/flushdns and the ipconfig/registerdns
0
 
LVL 27

Expert Comment

by:michko
ID: 20051295
It may just have an old entry in the DNS on that laptop.  First check that the DNS server is set up correctly.
Then Start -> Run   type cmd
In the command prompt type    ipconfig /flushdns

If that doesn't work, look at this article:
http://technet2.microsoft.com/windowsserver/en/library/0347e3db-f010-4229-a722-5f8fe653f5491033.mspx?mfr=true
0
 
LVL 2

Expert Comment

by:RayAtVittoria
ID: 20051320
Without knowing more about what operating system is on your laptop.. I have run across machines that stuck like that.
This may seem elementary but...
You can try to type the following at the command promt:

"ipconfig /release"   hit enter
then
'ipconfig /renew" hit enter
This will force the network adapter to renew its connection information.

Cheers...
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 

Author Comment

by:ecardio
ID: 20051357
Laptop is running Windows XP Pro. Here are some of the things that I have already tried.
-ipconfig /flushdns
-ipconfig /registerdns
-ipconfig /release
-ipconfig /renew
-took the laptop off the domain and placed it back on

Thanks for all your help, but still not working for me
0
 
LVL 27

Expert Comment

by:michko
ID: 20051454
Disable dhcp and set ip address and dns information manually.  See if that resolves the problem.
0
 

Author Comment

by:ecardio
ID: 20051483
No, still pings the wrong server ip address when giving the laptop a static ip address
0
 
LVL 6

Accepted Solution

by:
netnounours earned 500 total points
ID: 20051536
Check if there is an entry in the host file and, if yes, remove it.

\windows\system32\drivers\etc\hosts

I hope this helps
0
 
LVL 3

Expert Comment

by:jkpc21
ID: 20051575
If there is no entry in the host file, then i would suggest adding an entry for the server you are trying to access.

0
 

Author Comment

by:ecardio
ID: 20051590
Thanks netnounours. Thats exactly what it was.
0

Featured Post

VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Windows 10 Creator Update has just been released and I have it working very well on my laptop. Read below for issues, fixes and ideas.
This article provides a convenient collection of links to Microsoft provided Security Patches for operating systems that have reached their End of Life support cycle. Included operating systems covered by this article are Windows XP,  Windows Server…
Windows 8 comes with a dramatically different user interface known as Metro. Notably missing from the new interface is a Start button and Start Menu. Many users do not like it, much preferring the interface of earlier versions — Windows 7, Windows X…
Windows 10 is mostly good. However the one thing that annoys me is how many clicks you have to do to dial a VPN connection. You have to go to settings from the start menu, (2 clicks), Network and Internet (1 click), Click VPN (another click) then fi…
Suggested Courses

755 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question