We help IT Professionals succeed at work.

Blackberry Server Error Questions

dplaw
dplaw asked
on
10,881 Views
Last Modified: 2008-10-07
I am receiving many different types of errors in my event log on my BB server.  I am currently running 4.0.6.12.  

I am getting the follow error in the application log

Source:  Blackberry Router

[SERVICE_RELAY_SESSION:S103691:0077b5f0] Service transaction not found. SERVICESESSION_TAG=20260613

And a warring

Source:  Blackberry Router

[DEVICE_SESSION:23DB9C4C:01861d48] Timer Event. Exceeded service authentication timeout.  Service: S103691

In addition I am getting error messages in the application log

Source: Service Control Manager

The BlackBerry Synchronization Service service failed to start due to the following error:
The service did not start due to a logon failure.

AND

Source: Service Control Manager

The BlackBerry SyncServer service was unable to log on as DOMAIN\besadmin with the currently configured password due to the following error:
Logon failure: the user has not been granted the requested logon type at this computer.
 
Service: BlackBerry SyncServer
Domain and account: DOMAIN\besadmin
 
This service account does not have the necessary user right "Log on as a service."
 
User Action
 
Assign "Log on as a service" to the service account on this computer. You can use Local Security Settings (Secpol.msc) to do this. If this computer is a node in a cluster, check that this user right is assigned to the Cluster service account on all nodes in the cluster.
 
If you have already assigned this user right to the service account, and the user right appears to be removed, a Group Policy object associated with this node might be removing the right. Check with your domain administrator to find out if this is happening.


I did check the Local Security Settings and all is good there, however I know that if domain policy is different is wins.  I check the default policy and the besadmin account is not in there.  The Network Admin before me has the Blackberry server in the computers container.  I am in the middle of re-structuring AD but that is a whole other project itself.
Comment
Watch Question

It sounds as if either the password has changed on the Blackberry service account or it is not a local admin on the BES server with right to logon as a service.  Make sure that the services are running as BESAdmin and also if you changed the password to the account make sure you update the services and then try to start them again.  
Commented:
Unlock this solution and get a sample of our free trial.
(No credit card required)
UNLOCK SOLUTION

Author

Commented:
First, thank you both for your help.  The password has not changed and the BesAdmin account is in the local admin group.  One follow up question and if this does not work I may have to create another service account.  If at the domain level in AD, if the group policy does not have the BesAdmin account  log on as a service, would that filter down to the computers container and effect it that way?
It should not make a difference.  You can change it to make sure but I don't think it will matter.  You may want to retype the password in the services and try that but it might be easier to recreate the service account.  
I agree with Umbi & had a very similiar situation and creating a new besadmin (DOMAIN\besadmin2) account fixed it. In my particular situation - an exchange cutover had been done for a client and after moving the besadmin mailbox this all came up. I spent hours troubleshooting BES, permissions, exchange etc. and nothing. I created the new besadmin2 account, re-permissioned everything and about 30min later it was working fine again. The BB Support link Umbi sent you is exactly what is needed. Also, unless you have some really customized group policies you don't have to worry about the logon as a service in this case, I got the same error with the corrupt account.


~ CFJ

Author

Commented:
Thanks again everyone.

Commented:
recreating the account is quite easy and not as daunting as it sounds.

I know i put off doing it for quite a while, and when i finally did it, it was a piece of cake.

If your continuously having blackberry problems a very good resource i use is

http://www.blackberryforums.com/
Unlock the solution to this question.
Thanks for using Experts Exchange.

Please provide your email to receive a sample view!

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.