How to use +mimetype=application/  in ORACLE forms 9i???

Posted on 2007-10-10
Last Modified: 2013-12-19

I created a report with delimiteddata (ORACLE forms and reports and iAS 9i), the report is showed on the preview screen very well, however I found that if I add to the report URL the following characters : +mimetype=application/  on the explorer window , it appears an option to save the file in excel format which is what I really want, the problem is that I added these characters on the form as follows:


it used to be like
WEB.SHOW_DOCUMENT('/reports/rwservlet/getjobid'||substr(lv_report,instr(lv_report,'_',-1)+1)||'?'||'server='||lv_rep_server,'_blank');        --> this works but is not what I need.

What is happening is that if I add the characters for mimetype then the report seems to be opened but suddenly it is closed. (At execution time on the iAS)

If I type directly on the explorer window this:

Then the option to save as excel appears,
Can you please assist me?

Question by:dyanuca
    LVL 47

    Accepted Solution

    Oracle claims that this works:

    User's are running reports through  cgi and there are no problems starting
    automatically into one's browser window.
    Now user need the same feature when using run_report_object() and

    The mimetype=application/, this should be part of the URL that you
     have to submit via web.show_document()
    for eg:
    getjobid'  ||substr(report_job_id,JOB_NUMBER)||'?server=' || server_name ||

    Author Comment


    I asked two co-workers to try the same that I tried last night

    -- code in forms 9i

    This is the result: On their computers the option to save the file is appearing as expected, but, on mine, same status it opens the explorer window for a second and suddenly it is closed.

    This is really weird, any clue on this?

    Diana Sanchez

    Author Comment

    I also noticed that I included the "_blank" option on the web.show_document and the '+' sign.

    This is my try

    This is your example

    Is it making any difference?

    Diana Sanchez
    LVL 47

    Expert Comment

    Possibly it will be a good idea to compare the versions of Jinitiator and Excel you have installed on your box.
    Also the browser version is important.
    I have just tried outside Forms (via browser)
    to run this


    and it runs

    Write Comment

    Please enter a first name

    Please enter a last name

    We will never share this with anyone.

    Featured Post

    Top 6 Sources for Identifying Threat Actor TTPs

    Understanding your enemy is essential. These six sources will help you identify the most popular threat actor tactics, techniques, and procedures (TTPs).

    Suggested Solutions

    How to Create User-Defined Aggregates in Oracle Before we begin creating these things, what are user-defined aggregates?  They are a feature introduced in Oracle 9i that allows a developer to create his or her own functions like "SUM", "AVG", and…
    This post first appeared at Oracleinaction  ( Anju Garg (Myself). I  will demonstrate that undo for DML’s is stored both in undo tablespace and online redo logs. Then, we will analyze the reaso…
    This videos aims to give the viewer a basic demonstration of how a user can query current session information by using the SYS_CONTEXT function
    This video shows how to recover a database from a user managed backup

    737 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    19 Experts available now in Live!

    Get 1:1 Help Now