Pesty Macro Security Warning in Visio 2003 doc just won't go away! Argh!

I'm running Visio 2003 Pro.  I created an empty Macro in a visio doc. Now everytime I open the visio file, I get an annoying Macro security warning. So I delete the macro hoping to get rid of this warning. Nope, it persists. Anyone know how to get rid of the Macro security warning? I would think getting rid of the macros would do it, but no, that would be too easy, wouldn't it?  In fact, if I create even a blank visio, then add a blank empty macro and save the doc, then open it, I'll get this pesty warning. Ok, so then I delete the macro, save it and open it again - I get the warning. Now, I know I can copy/paste everything to a brand new empty visio doc, but in this case, my visio doc is 30 pages big with custom props, a custom shapes sheet and an attachment to a database, so it would be a hassle to do it. If there's a quicker way to get rid of this ridiculous warning, I'd like to know how. Please save me from this Microsoft insanity!
umbasaAsked:
Who is Participating?
 
Scott HelmersConnect With a Mentor Visio Consultant, Trainer, Author, and DeveloperCommented:
umbasa,

The answer to your problem is that deleting a macro through the Visio UI does delete the macro, but it doesn't delete the container that holds macros. Even though the container is empty, it still triggers the macro warning.

The problem is easy to solve.

1) With your drawing open, type ALT+F11, which opens the Visual Basic Editor.

2) In the Project pane in the upper left, expand the folder called "Modules" by clicking on the plus sign to its left.

3) In that folder you'll see an entry called NewMacros if you created your macro with the macro recorder.  If it has a different name, that's not a problem.

4) Right-click on NewMacros and select "Remove NewMacros"

5) In the next dialog, click NO that you don't want to export the macro code before removing it.

6) NewMacros and the Module1 folder should both disappear.

7) Save your drawing.

When you close and reopen your drawing, the macro warning will be gone.

Scott
0
 
Chris BottomleySoftware Quality Lead EngineerCommented:
Useless facts:

2000 - No probs
2002 - Same Issue

If it is the same then I have found that in 2002, deleting everything from thisdocument, (i.e. option explicit as well - I default with it on) removes the warning.

Can't say if it is the same in 2003.

Chris

Chris
0
 
umbasaAuthor Commented:
Not sure what you mean by "option explicit as well"?

And i forgot to mention that this visio is in a company shared folder, so if the solution were to change the security level of the visio app, that would work for just me, as I can't change the security level of everyone's computer's visio app unless I talk to AD folks about a major GPO.
0
Cloud Class® Course: CompTIA Cloud+

The CompTIA Cloud+ Basic training course will teach you about cloud concepts and models, data storage, networking, and network infrastructure.

 
Chris BottomleySoftware Quality Lead EngineerCommented:
At the top of my thisdocument there is some text, doesn't really matter what it is.  Have you deleted all text from this document and any user modules from the environment.

Chris
0
 
Chris BottomleySoftware Quality Lead EngineerCommented:
Umbasa

Any more on the issue?

Chris
0
 
umbasaAuthor Commented:
excellent! I actually had to delete the forms and other various things as well in the macro area. But it worked! Thanks!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.