• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 311
  • Last Modified:

Cannot Access own External Website

Hi,

We are running SBS Std 2003 in a domain environment with DNS running and cannot access our own website which is hosted externally.
Our domain is mycompany.local and our website is mycompany.com.au.

This has only been a recent problem and often when we reboot the Domain controller we can access our site.
When we attempt to access our site, we get a timeout message.

I haven't added a host name 'www' as the domain name to our website has .com.au rather than .local.

Does anyone have any suggestions?

Any help would be greatly appreciated.

Thanks
0
james_daley
Asked:
james_daley
  • 4
  • 4
1 Solution
 
james_daleyAuthor Commented:
When i do a nslookup, here is my results.

Microsoft Windows XP [Version 5.1.2600]
(C) Copyright 1985-2001 Microsoft Corp.

>nslookup www.mybusiness.com.au
Server:  mybusiness.local
Address:  192.168.1.10

Non-authoritative answer:
Name:    www.mybusiness.com.au
Address:  "address of my webserver"
0
 
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
Please post a COMPLETE ipconfig /all from the SBS.

Jeff
TechSoEasy
0
 
james_daleyAuthor Commented:
Microsoft Windows [Version 5.2.3790]
(C) Copyright 1985-2003 Microsoft Corp.

C:\Documents and Settings\Administrator>ipconfig /all

Windows IP Configuration

   Host Name . . . . . . . . . . . . : alpha
   Primary Dns Suffix  . . . . . . . : Mybusiness.local
   Node Type . . . . . . . . . . . . : Unknown
   IP Routing Enabled. . . . . . . . : Yes
   WINS Proxy Enabled. . . . . . . . : Yes
   DNS Suffix Search List. . . . . . : Mybusiness.local

Ethernet adapter Network Connection:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Intel 8255x-based PCI Ethernet Adapter (1
0/100)
   Physical Address. . . . . . . . . : 00-04-23-88-DB-8C
   DHCP Enabled. . . . . . . . . . . : No
   IP Address. . . . . . . . . . . . : 192.168.1.11
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . : 192.168.1.254
   DNS Servers . . . . . . . . . . . : 192.168.1.10
   NetBIOS over Tcpip. . . . . . . . : Disabled

Ethernet adapter Server Local Area Connection:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Intel(R) PRO/1000 MT Network Connection
   Physical Address. . . . . . . . . : 00-04-23-88-D6-48
   DHCP Enabled. . . . . . . . . . . : No
   IP Address. . . . . . . . . . . . : 192.168.1.10
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . : 192.168.1.254
   DNS Servers . . . . . . . . . . . : 192.168.1.10
0
How do you know if your security is working?

Protecting your business doesn’t have to mean sifting through endless alerts and notifications. With WatchGuard Total Security Suite, you can feel confident that your business is secure, meaning you can get back to the things that have been sitting on your to-do list.

 
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
Therein lies your problem.

You need to configure separate IP Subnets for each of the two NICs.  Please refer to http://sbsurl.com/twonics for an example of this.

It's easiest if you change the WAN NIC (Ethernet adapter Network Connection) because your internal DNS is already configured for 192.168.1.10.  This will also require that you modify the router's configuration.  There are also a couple of adjustments to make on the LAN NIC (Ethernet adapter Server Local Area Connection).

First, change your Router's LAN IP to 192.168.200.254.  Then, change the WAN NIC's IP to 192.168.200.11, and the default gateway should be changed to 192.168.200.254.  Leave the DNS Server set as 192.168.1.10.

Then, on the LAN NIC, REMOVE the Gateway entry, and then on the WINS TAB add 192.168.1.10 as the WINS Server.

Finally, rerun the Configure Email and Internet Connection Wizard (CEICW -- linked as "Connect to the Internet on the To-Do list in the Server Management Console)

A visual how-to for that is here:  http://sbsurl.com/ceicw

Jeff
TechSoEasy
0
 
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
FYI, your workstations should be using DHCP supplied by the SBS (not the router) to get all the proper network settings.  If you have DHCP enabled on the router, please disable it and follow the steps outlined at the bottom of http://sbsurl.com/dhcp to restore the service to your SBS.

Jeff
TechSoEasy
0
 
james_daleyAuthor Commented:
Thank you for your help.

Within the next few days (the weekend for me) I'll make these changes and report back to you.

Thanks again,

James Daley
0
 
james_daleyAuthor Commented:
Jeff,

I've made all the changes you specified.  In DNS, should the forwarders be set to the DNS Servers of my ISP, or to the IP of my router; 192.168.200.254?

And for the workstations, the network settings should be:

IP: 192.168.1.xx
Subnet: 255.255.255.0
Gateway: 192.168.1.10
DNS: 192.168.1.10
WINS:192.168.1.10

Is this correct?

Thank you for your help
0
 
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
DNS forwarders should be your ISP's DNS Server IPs.

The workstations should be using DHCP supplied by the SBS for best results.  Set your SBS correctly and your workstations will automatically be configured correctly.

Jeff
TechSoEasy
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: Certified Penetration Testing

This CPTE Certified Penetration Testing Engineer course covers everything you need to know about becoming a Certified Penetration Testing Engineer. Career Path: Professional roles include Ethical Hackers, Security Consultants, System Administrators, and Chief Security Officers.

  • 4
  • 4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now