?
Solved

VPN connection Cisco 5510 ASA site to site

Posted on 2007-10-10
3
Medium Priority
?
600 Views
Last Modified: 2010-04-09
Cisco 5510 ASA device,

I am trying to create a VPN connection at the Cisco Router but it won't allow me to connected from Site to Site.

I have a Linksys RV042 VPN route at the other end.
Public IP: 75.87.230.123
30.30.30.0/24 (255.255.255.0)

Cisco
Public IP: 66.120.127.4
10.0.0.0/26 (255.255.192.0)

MD5 and 3DES
SA life time 25000
phrased key: test
Group 2

Here are my Cisco configurations:

!
ASA Version 8.0(2)
!
hostname ciscoasa
domain-name hbr.ads.inc
enable password 8Ry2YjIyt7RRXU24 encrypted
names
dns-guard
!
interface Ethernet0/0
 description WAN Interface
 nameif Outside
 security-level 0
 ip address 66.120.127.4 255.255.255.192
 ospf cost 10
!
interface Ethernet0/1
 description LAN Interface
 nameif Inside
 security-level 100
 ip address 10.0.0.1 255.255.192.0
 ospf cost 10
!
interface Ethernet0/2
 shutdown
 no nameif
 security-level 0
 no ip address
!
interface Ethernet0/3
 shutdown
 no nameif
 no security-level
 no ip address
!
interface Management0/0
 nameif management
 security-level 100
 ip address 192.168.1.1 255.255.255.0
 ospf cost 10
 management-only
!
passwd 2KFQnbNIdI.2KYOU encrypted
boot system disk0:/asa802-k8.bin
ftp mode passive
clock timezone PST -8
clock summer-time PDT recurring 1 Sun Apr 2:00 last Sun Oct 2:00
dns domain-lookup Outside
dns server-group DefaultDNS
 name-server 68.94.156.1
 name-server 68.94.157.1
 domain-name hbr.ads.inc
object-group service BarracudaLogin tcp
 description 8000
 port-object eq 8000
object-group service ProductionWebsite tcp
 description Production Website
 port-object eq 88
object-group service DSProxy tcp
 description DS Proxy
 port-object eq 6004
object-group service DSStore tcp
 description Store and DS Referal
 port-object eq 6001
 port-object eq 6002
object-group protocol TCPUDP
 protocol-object udp
 protocol-object tcp
object-group service EndPointMapper tcp
 description End Point Mapper
 port-object eq 593
object-group service DM_INLINE_TCP_2 tcp
 group-object DSProxy
 group-object DSStore
 port-object eq pop3
 group-object EndPointMapper
object-group service DM_INLINE_TCP_3 tcp
 group-object BarracudaLogin
 port-object eq domain
 port-object eq smtp
 port-object eq ssh
access-list Outside_access_in extended permit tcp any interface Outside eq pop3
access-list Outside_access_in extended permit tcp any interface Outside eq smtp
access-list Outside_access_in extended permit tcp any interface Outside eq citrix-ica
access-list Outside_access_in extended permit udp any interface Outside eq ntp
access-list Outside_access_in extended permit tcp any interface Outside eq ftp
access-list Outside_access_in extended permit tcp any interface Outside eq https
access-list Outside_access_in extended permit tcp any interface Outside eq domain
access-list Outside_access_in extended permit tcp any interface Outside object-group DSStore
access-list Outside_access_in extended permit tcp any interface Outside object-group BarracudaLogin
access-list Outside_access_in extended permit tcp any interface Outside object-group DSProxy
access-list Outside_access_in extended permit tcp any interface Outside eq pptp
access-list Outside_access_in extended permit tcp any interface Outside object-group ProductionWebsite
access-list Outside_access_in extended permit tcp any interface Outside eq www
access-list Outside_access_in extended permit tcp any interface Outside eq ssh
access-list Inside_nat0_outbound extended permit ip 10.0.0.0 255.255.192.0 10.101.162.0 255.255.255.0
access-list Inside_nat0_outbound extended permit ip 10.0.0.0 255.255.192.0 10.28.57.0 255.255.255.0
access-list Inside_nat0_outbound extended permit ip 10.0.0.0 255.255.192.0 66.120.127.0 255.255.255.192
access-list management_3_cryptomap extended permit ip 10.0.0.0 255.255.192.0 30.30.30.0 255.255.255.0
pager lines 24
logging enable
logging asdm informational
mtu Outside 1500
mtu Inside 1500
mtu management 1500
no failover
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-602.bin
no asdm history enable
arp timeout 14400
global (Outside) 101 interface
nat (Inside) 0 access-list Inside_nat0_outbound
nat (Inside) 101 0.0.0.0 0.0.0.0
static (Inside,Outside) tcp interface pop3 10.0.0.50 pop3 netmask 255.255.255.255
static (Inside,Outside) tcp interface 8000 10.0.0.3 8000 netmask 255.255.255.255
static (Inside,Outside) tcp interface https 10.0.0.50 https netmask 255.255.255.255
static (Inside,Outside) tcp interface citrix-ica 10.0.0.9 citrix-ica netmask 255.255.255.255
static (Inside,Outside) udp interface ntp 10.0.0.3 ntp netmask 255.255.255.255
static (Inside,Outside) tcp interface domain 10.0.0.3 domain netmask 255.255.255.255
static (Inside,Outside) tcp interface ftp 10.0.0.55 ftp netmask 255.255.255.255
static (Inside,Outside) tcp interface smtp 10.0.0.3 smtp netmask 255.255.255.255
static (Inside,Outside) tcp interface 88 10.0.0.55 88 netmask 255.255.255.255
static (Inside,Outside) tcp interface pptp 10.0.0.107 pptp netmask 255.255.255.255
static (Inside,Outside) tcp interface 6002 10.0.0.50 6002 netmask 255.255.255.255
static (Inside,Outside) tcp interface 6001 10.0.0.50 6001 netmask 255.255.255.255
static (Inside,Outside) tcp interface www 10.0.0.50 www netmask 255.255.255.255
static (Inside,Outside) tcp interface 2004 10.0.0.50 2004 netmask 255.255.255.255
static (Inside,Outside) tcp interface ssh 10.0.0.3 ssh netmask 255.255.255.255
access-group Outside_access_in in interface Outside
route Outside 0.0.0.0 0.0.0.0 66.120.127.4 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout uauth 0:05:00 absolute
dynamic-access-policy-record DfltAccessPolicy
http server enable
http 192.168.1.0 255.255.255.0 management
http 10.0.0.0 255.255.192.0 Inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto map management_map 3 match address management_3_cryptomap
crypto map management_map 3 set pfs
crypto map management_map 3 set peer 75.87.230.123
crypto map management_map 3 set transform-set ESP-3DES-MD5
crypto map management_map interface management
crypto isakmp enable management
crypto isakmp policy 10
 authentication pre-share
 encryption des
 hash md5
 group 1
 lifetime 86400
crypto isakmp policy 30
 authentication pre-share
 encryption 3des
 hash md5
 group 1
 lifetime 86400
no crypto isakmp nat-traversal
telnet timeout 5
ssh timeout 5
console timeout 0
management-access Inside
dhcpd address 10.0.1.1-10.0.1.254 Inside
dhcpd dns 68.94.156.1 68.94.157.1 interface Inside
dhcpd wins 10.0.0.54 10.0.0.58 interface Inside
dhcpd enable Inside
!
dhcpd address 192.168.1.2-192.168.1.254 management
dhcpd enable management
!
threat-detection basic-threat
threat-detection statistics
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map global_policy
 class inspection_default
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny  
  inspect sunrpc
  inspect xdmcp
  inspect sip  
  inspect netbios
  inspect tftp
  inspect icmp
!
service-policy global_policy global
tunnel-group 75.87.230.123 type ipsec-l2l
tunnel-group 75.87.230.123 ipsec-attributes
 pre-shared-key *
prompt hostname context
Cryptochecksum:d1bc1a8fac40298811a292c2a686a0fb
0
Comment
Question by:jwjones2000
  • 2
3 Comments
 
LVL 79

Accepted Solution

by:
lrmoore earned 2000 total points
ID: 20055944
I don't see this:
  access-list Inside_nat0_outbound extended permit ip 10.0.0.0 255.255.192.0 30.30.30.0 255.255.255.0

crypto isakmp policy 30
 authentication pre-share
 encryption 3des
 hash md5
 group 1  <== change to group 2 and on the Linksys use 1024bit group setting
lifetime 86400  <== change to match the Linksys end 25000

>crypto isakmp enable management <== change this to outside....
 no crypto isakmp enable management
 crypto isakmp enable outside
0
 

Author Comment

by:jwjones2000
ID: 20061718
This is how it looks: I will do some testing in a minute

ASA Version 8.0(2)
!
hostname ciscoasa
domain-name hbr.ads.inc
enable password 8Ry2YjIyt7RRXU24 encrypted
names
dns-guard
!
interface Ethernet0/0
 description WAN Interface
 nameif Outside
 security-level 0
 ip address 66.120.127.4 255.255.255.192
 ospf cost 10
!
interface Ethernet0/1
 description LAN Interface
 nameif Inside
 security-level 100
 ip address 10.0.0.1 255.255.192.0
 ospf cost 10
!
interface Ethernet0/2
 shutdown
 no nameif
 security-level 0
 no ip address
!
interface Ethernet0/3
 shutdown
 no nameif
 no security-level
 no ip address
!
interface Management0/0
 nameif management
 security-level 100
 ip address 192.168.1.1 255.255.255.0
 ospf cost 10
 management-only
!
passwd 2KFQnbNIdI.2KYOU encrypted
boot system disk0:/asa802-k8.bin
ftp mode passive
clock timezone PST -8
clock summer-time PDT recurring 1 Sun Apr 2:00 last Sun Oct 2:00
dns domain-lookup Outside
dns server-group DefaultDNS
 name-server 68.94.156.1
 name-server 68.94.157.1
 domain-name hbr.ads.inc
object-group service BarracudaLogin tcp
 description 8000
 port-object eq 8000
object-group service ProductionWebsite tcp
 description Production Website
 port-object eq 88
object-group service DSProxy tcp
 description DS Proxy
 port-object eq 6004
object-group service DSStore tcp
 description Store and DS Referal
 port-object eq 6001
 port-object eq 6002
object-group protocol TCPUDP
 protocol-object udp
 protocol-object tcp
object-group service EndPointMapper tcp
 description End Point Mapper
 port-object eq 593
object-group service DM_INLINE_TCP_2 tcp
 group-object DSProxy
 group-object DSStore
 port-object eq pop3
 group-object EndPointMapper
object-group service DM_INLINE_TCP_3 tcp
 group-object BarracudaLogin
 port-object eq domain
 port-object eq smtp
 port-object eq ssh
access-list Outside_access_in extended permit tcp any interface Outside eq pop3
access-list Outside_access_in extended permit tcp any interface Outside eq smtp
access-list Outside_access_in extended permit tcp any interface Outside eq citrix-ica
access-list Outside_access_in extended permit udp any interface Outside eq ntp
access-list Outside_access_in extended permit tcp any interface Outside eq ftp
access-list Outside_access_in extended permit tcp any interface Outside eq https
access-list Outside_access_in extended permit tcp any interface Outside eq domain
access-list Outside_access_in extended permit tcp any interface Outside object-group DSStore
access-list Outside_access_in extended permit tcp any interface Outside object-group BarracudaLogin
access-list Outside_access_in extended permit tcp any interface Outside object-group DSProxy
access-list Outside_access_in extended permit tcp any interface Outside eq pptp
access-list Outside_access_in extended permit tcp any interface Outside object-group ProductionWebsite
access-list Outside_access_in extended permit tcp any interface Outside eq www
access-list Outside_access_in extended permit tcp any interface Outside eq ssh
access-list Inside_nat0_outbound extended permit ip 10.0.0.0 255.255.192.0 10.101.162.0 255.255.255.0
access-list Inside_nat0_outbound extended permit ip 10.0.0.0 255.255.192.0 10.28.57.0 255.255.255.0
access-list Inside_nat0_outbound extended permit ip 10.0.0.0 255.255.192.0 66.120.127.0 255.255.255.192
access-list Inside_nat0_outbound extended permit ip 10.0.0.0 255.255.192.0 30.30.30.0 255.255.255.0
access-list Outside_1_cryptomap extended permit ip 10.0.0.0 255.255.192.0 30.30.30.0 255.255.255.0
pager lines 24
logging enable
logging asdm informational
mtu Outside 1500
mtu Inside 1500
mtu management 1500
no failover
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-602.bin
no asdm history enable
arp timeout 14400
global (Outside) 101 interface
nat (Inside) 0 access-list Inside_nat0_outbound
nat (Inside) 101 0.0.0.0 0.0.0.0
static (Inside,Outside) tcp interface pop3 10.0.0.50 pop3 netmask 255.255.255.255
static (Inside,Outside) tcp interface 8000 10.0.0.3 8000 netmask 255.255.255.255
static (Inside,Outside) tcp interface https 10.0.0.50 https netmask 255.255.255.255
static (Inside,Outside) tcp interface citrix-ica 10.0.0.9 citrix-ica netmask 255.255.255.255
static (Inside,Outside) udp interface ntp 10.0.0.3 ntp netmask 255.255.255.255
static (Inside,Outside) tcp interface domain 10.0.0.3 domain netmask 255.255.255.255
static (Inside,Outside) tcp interface ftp 10.0.0.55 ftp netmask 255.255.255.255
static (Inside,Outside) tcp interface smtp 10.0.0.3 smtp netmask 255.255.255.255
static (Inside,Outside) tcp interface 88 10.0.0.55 88 netmask 255.255.255.255
static (Inside,Outside) tcp interface pptp 10.0.0.107 pptp netmask 255.255.255.255
static (Inside,Outside) tcp interface 6002 10.0.0.50 6002 netmask 255.255.255.255
static (Inside,Outside) tcp interface 6001 10.0.0.50 6001 netmask 255.255.255.255
static (Inside,Outside) tcp interface www 10.0.0.50 www netmask 255.255.255.255
static (Inside,Outside) tcp interface 2004 10.0.0.50 2004 netmask 255.255.255.255
static (Inside,Outside) tcp interface ssh 10.0.0.3 ssh netmask 255.255.255.255
access-group Outside_access_in in interface Outside
route Outside 0.0.0.0 0.0.0.0 66.120.127.4 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout uauth 0:05:00 absolute
dynamic-access-policy-record DfltAccessPolicy
http server enable
http 192.168.1.0 255.255.255.0 management
http 10.0.0.0 255.255.192.0 Inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto map Outside_map 1 match address Outside_1_cryptomap
crypto map Outside_map 1 set peer 75.87.230.123
crypto map Outside_map 1 set transform-set ESP-3DES-MD5
crypto map Outside_map 1 set security-association lifetime kilobytes 86400
crypto map Outside_map 1 set phase1-mode aggressive group1
crypto map Outside_map interface Outside
crypto isakmp enable Outside
crypto isakmp policy 10
 authentication pre-share
 encryption 3des
 hash md5
 group 1
 lifetime 86400
no crypto isakmp nat-traversal
telnet timeout 5
ssh timeout 5
console timeout 0
management-access Inside
dhcpd address 10.0.1.1-10.0.1.254 Inside
dhcpd dns 68.94.156.1 68.94.157.1 interface Inside
dhcpd wins 10.0.0.54 10.0.0.58 interface Inside
dhcpd enable Inside
!
dhcpd address 192.168.1.2-192.168.1.254 management
dhcpd enable management
!
threat-detection basic-threat
threat-detection statistics
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map global_policy
 class inspection_default
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny  
  inspect sunrpc
  inspect xdmcp
  inspect sip  
  inspect netbios
  inspect tftp
  inspect icmp
!
service-policy global_policy global
group-policy DfltGrpPolicy attributes
tunnel-group DefaultL2LGroup ipsec-attributes
 pre-shared-key *
tunnel-group testVPN type ipsec-l2l
tunnel-group testVPN ipsec-attributes
 pre-shared-key *
tunnel-group-map default-group DefaultL2LGroup
prompt hostname context
Cryptochecksum:a2909a4e220d975064883f4f86648fc5
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 20061925
>crypto map Outside_map 1 set phase1-mode aggressive group1
You might want to remove this if it is not working as you expect.
0

Featured Post

NFR key for Veeam Agent for Linux

Veeam is happy to provide a free NFR license for one year.  It allows for the non‑production use and valid for five workstations and two servers. Veeam Agent for Linux is a simple backup tool for your Linux installations, both on‑premises and in the public cloud.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article is in regards to the Cisco QSFP-4SFP10G-CU1M cables, which are designed to uplink/downlink 40GB ports to 10GB SFP ports. I recently experienced this and found very little configuration documentation on how these are supposed to be confi…
In this article, the configuration steps in Zabbix to monitor devices via SNMP will be discussed with some real examples on Cisco Router/Switch, Catalyst Switch, NAS Synology device.
Windows 10 is mostly good. However the one thing that annoys me is how many clicks you have to do to dial a VPN connection. You have to go to settings from the start menu, (2 clicks), Network and Internet (1 click), Click VPN (another click) then fi…
Both in life and business – not all partnerships are created equal. As the demand for cloud services increases, so do the number of self-proclaimed cloud partners. Asking the right questions up front in the partnership, will enable both parties …
Suggested Courses

850 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question