Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1279
  • Last Modified:

Advent laptop not powering up

I have an Advent 7081 laptop, presumably bought at PC World a few years ago. Owner can't afford a replacement so is asking for a fix. When powered up the mains indicator light on the laptop lights breifly, the CPU fan spins for a few seconds, then stops, the DVD access light illuminates and then blinks continuously. Apart from that - nothing.
I've tested the output voltage from the adapter and it is corrected.
I've tried removing all plug-in components - HDD, RAM ,DVD - no diffrence.
Once when I tried, the display shoed the intel Celeron symbol, but then that faded out and it stopped again.

I suspect - CPU or motherboard or maybe CMOS battery - could it be that??

Please advise how to diagnose or any other thoughts. I don't have spare components to swap out.
0
ComputerFundi
Asked:
ComputerFundi
2 Solutions
 
Arthur_MinoCommented:
G'day,

Does not sound good. If it was the BIOS battery it should still boot.

To be honest I would make it very clear to the owner that you'll try to fix it but it'll be at their expense before you waist any time on it.
Now if you have time, I would pull the whole thing apart and try to run it, see if you can troubleshoot the problem.

Try to turn it on with no HDD, no CD/DVD drive, with different memory modules, in different banks. Flex the board a little.

Hope this helps,

Cheers,

Arthur
0
 
MarkCommented:
You may have a overheating issue. Remove the heatsink from the CPU, clean off the old heatsink compound, put new compound on and reassemble the heatsink.
0
 
ridCommented:
The AC adapter may be bad; it can yield good voltage when not connected to a load (a voltmeter is not a "load" in this context), but fold when connected to the laptop.

Do you get battery charge indication?
/RD
0
 
nobusCommented:
when you boot with hdd, cd and ram removed, does it beep? if not it is a cpu / mobo problem.
the only thing you can do is to remove the cpu, inspect the pins, and reseat it properly - apply some heat paste too.
>>  Once when I tried, the display shoed the intel Celeron symbol, but then that faded out   <<   this can point to a backlight problem, or the power diminues slowly.
you can also try this : with the power and battery removed, hold the power button for 30 sec.
Then put in battery or AC adaptor, and try booting.
alternatively, you can try to reset the bios, by taking out the battery - if possible
btw - i have had systems that would NOT boot when the bios battery was dead
0
 
Computer101Commented:
Forced accept.

Computer101
EE Admin
0

Featured Post

Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now