[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 3703
  • Last Modified:

Allow NTP from two servers to internal network devices through ASA

Hello,

I'm configuring some Cisco Catalyst Switches (one 3548XL and three 2924M-XL's running 12.0(5)WC17 code) on my internal network to use Network Time Protocol for their clocks.  I've entered the commands on the switches (see commands below ASA config) and I thought the switches would periodically go out through the ASA to the NTP servers on the Internet and the return traffic would be allowed back to the switches from the NTP servers.  UDP is connectionless, so I can see why that probably won't work.

I'd like to allow the traffic in the most secure manner possible.  If I have to permit NTP inbound, I'd like to limit the traffic so it must come from the two NTP servers only.  I'd also like the traffic inspected to make sure it is actually NTP protocol, and isn't spoofed or tampered with.  Any help would be greatly appreciated.

Another option may be to have the ASA be my NTP server?

PIX Config:

show run
: Saved
:
ASA Version 7.2(3)
!
hostname firewall
domain-name abc-co.com
enable password [deleted] encrypted
names
dns-guard
!
interface Ethernet0/0
 description Internet Interface
 speed 10
 duplex half
 nameif Outside
 security-level 0
 ip address 1.1.1.2 255.255.255.252
!
interface Ethernet0/1
 description Inside LAN Interface
 nameif Inside
 security-level 100
 ip address 192.168.1.1 255.255.255.0
!
interface Ethernet0/2
description DMZ Interface for future use.
 shutdown
 nameif DMZ
 security-level 5
 ip address 10.0.0.1 255.255.255.0
!
interface Ethernet0/3
 shutdown
 no nameif
 no security-level
 no ip address
!
interface Management0/0
 nameif management
 security-level 100
 ip address 192.168.101.1 255.255.255.0
 management-only
!
passwd [deleted] encrypted
boot system disk0:/asa723-k8.bin
ftp mode passive
clock timezone EST -5
clock summer-time EDT recurring
dns server-group DefaultDNS
domain-name abc-co.com
same-security-traffic permit intra-interface
access-list management_nat0_outbound extended permit ip any 192.168.1.32 255.255
.255.224
access-list Inside_nat0_outbound extended permit ip 192.168.1.0 255.255.255.0 19
2.168.2.0 255.255.255.0
access-list Outside-Inward extended permit tcp any interface Outside eq smtp
pager lines 24
logging enable
logging timestamp
logging list vpnUser level warnings class vpnc
logging list vpnIPSec level notifications class vpn
logging list sysMsgs level errors class sys
logging list idsMsgs level errors class ids
logging buffer-size 16384
logging trap notifications
logging asdm informational
logging host Inside 192.168.1.7
logging permit-hostdown
logging class auth trap notifications
logging class vpn trap informational
logging class vpnc trap informational
mtu Outside 1500
mtu Inside 1500
mtu DMZ 1500
mtu management 1500
ip local pool VPN-IP-POOL 192.168.2.1-192.168.2.254 mask 255.255.255.0
ip verify reverse-path interface Outside
ip verify reverse-path interface Inside
ip verify reverse-path interface DMZ
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-523.bin
no asdm history enable
arp timeout 14400
global (Outside) 1 interface
nat (Outside) 1 192.168.2.0 255.255.255.0
nat (Inside) 0 access-list Inside_nat0_outbound
nat (Inside) 1 0.0.0.0 0.0.0.0
nat (management) 0 access-list management_nat0_outbound
static (Inside,Outside) tcp interface smtp 192.168.1.6 smtp netmask 255.255.255.
255
access-group Outside-Inward in interface Outside
route Outside 0.0.0.0 0.0.0.0 1.1.1.3 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout uauth 0:05:00 absolute
aaa-server InternalAuth protocol radius
aaa-server InternalAuth host 192.168.1.7
 key [deleted]
aaa authentication enable console LOCAL
aaa authentication serial console LOCAL
aaa authentication http console InternalAuth LOCAL
aaa authentication ssh console InternalAuth LOCAL
aaa authorization command LOCAL
aaa local authentication attempts max-fail 10
http server enable
http 192.168.101.0 255.255.255.0 management
http 192.168.1.0 255.255.255.0 Inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto dynamic-map Outside_dyn_map 40 set pfs
crypto dynamic-map Outside_dyn_map 40 set transform-set ESP-3DES-SHA
crypto map Outside_map 65535 ipsec-isakmp dynamic Outside_dyn_map
crypto map Outside_map interface Outside
crypto ca trustpoint adc01
 revocation-check crl none
 enrollment terminal
 subject-name CN=firewall.abc-co.com,O=abc-co.com,C=US,St=New York,L
=Small Town
 crl configure
crypto isakmp identity hostname
crypto isakmp enable Outside
crypto isakmp policy 30
 authentication pre-share
 encryption 3des
 hash sha
 group 2
 lifetime 86400
crypto isakmp disconnect-notify
telnet timeout 5
ssh scopy enable
ssh 192.168.1.0 255.255.255.0 Inside
ssh timeout 60
ssh version 2
console timeout 0
management-access Inside
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns migrated_dns_map_1
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns migrated_dns_map_1
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny
  inspect sunrpc
  inspect xdmcp
  inspect sip
  inspect netbios
  inspect tftp
  inspect http
!
service-policy global_policy global
ntp server 128.59.59.177 source Outside prefer
ntp server 66.250.45.2 source Outside
group-policy VPN1 internal
group-policy VPN1 attributes
 wins-server value 192.168.1.7
 dns-server value 192.168.1.7 192.168.1.6
 vpn-tunnel-protocol IPSec
 default-domain value abc-co.com
username [deleted] password [deleted] encrypted privilege 15
tunnel-group VPN1 type ipsec-ra
tunnel-group VPN1 general-attributes
 address-pool VPN-IP-POOL
 authentication-server-group InternalAuth
 default-group-policy VPN1
tunnel-group VPN1 ipsec-attributes
 pre-shared-key *
privilege cmd level 3 mode exec command perfmon
privilege cmd level 3 mode exec command ping
privilege cmd level 3 mode exec command who
privilege cmd level 3 mode exec command logging
privilege cmd level 3 mode exec command failover
privilege cmd level 3 mode exec command vpn-sessiondb
privilege show level 5 mode exec command running-config
privilege show level 3 mode exec command reload
privilege show level 3 mode exec command mode
privilege show level 3 mode exec command firewall
privilege show level 3 mode exec command interface
privilege show level 3 mode exec command clock
privilege show level 3 mode exec command dns-hosts
privilege show level 3 mode exec command access-list
privilege show level 3 mode exec command logging
privilege show level 3 mode exec command ip
privilege show level 3 mode exec command failover
privilege show level 3 mode exec command asdm
privilege show level 3 mode exec command arp
privilege show level 3 mode exec command route
privilege show level 3 mode exec command ospf
privilege show level 3 mode exec command aaa-server
privilege show level 3 mode exec command aaa
privilege show level 3 mode exec command crypto
privilege show level 3 mode exec command vpn-sessiondb
privilege show level 3 mode exec command ssh
privilege show level 3 mode exec command dhcpd
privilege show level 3 mode exec command vpn
privilege show level 3 mode exec command blocks
privilege show level 3 mode exec command uauth
privilege show level 3 mode configure command interface
privilege show level 3 mode configure command clock
privilege show level 3 mode configure command access-list
privilege show level 3 mode configure command logging
privilege show level 3 mode configure command ip
privilege show level 3 mode configure command failover
privilege show level 5 mode configure command asdm
privilege show level 3 mode configure command arp
privilege show level 3 mode configure command route
privilege show level 3 mode configure command aaa-server
privilege show level 3 mode configure command aaa
privilege show level 3 mode configure command crypto
privilege show level 3 mode configure command vpn-sessiondb
privilege show level 3 mode configure command ssh
privilege show level 3 mode configure command dhcpd
privilege show level 5 mode configure command privilege
privilege clear level 3 mode exec command dns-hosts
privilege clear level 3 mode exec command logging
privilege clear level 3 mode exec command arp
privilege clear level 3 mode exec command aaa-server
privilege clear level 3 mode exec command crypto
privilege cmd level 3 mode configure command failover
privilege clear level 3 mode configure command logging
privilege clear level 3 mode configure command arp
privilege clear level 3 mode configure command crypto
privilege clear level 3 mode configure command aaa-server
prompt hostname context
Cryptochecksum:[deleted]
: end
firewall#

Switch NTP Commands and results:

!
clock timezone EST -5
clock summer-time EDT recurring
!
!
ntp server 128.59.59.177 source FastEthernet0/37 prefer
ntp server 66.250.45.2 source FastEthernet0/37
end

NTP Sync Info:

Master-Switch#show ntp stat
Clock is unsynchronized, stratum 16, no reference clock
nominal freq is 381.4697 Hz, actual freq is 381.4697 Hz, precision is 2**17
reference time is 00000000.00000000 (19:00:00.000 EST Thu Dec 31 1899)
clock offset is 0.0000 msec, root delay is 0.00 msec
root dispersion is 0.00 msec, peer dispersion is 0.00 msec
Master-Switch#show ntp ?
  associations  NTP associations
  status        NTP status

Master-Switch#show ntp asso

      address         ref clock     st  when  poll reach  delay  offset    disp
 ~128.59.59.177    0.0.0.0          16     -    64    0     0.0    0.00  16000.
 ~66.250.45.2      0.0.0.0          16     -    64    0     0.0    0.00  16000.
 * master (synced), # master (unsynced), + selected, - candidate, ~ configured
Master-Switch#
0
Sma11T0wnITGuy
Asked:
Sma11T0wnITGuy
1 Solution
 
lrmooreCommented:
It should work no problem. DNS is also UDP and it works. NTP is the same way.
Did you set the proper default gateway on your switches?
0
 
Sma11T0wnITGuyAuthor Commented:
You've got to be kidding!  How embarrassing.  Thanks lrmoore, that's all it was!

Ted
0

Featured Post

Exciting career futures for women in IT

Education has the power to transform lives and open the door to new career opportunities. By earning an IT degree from WGU, you can become a highly skilled IT professional. Get the credentials and certifications you need to become a leader in this rewarding field.  

Tackle projects and never again get stuck behind a technical roadblock.
Join Now