Cant get ANY NIC / network card to work with brand new HP PC

Hi guys im having one hell of a frustrating problem.

I have bought a brand new HP dx2250 business desktop pc for a client.
It has XP pro and onboard realtek network card.

The problem is after switching the pc on and validating with microsoft the onboard network card refused to work. I tried download drivers and installing with those but after restarting it tries to get ip and then cant and shows limited connectivity error.

I have tried 2 definietely working nics in the pc's PCI slot. Neither worked.
It detects an Ethernet controller and also PCI device but when i try to install with the correct drivers neither work.
I had also switched off onboard LAN before trying the PCI cards.

I tried installing all 3 nics using there own drivers and also windows/system32 and windows/system32/drivers.

Im really at a loss as to why this pcs refuses to have a working nic.
Does anyone have any ideas?

Cheers,
AR
drews1fAsked:
Who is Participating?
 
drews1fConnect With a Mentor Author Commented:
nope i ended up having to get a usb network card! that worked straight away.
0
 
skree358Commented:
Have you tried working in safe mode with networking? I think the problem could be with the firewall or antivirus software. You may try disabling or uninstalling this. See if it works. Hope this helps.
0
 
johnb6767Commented:
Do you even get an IP Address?
0
Protect Your Employees from Wi-Fi Threats

As Wi-Fi growth and popularity continues to climb, not everyone understands the risks that come with connecting to public Wi-Fi or even offering Wi-Fi to employees, visitors and guests. Download the resource kit to make sure your safe wherever business takes you!

 
willcompCommented:
Also try resetting Windows Sockets:
http://www.majorgeeks.com/download4372.html
0
 
drews1fAuthor Commented:
thansk for your responses.

I uninstalled the NIC in the hardware monitor and then restarted my pc.

Went into BIOS and reactivated the onboard NIC. saved a restarted.

Went into safe mode with networking and installed drivers for both realtek 8100 onboard and also
belkin F5D5000.
restarted and plugged both nics in one at a time.

Both attempted to get an ip before failing and saying limited or no activity.
Both went straight to network cable unplugged when i removed the cable so i presume the system and drivers are working correctly?

I weill now try the winsock fix.

AR
0
 
drews1fAuthor Commented:
winsock fix made no difference.

When i plug a cable in it tries to assign an ip for ages then says limited or no connectivity.

in net conn details it says:

ip: 169.254.70.217
subnet 255.255.0.0
everythign else blank


it is the same for both nics :(
except on nic #2 the ip is: 169.254.233.178


anyone got any other ideas?
AR
0
 
jholland79Commented:
Hi there,
It seems that the NICs have installed correctly, but the problem is with the IP address settings. Are you using a DHCP server on this network?
Also, have you tried connecting a different PC to that cable, connecting that PC with a different cable and into a different socket?
If a different PC works ok, type ipconfig /all at a command prompt and let us know what it says for DHCP enabled.
John.
0
 
johnb6767Commented:
Have you tried with only 1 NIC at a time?
0
 
drews1fAuthor Commented:
im plugging the pc into a small business network with DHCP from a win2k3 SBS.
there are around 20 other pcs connected and DHCP is working fine.
Ive changed the cable for another and tried both cables with other machines and they seem to work quite happilly.

With no cable in either NIC this is what i got from ipconfig /all


Windows IP COnfiguration

Host name... pc
primary dns suffix...
node type... Unknown
IP Routing enabled... No
WINS Proxy enabled... No

Ethernet adapter local area connection 7:
media state... media disconnected
description... Realtek RTL8139/810x Family Fast ethernet nic
physical address... 00-19-CB-8D-56-8A

Ethernet adapter local area connection 8:
media state... media disconnected
description... F5D5000, PCI Card/Desktop Network PCI Card
physical address... 00-10-B5-10-3D-AE
0
 
willcompCommented:
Do as jholland79 recommended. DHCP server may not be providing addresses. Are you using a "home" type router such as Linksys?
0
 
drews1fAuthor Commented:
When i plugged in the realtek card i got this from ipconfig /all

everything was the same except:

Ethernet adapter Local Area Connection 7:

Connection-specific DNS Suffix...
description... Realtek RTL8139/810x Family Fast ethernet nic
physical address... 00-19-CB-8D-56-8A
Dhcp Enabled... Yes
Autoconfiguration Enabled... Yes
Autoconfiguration IP Address... 169.254.233.178
Subnet Mask... 255.255.0.0
Default Gateway...
0
 
willcompCommented:
Do you have another PC on network to check? What router are you using?
0
 
johnb6767Commented:
Did you get a chance to test with only 1 NIC installed at a time?
0
 
SysExpertCommented:
The 169.x.x. address means it can not get a DHCP address.

try doing

ipconfig /renew on another computer and se if their are issues.

Did you check the DHCP server to see if it has enough addresses ?

have you tested this computer at another location, preferably with just the normal NIC ?

I hope this helps !
0
 
noelcCommented:
Did you ever get this fixed I am having the same issue. I have decided to format the drive and start again.
0
 
ONyonCommented:
I am having the same problem . I believe it is the network controller embedded in the chipset.
The PC doen't recognise the NIC i have to manually assign a driver to it. why?
0
 
noelcCommented:
I had the same issue, tried all the ipconfig commands etc, tried formatting and starting again. in the end it was a faulty motherboard under warranty
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.