• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 4978
  • Last Modified:

Error when invoking webservice from a java application in RAD V7.1

In RAD V7.1 with WAS 6.1 as my server,
I get an error when I try to run my webservice client as a stand alone java application. I generate the client proxy using RAD and it works when I test it from a jsp program. However when I use the exact same code from a java program, the following happens:
Oct 11, 2007 11:39:10 AM com.ibm.ws.naming.java.javaURLContextFactory
SEVERE: javaAccessorNotSet
Exception in thread "main" java.lang.NoClassDefFoundError: org.eclipse.core.runtime.CoreException
      at java.lang.J9VMInternals.verifyImpl(Native Method)
      at java.lang.J9VMInternals.verify(J9VMInternals.java:59)
      at java.lang.J9VMInternals.initialize(J9VMInternals.java:120)
      at com.ibm.ws.webservices.multiprotocol.discovery.ServiceProviderManager.getDiscoveredServiceProviders(ServiceProviderManager.java:378)
      at com.ibm.ws.webservices.multiprotocol.discovery.ServiceProviderManager.getAllServiceProviders(ServiceProviderManager.java:214)
      at com.ibm.ws.webservices.multiprotocol.discovery.ServiceProviderManager.getSupportingServiceProvider(ServiceProviderManager.java:400)
      at com.ibm.ws.webservices.multiprotocol.discovery.ServiceProviderManager.getServiceProvider(ServiceProviderManager.java:241)
      at com.ibm.ws.webservices.multiprotocol.utils.ServiceManager.discoverServiceForNamespace(ServiceManager.java:167)
      at com.ibm.ws.webservices.multiprotocol.utils.ServiceManager.getServiceForNamespace(ServiceManager.java:103)
      at com.ibm.ws.webservices.multiprotocol.AgnosticService.getGeneratedStub(AgnosticService.java:525)
      at com.ibm.ws.webservices.multiprotocol.AgnosticService.doGetPort(AgnosticService.java:462)
      at com.ibm.ws.webservices.multiprotocol.AgnosticService.getStub(AgnosticService.java:405)
      at DEMO.DemoWebServiceServiceLocator.getDemoWebService(DemoWebServiceServiceLocator.java:68)
      at DEMO.DemoWebServiceServiceLocator.getDemoWebService(DemoWebServiceServiceLocator.java:63)
      at DEMO.DemoWebServiceProxy._initDemoWebServiceProxy(DemoWebServiceProxy.java:24)
      at DEMO.DemoWebServiceProxy.<init>(DemoWebServiceProxy.java:9)
      at DEMO.TestMes.main(TestMes.java:10)
0
soumyaraghavan
Asked:
soumyaraghavan
1 Solution
 
msmolyakCommented:
Look at this link

http://www.ibm.com/developerworks/forums/dw_thread.jsp?message=13997909&cat=24&thread=144425&treeDisplayType=threadmode1&forum=430#13997909

The class org.eclipse.core.runtime.CoreException is in runtime.jar. Try adding it to the classpath of your client program.

Michael
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: Certified Penetration Testing

This CPTE Certified Penetration Testing Engineer course covers everything you need to know about becoming a Certified Penetration Testing Engineer. Career Path: Professional roles include Ethical Hackers, Security Consultants, System Administrators, and Chief Security Officers.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now