Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
?
Solved

Cisco PIX 501 cannot establish tunnel with peer - VPN Peer:ISAKMP: Peer Info for x.x.x.x/500 not found - peers:0

Posted on 2007-10-11
13
Medium Priority
?
2,607 Views
Last Modified: 2013-11-16
I have a PIX 501 that was working great. The tunnel dropped and it will not reconnect to the peer. There have been no changes to this PIX or the remote PIX(peer). The error I am getting when I do a debug is:

VPN Peer:ISAKMP: Peer Info for  x.x.x.x/500 not found - peers:0.

ISAKMP (0): Total payload length: 12\par
return status is IKMP_NO_ERROR\par
ISAKMP (0): retransmitting phase 1 (0)...\par
ISAKMP (0): retransmitting phase 1 (1)...\par
ISAKMP (0): retransmitting phase 1 (2)...\par
ISAKMP (0): retransmitting phase 1 (3)...\par
ISAKMP (0): retransmitting phase 1 (4)...\par
ISAKMP (0): deleting SA: src 192.168.50.1, dst ISAKMP (0): Total payload length: 12\par
return status is IKMP_NO_ERROR\par
ISAKMP (0): retransmitting phase 1 (0)...\par
ISAKMP (0): retransmitting phase 1 (1)...\par
ISAKMP (0): retransmitting phase 1 (2)...\par
ISAKMP (0): retransmitting phase 1 (3)...\par
ISAKMP (0): retransmitting phase 1 (4)...\par
ISAKMP (0): deleting SA: src 192.168.50.1, dst  x.x.x.x\par
ISADB: reaper checking SA 0xac591c, conn_id = 0  DELETE IT!\par
\par
VPN Peer:ISAKMP: Peer Info for  x.x.x.x/500 not found - peers:0\par\par
ISADB: reaper checking SA 0xac591c, conn_id = 0  DELETE IT!\par

Any help on this would be great. Thanks
0
Comment
Question by:valicon
  • 7
  • 6
13 Comments
 
LVL 36

Expert Comment

by:grblades
ID: 20059523
Can you post your current configuration.
0
 
LVL 12

Author Comment

by:valicon
ID: 20059666
Here is the config:

PIX Version 6.3(5)
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password k4HlcGX2lC1ypFOm encrypted
passwd y5Nu/Nt1/5dK8Iuf encrypted
hostname m100
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list permit-in permit icmp any any echo-reply
access-list permit-in permit icmp any any echo
access-list encrypt permit ip 172.16.40.0 255.255.255.0 any
access-list no-encrypt permit ip 172.16.40.0 255.255.255.0 any
pager lines 24
logging timestamp
logging trap debugging
logging host inside 172.16.40.2
logging host inside 172.16.40.1
mtu outside 1500
mtu inside 1500
ip address outside 192.168.50.1 255.255.255.0
ip address inside 172.16.40.254 255.255.0.0
ip audit info action alarm
ip audit attack action alarm
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list no-encrypt
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
access-group permit-in in interface outside
route outside 0.0.0.0 0.0.0.0 192.168.50.254 1
route outside 172.16.33.0 255.255.255.0 x.x.x.x 1
route outside 192.168.5.0 255.255.255.0 x.x.x.x 1
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout sip-disconnect 0:02:00 sip-invite 0:03:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
sysopt ipsec pl-compatible
crypto ipsec transform-set ch-strong esp-3des esp-sha-hmac
crypto map ch-vpn 10 ipsec-isakmp
crypto map ch-vpn 10 match address encrypt
crypto map ch-vpn 10 set peer x.x.x.x
crypto map ch-vpn 10 set transform-set ch-strong
crypto map ch-vpn interface outside
isakmp enable outside
isakmp key ******** address x.x.x.x netmask 255.255.255.255
isakmp identity address
isakmp policy 10 authentication pre-share
isakmp policy 10 encryption aes
isakmp policy 10 hash sha
isakmp policy 10 group 2
isakmp policy 10 lifetime 86400
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd address 172.16.40.1-172.16.40.10 inside
dhcpd lease 3600
dhcpd ping_timeout 750
dhcpd auto_config outside
dhcpd enable inside
terminal width 80
Cryptochecksum:41bff60761e4af01079b4093a0ce87b1
0
 
LVL 36

Expert Comment

by:grblades
ID: 20059715
> crypto ipsec transform-set ch-strong esp-3des esp-sha-hmac
You have the VPN set to use 3des encryption

> isakmp policy 10 encryption aes
however the only isakmp policy you have is for aes.

Check what the other end is configured to use and then correct one of the above two lines as appropiate so that it matches the remote end.
0
Prepare for an Exciting Career in Cybersecurity

Help prevent cyber-threats and provide solutions to safeguard our global digital economy. Earn your MS in Cybersecurity. WGU’s MSCSIA degree program curriculum features two internationally recognized certifications from the EC-Council at no additional time or cost.

 
LVL 12

Author Comment

by:valicon
ID: 20059766
The other side has both:

crypto ipsec transform-set ch-strong esp-3des esp-sha-hmac

isakmp policy 10 encryption aes


0
 
LVL 12

Author Comment

by:valicon
ID: 20059812
The other side also has 4 additional peers working fine.
0
 
LVL 36

Expert Comment

by:grblades
ID: 20059828
Can you post the configuration of the other end aswell.
0
 
LVL 12

Author Comment

by:valicon
ID: 20060079
The other end:

PIX Version 6.3(3)
interface ethernet0 auto
interface ethernet1 auto
interface ethernet2 auto shutdown
nameif ethernet0 outside security0
nameif ethernet1 inside security100
nameif ethernet2 dmz security10
enable password k4HlcGX2lC1ypFOm encrypted
passwd y5Nu/Nt1/5dK8Iuf encrypted
hostname fw-bs
domain-name xxxxxxxxxxxxxxxxxxx
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554]
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list permit-in permit tcp host  x.x.x.x host x.x.x.x eq 2050
access-list permit-in permit tcp host  x.x.x.x host  x.x.x.x eq 2050
access-list permit-in permit tcp host  x.x.x.x host  x.x.x.x eq 50
access-list permit-in permit tcp host  x.x.x.x host  x.x.x.x eq 500
access-list permit-in permit tcp host  x.x.x.x host  x.x.x.x eq 2052
access-list permit-in permit tcp host x.x.x.x host  x.x.x.x eq 2053
access-list permit-in permit tcp host  x.x.x.x host  x.x.x.x eq 2052
access-list permit-in permit tcp host  x.x.x.x host  x.x.x.x eq 2053
access-list permit-in permit udp any host  x.x.x.x eq 5008
access-list permit-in permit tcp any host x.x.x.x eq www
access-list encrypt-cp permit ip any 172.16.35.0 255.255.255.0
access-list no-encrypt permit ip any 172.16.35.0 255.255.255.0
access-list no-encrypt permit ip any 172.16.36.0 255.255.255.0
access-list no-encrypt permit ip any 172.16.38.0 255.255.255.0
access-list no-encrypt permit ip any 172.16.39.0 255.255.255.0
access-list no-encrypt permit ip any 172.16.40.0 255.255.255.0
access-list encrypt-boa permit ip any 172.16.36.0 255.255.255.0
access-list encrypt-sv permit ip any 172.16.38.0 255.255.255.0
access-list encrypt-ss permit ip any 172.16.39.0 255.255.255.0
access-list encrypt-bam permit ip any 172.16.40.0 255.255.255.0
pager lines 24
logging timestamp
logging trap debugging
logging host inside 10.10.10.1
logging host inside 192.168.5.215
mtu outside 1500
mtu inside 1500
mtu dmz 1500
ip address outside  x.x.x.x 255.255.255.0
ip address inside 172.16.33.254 255.255.255.0
ip address dmz 127.0.0.1 255.255.255.255
ip audit info action alarm
ip audit attack action alarm
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list no-encrypt
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
static (inside,outside) x.x.x.x 192.168.5.15 netmask 255.255.255.255 0 0
static (inside,outside)  x.x.x.x 192.168.5.27 netmask 255.255.255.255 0 0
static (inside,outside)  x.x.x.x 192.168.5.35 netmask 255.255.255.255 0 0
access-group permit-in in interface outside
route inside 0.0.0.0 0.0.0.0 172.16.33.253 1
route outside x.x.x.x 255.255.255.255  x.x.x.x 1
route outside x.x.x.x 255.255.255.255  x.x.x.x 1
route outside x.x.x.x 255.255.255.255  x.x.x.x 1
route outside  x.x.x.x 255.255.255.255 x.x.x.x 1
route outside x.x.x.x 255.255.0.0  x.x.x.x 1
route outside x.x.x.x 255.255.0.0  x.x.x.x 1
route outside x.x.x.x 255.255.0.0  x.x.x.x 1
route outside x.x.x.x 255.255.0.0  x.x.x.x 1
route outside  x.x.x.x 255.255.255.255  x.x.x.x 1
route outside  x.x.x.x 255.255.0.0 x.x.x.x 1
route outside x.x.x.x 255.255.255.255 x.x.x.x 1
route inside 172.16.0.0 255.255.0.0 172.16.33.253 1
route outside 172.16.35.0 255.255.255.0  x.x.x.x 1
route outside 172.16.36.0 255.255.255.0  x.x.x.x 1
route outside 172.16.38.0 255.255.255.0  x.x.x.x 1
route outside 172.16.39.0 255.255.255.0  x.x.x.x 1
route outside 172.16.40.0 255.255.255.0  x.x.x.x 1
route inside 192.168.1.0 255.255.255.0 172.16.33.253 1
route inside 192.168.5.0 255.255.255.0 172.16.33.253 1
route outside x.x.x.x 255.255.255.255  x.x.x.x 1
route outside x.x.x.x 255.255.255.255  x.x.x.x 1
route outside  x.x.x.x 255.255.255.255 x.x.x.x 1
route outside  x.x.x.x 255.255.255.255  x.x.x.x 1
route outside  x.x.x.x 255.255.255.255 x.x.x.x 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
aaa-server LOCAL protocol local
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
sysopt ipsec pl-compatible
crypto ipsec transform-set ch-strong esp-3des esp-sha-hmac
crypto map ch-vpn 10 ipsec-isakmp
crypto map ch-vpn 10 match address encrypt-cop
crypto map ch-vpn 10 set peer  x.x.x.x
crypto map ch-vpn 10 set transform-set ch-strong
crypto map ch-vpn 20 ipsec-isakmp
crypto map ch-vpn 20 match address encrypt-boa
crypto map ch-vpn 20 set peer x.x.x.x
crypto map ch-vpn 20 set transform-set ch-strong
crypto map ch-vpn 30 ipsec-isakmp
crypto map ch-vpn 30 match address encrypt-sv
crypto map ch-vpn 30 set peer  x.x.x.x
crypto map ch-vpn 30 set transform-set ch-strong
crypto map ch-vpn 40 ipsec-isakmp
crypto map ch-vpn 40 match address encrypt-ss
crypto map ch-vpn 40 set peer x.x.x.x
crypto map ch-vpn 40 set transform-set ch-strong
crypto map ch-vpn 50 ipsec-isakmp
crypto map ch-vpn 50 match address encrypt-bam
crypto map ch-vpn 50 set peer  x.x.x.x
crypto map ch-vpn 50 set transform-set ch-strong
crypto map chd-vpn interface outside
isakmp enable outside
isakmp key ******** address  x.x.x.x netmask 255.255.255.255
isakmp key ******** address x.x.x.x netmask 255.255.255.255
isakmp key ******** address  x.x.x.x netmask 255.255.255.255
isakmp key ******** address  x.x.x.x netmask 255.255.255.255
isakmp key ******** address  x.x.x.x netmask 255.255.255.255
isakmp identity address
isakmp policy 10 authentication pre-share
isakmp policy 10 encryption aes
isakmp policy 10 hash sha
isakmp policy 10 group 2
isakmp policy 10 lifetime 86400
telnet 192.168.5.0 255.255.255.0 inside
telnet 172.16.33.0 255.255.255.0 inside
telnet timeout 5
ssh 0.0.0.0 0.0.0.0 outside
ssh timeout 5
console timeout 0
terminal width 80
Cryptochecksum:efc7dc224949e0ef46b2213454ca05e0
0
 
LVL 36

Accepted Solution

by:
grblades earned 2000 total points
ID: 20060435
I dont understand why it would have worked to start with unless some configuration was previous removed and it only took effect when the vpn went down and needed to be re-established.

Anyway adding the following configuration to both ends will give it an additional isakmp policy that it will accept and this matches the crypto you have specified for the vpn.

isakmp policy 20 authentication pre-share
isakmp policy 20 encryption 3des
isakmp policy 20 hash sha
isakmp policy 20 group 2
isakmp policy 20 lifetime 86400

0
 
LVL 12

Author Comment

by:valicon
ID: 20060468
I agree, it is very strange. It worked for quite some time and then stopped working.

isakmp policy 20 authentication pre-share
isakmp policy 20 encryption 3des
isakmp policy 20 hash sha
isakmp policy 20 group 2
isakmp policy 20 lifetime 86400


Will the lines above affect any of the other PIXs?
0
 
LVL 36

Expert Comment

by:grblades
ID: 20060556
No it wont. I suggested adding this rather than changing the existing one in order to avoid any possible issues with affecting other vpns.

What happens is that when one end tries to establish a new vpn the remote end scans through the various isakmp policies that it has until it finds a match and it will use that first one discovered. These command basically just add a new accepted combination at the end of the list.
0
 
LVL 12

Author Comment

by:valicon
ID: 20067613
That did the trick :) Thanks. What do you think of the two configs, any suggestions on tweaking them?  Thanks again.
0
 
LVL 36

Expert Comment

by:grblades
ID: 20067672
The configs look very clean.

If you add a mail server be carefull of the 'fixup protocol smtp' as it does cause problems with quite a few mail servers. If you find you are unable to send or receive mail to certain people then try disabling it.

You probably know that for example from your PIX501 network you can communicate with machines on the remote site but not the other sites it connects to. This is because V6 of the PIX software wont route connections back out the same interface.
The way around this is to create a fully meshed VPN setup where every remote has a VPN to every other remote site. This can get complicated as you add more remotes. Another way would be to upgrade the main site to at least version 7 of the PIX software which allows traffic to come in over one VPN and back out another.
0
 
LVL 12

Author Comment

by:valicon
ID: 20068349
Thanks again. I really appreciate it! Have a great weekend.
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article explains the fundamentals of industrial networking which ultimately is the backbone network which is providing communications for process devices like robots and other not so interesting stuff.
In this article, WatchGuard's Director of Security Strategy and Research Teri Radichel, takes a look at insider threats, the risk they can pose to your organization, and the best ways to defend against them.
Both in life and business – not all partnerships are created equal. Spend 30 short minutes with us to learn:   • Key questions to ask when considering a partnership to accelerate your business into the cloud • Pitfalls and mistakes other partners…
When cloud platforms entered the scene, users and companies jumped on board to take advantage of the many benefits, like the ability to work and connect with company information from various locations. What many didn't foresee was the increased risk…
Suggested Courses
Course of the Month13 days, 1 hour left to enroll

579 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question