?
Solved

Problem with Reboot/Shut Down

Posted on 2007-10-11
9
Medium Priority
?
563 Views
Last Modified: 2013-12-15
I've got a problem when I reboot or shutdown my Ubuntu VM. I'm running 7.04 in the most recent Parallels 3.0 on an Intel MacBook Pro, but I had the same problem happening on my Windows computer that I installed Linux on a few months ago.

The problem is that, during a reboot, the second that the OS begins unloading the display gets scrambled. It stays like that for the duration of the system shutting down and then the display goes back to normal (proper text) at BIOS. When I shutdown entirely, the process seems to stop somewhere along the way and the system never shuts down entirely; I'm forced to hit the power button.
Screenshot: http://ubuntuforums.org/attachment.php?attachmentid=45865&d=1192026032

I'm really not sure what's going on, I've never seen anything like this in my previous Ubuntu installs except for with 7.04, and I've not seen Windows/Mac/Linux do anything like this before. Can anyone point me in the right direction on this one?
0
Comment
Question by:Harry_Truman
  • 4
6 Comments
 
LVL 35

Accepted Solution

by:
Duncan Roe earned 1000 total points
ID: 20061307
This could be caused by framebuffer console, and udev terminating (taking /dev/fb0 with it). I get minor corruption during halt or reboot due to this right now, planned to fix it by setting the framebuffer resolution before starting udev.
That might fix it for you too - I'll post again once I've tried it myself.
0
 
LVL 35

Expert Comment

by:Duncan Roe
ID: 20069461
Ok I tried it and the corruption went away. I am not familiar with Ubuntu /etc rc scripts but the commands to look for are fbset (sets framebuffer resolution) and udevd (manages the udev /dev mount).
Before udev starts, you have the old-style /dev directory on the root device. This should have an entry for fb0:

crw-rw----  1 root video 29, 0 2007-10-13 17:15 /dev/fb0

As it happens, mine had that already. You should mknod it if it's not there (in case fbcon is a module)

Because udev hides the real /dev by doing a tmpfs mount of /dev, you may need to reboot with "init=/bin/bash" to access the "real" /dev. Once you have verified it contains fb0, alter your startup scripts so fbset is done before udevd and not done again after udevd.
(don't include the double quotes on the boot command line)
0
 
LVL 35

Expert Comment

by:Duncan Roe
ID: 20076983
Oh dear, not so good after all. If I go in and out of X, corruption reappears. If I issue halt or reboot commands fro an xterm, corruption is worse than previously.
I really think you want to get rid of framebuffer console.
In the interim, if you Ctrl-Alt-F6 back to a console before shutting down the system, corruption may not be so bad.
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 
LVL 4

Author Comment

by:Harry_Truman
ID: 20077442
Yeah, I've noticed that anything I do outside of X really doesn't cause any issues.  I'll give it a shot and see what happens, at the very least I can just revert to a snapshot if anything gets worse...
0
 
LVL 8

Assisted Solution

by:MushyPea
MushyPea earned 1000 total points
ID: 22044530
If you think the framebuffer is causing this, try disabling it:

https://wiki.ubuntu.com/FrameBuffer
0
 
LVL 35

Expert Comment

by:Duncan Roe
ID: 22447711
I believe I identified the problem as being framebuffer so deserve credit. MushyPea posted a nice website about framebuffer with at least one useful observation: "If you don't care about a graphic boot then you don't need framebuffer" - true enough if you want to use X windows all the time.
I think I did the lion's share, but wouldn't object to a split.
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article will explain how to establish a SSH connection to Ubuntu through the firewall and using a different port other then 22. I have set up a Ubuntu virtual machine in Virtualbox and I am running a Windows 7 workstation. From the Ubuntu vi…
Often times it's very very easy to extend a volume on a Linux instance in AWS, but impossible to shrink it. I wanted to contribute to the experts-exchange community a way of providing a procedure that works on an AWS instance. It can also be used on…
Learn how to get help with Linux/Unix bash shell commands. Use help to read help documents for built in bash shell commands.: Use man to interface with the online reference manuals for shell commands.: Use man to search man pages for unknown command…
Connecting to an Amazon Linux EC2 Instance from Windows Using PuTTY.
Suggested Courses
Course of the Month12 days, 15 hours left to enroll

578 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question