[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1315
  • Last Modified:

MPLS private network routing bgp, remote wants to run internet over same ciruit problem

I have a client with a meshed MPLS network for their private traffic using BGP with locations in various states.  Each location has its own internet access through a local T1 or cable modem, etc.  One location is downsizing and they wish to cut the internet circuit, running it instead over the MPLS circuit to the corporate location, which is causing me a brainfreeze.  The MPLS router (Cisco 2811xm) at the remote is not the default gateway, there is a smaller Cisco router (2620) that handles this function, and I've modified the route that pointed to their watchguard to go to the mpls router now.  Depending on where I'm trying to go (say tracert to google.com, cisco.com, etc.), I get different interface results, but each with this similiarity: tracert ping-pongs between the local mpls router interface and one of the remotes or the corporate until it times out at 30 hops.  As this is BGP, a simple "ip route 0.0.0.0 0.0.0.0 corpoffiint" type statement isn't going to work.

I'm trying to wrap my mind around this, any help would be appreciated. :)

TIA.
0
pbenningfield
Asked:
pbenningfield
  • 7
  • 7
  • 4
1 Solution
 
lrmooreCommented:
The head end that will be providing the Internet access needs to broadcast network 0.0.0.0 through BGP. Assuming that each remote has a static default pointing to their local firewall, then the BGP learned route will have a higher cost and the only office that will use it will be the one that does not have its own Internet access. It is also the easiest way to provide backup Internet for all the other sites.

At main site, add this to the bgp:
 router bgp 65123
  network 0.0.0.0 mask 0.0.0.0

That's all there is to it.
0
 
tvman_odCommented:
On the site where you wish to use internet for remote site add into BGP router config this
You need to resistribute your static routing, connected networks and possible other dynamic protols like OSPF if you use them.

router bgp 1
 no synchronization
 bgp log-neighbor-changes
 redistribute connected
 redistribute static !###you need this
  default-information originate !### and this
0
 
lrmooreCommented:
Sorry, tvman, but the network 0.0.0.0 is preferred method in BGP/MPLS. I've been there many times.
0
Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

 
tvman_odCommented:
Thanks, I'll make a note
0
 
pbenningfieldAuthor Commented:
Thanks lrmoore!!  Just one odd thing I didn't expect.  I added this, and after a few minutes I did a show ip route on the remote routes and all the routers EXCEPT the one I need it one.  I combed through that remotes router config, compared it with the others and they are almost identical, nothing appearing out of the ordinary.  I rebooted the remote, waited an hour, still nothing.  Anything I should look at?  Thank you!
0
 
lrmooreCommented:
Are all of your sites the same BGP AS number, or is each site unique?
Are you learning that site's route through BGP on your HQ end?
0
 
tvman_odCommented:
Do you have local default gateway on your remote router?
BTW, do you have an alternative way to reach the remote site router? If you would start messing around and loose connection to the romote router it would be nice to be able to reboot it.
0
 
pbenningfieldAuthor Commented:
Thanks guys!  The AS number is the same all the way across; I do have a secondary way in, thank you for asking... always have a backup plan ;).

The HQ learned about the network on the remote side via BGP, but instead of being like every other entry
example: B    192.1.7.0/24 [20/0] via 12.84.82.73, 5d13h
(all other sites show 5days 13hours)
I have this:
               B    192.1.1.0/24 [20/0] via 12.84.82.73, 02:43:09

Why would this be different, and even if it is, why would affect route learning?

Thanks!
0
 
tvman_odCommented:
I'd ask more details if possible. It could be a little option sitting in one of the routers which didn't affect anything before.
0
 
pbenningfieldAuthor Commented:
REMOTE ROUTER:
version 12.3
service timestamps debug datetime localtime
service timestamps log datetime localtime
service password-encryption
!
hostname Evansville_2620
!
boot-start-marker
boot-end-marker
!
card type t1 1 1
logging buffered 4096 debugging
enable secret xxxxxxxxxxxxxxxxxxxxxxxxxxxxx
!
no aaa new-model
!
resource policy
!
clock timezone CST -6
clock summer-time CST recurring
no network-clock-participate slot 1
no network-clock-participate wic 0
ip subnet-zero
ip cef
!
no ip dhcp use vrf connected
!
no ip domain lookup
ip sla monitor responder
no ftp-server write-enable
voice-card 1
!
controller T1 1/0
 framing esf
 linecode b8zs
 cablelength short 133
 ds0-group 0 timeslots 1-12 type e&m-wink-start
 description Grp0 E&M tie-line to Evansville PBX
!
class-map match-any VOIP
 match access-group 100
class-map match-any VOIP-CONTROL
 match access-group 101
!
policy-map llq
 class VOIP
  priority percent 70
class VOIP-CONTROL
  bandwidth 8
 class class-default
  fair-queue
!
interface Loopback3
 ip address 10.1.1.9 255.255.255.252
 h323-gateway voip bind srcaddr 10.1.1.9
!
interface FastEthernet0/0
 ip address 192.1.1.2 255.255.255.0
 speed 100
 full-duplex
 no keepalive
 no cdp log mismatch duplex
!
interface Serial0/0
 description Circuit #
 no ip address
 encapsulation frame-relay IETF
 no ip route-cache cef
 no ip mroute-cache
 shutdown
 no fair-queue
 no dce-terminal-timing-enable
 service-module t1 timeslots 1-6
 cdp enable
 frame-relay traffic-shaping
 frame-relay lmi-type ansi
 hold-queue 1024 out
!
interface Serial0/0.1 point-to-point
 description Primary Connection to Ft Smith IMA
 no ip mroute-cache
 shutdown
 frame-relay interface-dlci 21 ppp Virtual-Template1
!
interface Serial0/1
 ip address 12.84.94.90 255.255.255.252
 encapsulation ppp
 no ip route-cache cef
 no ip route-cache
 ip tcp header-compression iphc-format
 load-interval 30
 no dce-terminal-timing-enable
 ppp multilink
 service-policy output llq
 ip rtp header-compression iphc-format
!
interface Virtual-Template1
 no ip address
!
router eigrp 1
 network 192.1.1.0
 no auto-summary
 no eigrp log-neighbor-changes
!
router bgp 65444
 no synchronization
 no bgp log-neighbor-changes
 network 10.1.1.8 mask 255.255.255.252
 network 12.84.94.88 mask 255.255.255.252
 network 192.1.1.0
 network 192.168.18.0
 neighbor 12.84.94.89 remote-as 7018
 neighbor 12.84.94.89 default-originate
 no auto-summary
!
ip classless
ip route 172.16.9.0 255.255.255.0 12.84.82.74
!
!
no ip http server
no ip http secure-server
!
access-list 4 permit any
access-list 100 permit ip any any dscp ef
access-list 100 permit ip any any precedence critical
access-list 100 permit udp any any range 16384 32767
access-list 101 permit tcp any eq 1720 any
access-list 101 permit tcp any any eq 1720
access-list 101 permit tcp any range 11000 11999 any
access-list 101 permit tcp any any range 11000 11999
access-list 101 permit tcp any range 2000 2002 any
access-list 101 permit tcp any any range 2000 2002
snmp-server community private RW 4
snmp-server location Evansville Frame Router
snmp-server contact Dana McDaniel
snmp-server enable traps tty
snmp-server enable traps envmon shutdown supply temperature voltage
snmp-server enable traps entity
snmp-server host 192.1.9.10 private
!
control-plane
!
voice-port 1/0:0
 echo-cancel coverage 32
 no comfort-noise
 timeouts call-disconnect 3
 description "12 Channel E&M TieLine from Evansville PBX"
!
dial-peer voice 20100 voip
 description voice to ludington
 destination-pattern 03
 session target ipv4:10.1.1.17
 dtmf-relay h245-alphanumeric
 ip qos dscp cs5 media
 no vad
!
dial-peer voice 20102 voip
 description voice to Clinton
 destination-pattern 04
 session target ipv4:10.1.1.21
 dtmf-relay h245-alphanumeric
 ip qos dscp cs5 media
 no vad
!
dial-peer voice 20103 pots
 description voice to Evansville
 destination-pattern 06
 port 1/0:0
!
dial-peer voice 20104 voip
 description voice to Elizabethtown
 destination-pattern 02
 session target ipv4:10.1.1.13
 dtmf-relay h245-alphanumeric
 ip qos dscp cs5 media
 no vad
!
dial-peer voice 20105 voip
 description voice to Newport
 destination-pattern 07
 session target ipv4:10.1.1.25
 dtmf-relay h245-alphanumeric
 ip qos dscp cs5 media
 no vad
!
dial-peer voice 20106 voip
 description voice to Madison
 destination-pattern 08
 session target ipv4:10.1.1.5
 dtmf-relay h245-alphanumeric
 ip qos dscp cs5 media
!
dial-peer voice 20107 voip
 description voice to Ft Smith
 destination-pattern 01....
 session target ipv4:172.16.9.11
 dtmf-relay h245-alphanumeric
 ip qos dscp cs5 media
 no vad
!
line con 0
 exec-timeout 0 0
 password 7 xxxxxxxxxxxxx
 login
 speed 115200
line aux 0
 exec-timeout 1 30
 password 7 xxxxxxxxxxxxx
 login
 modem InOut
 transport input all
 stopbits 1
 speed 38400
 flowcontrol hardware
line vty 0 4
 password 7 xxxxxxxxxxxx
 login
!
end

CORPORATE ROUTER:
version 12.3
service timestamps debug datetime localtime
service timestamps log datetime localtime
service password-encryption
!
hostname FtSmith_2620
!
boot-start-marker
boot-end-marker
!
card type t1 1 1
logging buffered 4096 debugging
enable secret XXXXXXXXXXXXXXXXXXXX
!
no aaa new-model
!
resource policy
!
clock timezone CST -6
clock summer-time CST recurring
network-clock-participate slot 1
network-clock-participate wic 0
network-clock-participate wic 1
network-clock-select 1 T1 0/0
network-clock-select 2 T1 0/1
ip subnet-zero
ip cef
!
no ip dhcp use vrf connected
!
ip flow-cache timeout inactive 10
ip flow-cache timeout active 5
no ip domain lookup
ip host madison 10.1.1.5
ip host etown 10.1.1.13
ip host clinton 10.1.1.21
ip host luding 10.1.1.17
ip host newport 10.1.1.25
ip host evansville 10.1.1.9
ip sla monitor 666
 type jitter dest-ipaddr 10.1.1.21 dest-port 16384 codec g729a
 enhanced-history interval 900 buckets 100
ip sla monitor schedule 666 life forever start-time now
ip sla monitor 667
 type jitter dest-ipaddr 10.1.1.25 dest-port 16384 codec g729a
ip sla monitor 668
 type jitter dest-ipaddr 192.168.254.6 dest-port 16384 codec g729a
 enhanced-history interval 900 buckets 100
ip sla monitor schedule 668 life forever start-time now
ip sla monitor 669
 type jitter dest-ipaddr 10.1.1.13 dest-port 16384 codec g729a
ip sla monitor 670
 type jitter dest-ipaddr 10.1.1.21 dest-port 16384 codec g729a
no ftp-server write-enable
isdn switch-type primary-ni
voice-card 1
 no dspfarm
 dsp services dspfarm
!
voice class codec 1
 codec preference 1 g711alaw
 codec preference 2 g711ulaw
 codec preference 3 g729br8
!
controller T1 0/0
 mode atm aim 0
 framing esf
 linecode b8zs
!
controller T1 0/1
 mode atm aim 0
 --More--          framing esf
 linecode b8zs
!
controller T1 0/2
 framing esf
 clock source internal
 linecode b8zs
 channel-group 0 timeslots 1-24 speed 64
!
controller T1 0/3
 framing esf
 clock source internal
 linecode b8zs
 channel-group 1 timeslots 1-24 speed 64
!
controller T1 1/0
 framing esf
 linecode b8zs
 ds0-group 0 timeslots 1-24 type e&m-immediate-start
 description Grp0 E&M tie-line to FtSmith PBX
!
class-map match-any VOIP
 match access-group 100
 class-map match-any VOIP-CONTROL
 match access-group 101
!
policy-map llq_384
 class VOIP
  priority percent 70
 class VOIP-CONTROL
  bandwidth 8
 class class-default
  fair-queue
policy-map llq_512
 class VOIP
  priority percent 70
 class VOIP-CONTROL
  bandwidth 8
 class class-default
  fair-queue
policy-map llq
 class VOIP
  priority percent 70
 class VOIP-CONTROL
  bandwidth 8
 class class-default
!
interface Loopback1
 ip address 10.1.1.1 255.255.255.252
!
interface Multilink1
 description "TO AT&T MPLS Network"
 ip address 12.84.82.74 255.255.255.252
 no ip route-cache cef
 no ip route-cache
 ip tcp header-compression iphc-format
 load-interval 30
 ppp multilink
 ppp multilink fragment delay 10
 ppp multilink interleave
 ppp multilink group 1
 service-policy output llq_512
 ip rtp header-compression iphc-format
!
 interface ATM0/0
 no ip address
 no ip proxy-arp
 ip route-cache flow
 shutdown
 no scrambling-payload
 ima-group 0
 no atm ilmi-keepalive
!
interface FastEthernet0/0
 ip address 192.1.9.254 255.255.255.0
 no ip proxy-arp
 ip nbar protocol-discovery
 ip route-cache flow
 speed auto
 full-duplex
 no cdp log mismatch duplex
!
interface ATM0/1
 no ip address
 no ip proxy-arp
 ip route-cache flow
 shutdown
 no scrambling-payload
 ima-group 0
 no atm ilmi-keepalive
!
interface Serial0/2:0
 description CID DHEC.335737.ATI
 no ip address
 encapsulation ppp
 no fair-queue
 ppp multilink
 ppp multilink group 1
!
interface Serial0/3:1
 no ip address
 encapsulation ppp
 ppp multilink
 ppp multilink group 1
!
interface ATM0/IMA0
 no ip address
 no ip proxy-arp
 ip route-cache flow
 ima clock-mode common 1
 no atm ilmi-keepalive
!
router eigrp 1
 redistribute static
 network 192.1.9.0
 no auto-summary
 no eigrp log-neighbor-changes
!
router bgp 65001
 no synchronization
 no bgp log-neighbor-changes
 network 0.0.0.0
 network 10.1.1.0 mask 255.255.255.252
 network 12.84.82.72 mask 255.255.255.252
 network 172.16.9.0 mask 255.255.255.0
 network 192.1.9.0
 network 192.168.11.0
 network 192.168.253.0
 neighbor 12.84.82.73 remote-as 7018
 neighbor 12.84.82.73 default-originate
 no auto-summary
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.1.9.20
ip route 172.16.9.0 255.255.255.0 192.1.9.192
ip route 192.1.20.0 255.255.255.0 192.1.9.20
!
ip flow-export version 5
ip flow-export destination 192.1.9.10 9993
!
no ip http server
no ip http secure-server
!
access-list 4 permit any
access-list 100 permit ip any any dscp ef
access-list 100 permit ip any any precedence critical
access-list 100 permit udp any any range 16384 32767
access-list 101 permit tcp any eq 1720 any
access-list 101 permit tcp any any eq 1720
access-list 101 permit tcp any range 11000 11999 any
access-list 101 permit tcp any any range 11000 11999
access-list 101 permit tcp any range 2000 2002 any
access-list 101 permit tcp any any range 2000 2002
snmp-server community private RW 4
snmp-server location Ft.Smith Frame Router
snmp-server contact Dana McDaniel
snmp-server enable traps tty
snmp-server enable traps envmon shutdown supply temperature voltage
snmp-server enable traps entity
snmp-server host 192.1.9.10 private
!
control-plane
!
voice-port 1/0:0
!
sccp local FastEthernet0/0
sccp ccm 172.16.9.11 identifier 1
sccp ip precedence 1
sccp
!
sccp ccm group 1
 associate ccm 1 priority 1
 associate profile 2 register CFB001120469620
!
sccp ccm group 2
 associate ccm 1 priority 1
 associate profile 5 register TransCode01
!
dspfarm profile 5 transcode
 codec g711ulaw
 codec g711alaw
 codec g729ar8
 codec g729abr8
 codec gsmfr
 codec g729r8
 codec g729br8
 maximum sessions 9
 associate application SCCP
!
dspfarm profile 2 conference
 codec g711ulaw
 codec g711alaw
 codec g729ar8
 codec g729abr8
 codec g729r8
 codec g729br8
 maximum sessions 2
 associate application SCCP
!
!
dial-peer voice 10200 pots
 destination-pattern 10200
!
dial-peer voice 20100 voip
 description voice to ludington
 destination-pattern 03
 session target ipv4:10.1.1.17
 dtmf-relay h245-alphanumeric
 codec g711ulaw
 ip qos dscp cs5 media
 no vad
!
dial-peer voice 20102 voip
 description voice to Clinton
 destination-pattern 04
 session target ipv4:10.1.1.21
 dtmf-relay h245-alphanumeric
 ip qos dscp cs5 media
 no vad
!
 dial-peer voice 20103 voip
 description voice to Evansville
 destination-pattern 06
 session target ipv4:10.1.1.9
 dtmf-relay h245-alphanumeric
 ip qos dscp cs5 media
 no vad
!
dial-peer voice 20104 voip
 description voice to Elizabethtown
 destination-pattern 02
 session target ipv4:10.1.1.13
 dtmf-relay h245-alphanumeric
 ip qos dscp cs5 media
 no vad
!
dial-peer voice 20105 voip
 description voice to Newport
 destination-pattern 07
 session target ipv4:10.1.1.25
 dtmf-relay h245-alphanumeric
 ip qos dscp cs5 media
 no vad
!
dial-peer voice 20106 voip
 description voice to Madison
 destination-pattern 08
 session target ipv4:10.1.1.5
 dtmf-relay h245-alphanumeric
 ip qos dscp cs5 media
!
dial-peer voice 20107 voip
 description voice to Ft Smith CCM
 destination-pattern 01
 session target ipv4:172.16.9.11
 dtmf-relay h245-alphanumeric
!
gateway
 timer receive-rtp 1200
!
line con 0
 exec-timeout 0 0
 password xxxxxxxxxxxxxx
 logging synchronous
 login
line aux 0
 password XXXXXXXXXXXXX
 login
line vty 0 4
 exec-timeout 30 0
 password XXXXXXXXXXX

 login
!
ntp server 192.168.254.1
!
end

0
 
lrmooreCommented:
Remove the static route from the remote site

no ip route 172.16.9.0 255.255.255.0 12.84.82.74
0
 
pbenningfieldAuthor Commented:
Thank you!

I've done this, waited 30 minutes, and done an ip route on the remote I'm having trouble with an another remote site. My problem site appears to still be picking up all advertised BGP routes but the 0.0.0.0.  I've posted this below:

clinton2620#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is 12.84.94.93 to network 0.0.0.0

B    192.1.9.0/24 [20/0] via 12.84.94.93, 4d16h
B    192.168.212.0/24 [20/0] via 12.84.94.93, 4d17h
     172.16.0.0/24 is subnetted, 1 subnets
S       172.16.9.0 [1/0] via 12.84.82.74
B    192.1.4.0/24 [20/0] via 12.84.94.93, 4d17h
     10.0.0.0/30 is subnetted, 7 subnets
B       10.1.1.8 [20/0] via 12.84.94.93, 00:12:39
B       10.1.1.12 [20/0] via 12.84.94.93, 4d17h
B       10.1.1.0 [20/0] via 12.84.94.93, 4d16h
B       10.1.1.4 [20/0] via 12.84.94.93, 4d17h
B       10.1.1.24 [20/0] via 12.84.94.93, 4d17h
B       10.1.1.16 [20/0] via 12.84.94.93, 4d17h
C       10.1.1.20 is directly connected, Loopback6
B    192.1.7.0/24 [20/0] via 12.84.94.93, 4d17h
     12.0.0.0/8 is variably subnetted, 9 subnets, 3 masks
B       12.84.38.116/30 [20/0] via 12.84.94.93, 4d17h
B       12.84.94.44/30 [20/0] via 12.84.94.93, 4d17h
B       12.84.82.72/30 [20/0] via 12.84.94.93, 4d16h
B       12.84.54.44/30 [20/0] via 12.84.94.93, 4d17h
B       12.84.54.40/30 [20/0] via 12.84.94.93, 4d17h
C       12.84.94.92/30 is directly connected, Serial0/1
C       12.84.94.93/32 is directly connected, Serial0/1
B       12.84.94.88/30 [20/0] via 12.84.94.93, 00:13:57
B       12.38.168.0/24 [20/0] via 12.84.94.93, 4d17h
B    192.1.1.0/24 [20/0] via 12.84.94.93, 00:13:02
B    192.168.1.0/24 [20/0] via 12.84.94.93, 4d17h
     135.89.0.0/29 is subnetted, 2 subnets
B       135.89.152.56 [20/0] via 12.84.94.93, 4d17h
B       135.89.154.152 [20/0] via 12.84.94.93, 4d17h
C    192.1.3.0/24 is directly connected, FastEthernet0/0
B*   0.0.0.0/0 [20/0] via 12.84.94.93, 4d17h



Evansville_2620#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

B    192.1.9.0/24 [20/0] via 12.84.94.89, 00:18:50
B    192.168.212.0/24 [20/0] via 12.84.94.89, 00:18:50
     172.16.0.0/24 is subnetted, 1 subnets
B       172.16.9.0 [20/0] via 12.84.94.89, 00:18:50
B    192.1.4.0/24 [20/0] via 12.84.94.89, 00:18:50
     10.0.0.0/30 is subnetted, 7 subnets
C       10.1.1.8 is directly connected, Loopback3
B       10.1.1.12 [20/0] via 12.84.94.89, 00:18:50
B       10.1.1.0 [20/0] via 12.84.94.89, 00:18:50
B       10.1.1.4 [20/0] via 12.84.94.89, 00:18:50
B       10.1.1.24 [20/0] via 12.84.94.89, 00:18:50
B       10.1.1.16 [20/0] via 12.84.94.89, 00:18:50
B       10.1.1.20 [20/0] via 12.84.94.89, 00:18:50
B    192.1.7.0/24 [20/0] via 12.84.94.89, 00:18:51
     12.0.0.0/8 is variably subnetted, 9 subnets, 3 masks
B       12.84.38.116/30 [20/0] via 12.84.94.89, 00:18:51
B       12.84.94.44/30 [20/0] via 12.84.94.89, 00:18:51
B       12.84.82.72/30 [20/0] via 12.84.94.89, 00:18:51
B       12.84.54.44/30 [20/0] via 12.84.94.89, 00:18:51
B       12.84.54.40/30 [20/0] via 12.84.94.89, 00:18:51
B       12.84.94.92/30 [20/0] via 12.84.94.89, 00:18:51
C       12.84.94.88/30 is directly connected, Serial0/1
C       12.84.94.89/32 is directly connected, Serial0/1
B       12.38.168.0/24 [20/0] via 12.84.94.89, 00:18:51
C    192.1.1.0/24 is directly connected, FastEthernet0/0
B    192.168.1.0/24 [20/0] via 12.84.94.89, 00:18:51
     135.89.0.0/29 is subnetted, 2 subnets
B       135.89.152.56 [20/0] via 12.84.94.89, 00:18:51
B       135.89.154.152 [20/0] via 12.84.94.89, 00:18:51
B    192.1.3.0/24 [20/0] via 12.84.94.89, 00:18:51
0
 
lrmooreCommented:
Remove this from Evansville also
router bgp xxxx
  neighbor 12.84.94.89 default-originate
0
 
pbenningfieldAuthor Commented:
Thanks LR,

I now see
B*   0.0.0.0/0 [20/0] via 12.84.94.89, 00:16:44
in at the Evansville site, but still have my original issue, wherein I receive different results depending on where I'm trying to go (say tracert to google.com, cisco.com, etc.), with none completing.

Thanks!

Trish
0
 
lrmooreCommented:
Maybe it's an issue at the firewall end at Corp router? Does the firewall have a route back to the Evansville subnet?
0
 
pbenningfieldAuthor Commented:
Yes, thanks.

Let me explain a little further, if I ping 151.164.169.201 (sbc/att DNS server),from Evansville, the route taken is local router, local router, MPLS to a remote in Madison, TN.  If I ping www.google.com, the route taken is local router, local router, MPLS to corporate office, then back to local office, ping pong effect until timeout.  If I ping something else, maybe cisco.com or whatever, it will go a completely different route...

My primary problem is that the route selected from the starting point is not the same consistently, ie over the MPLS to the corporate router, despite now advertising 0.0.0.0 at the corporate location.

Thanks,

Trish
0
 
lrmooreCommented:
Ahso...
Make sure none of the other sites have the default-originate command in their BGP setup (including HQ)

  neighbor 12.84.94.xx default-originate

Corporate is the only one that advertises network 0.0.0.0


0
 
pbenningfieldAuthor Commented:
Thank you, removing all the default-originate statements did the trick!!!
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 7
  • 7
  • 4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now