user can't connect - driving me mad!

Posted on 2007-10-11
Last Modified: 2010-03-19
My background is very much in sql 2000 and am a bit raw with 2005.
I developed a database which is a backend for a local web app. All worked fine on the development server.
I have moved this over to a 2005 sql server in production and fired everything up. Out of approx 30 users tsted so far 2 of them cannot connect via the web app. They get login failed for nt authority/anonymous user
Anon access is not turned on in iis (Windows Auth is) None of these people that failed have permissions (windows/sql) above or below those that passed.

To get the db from 2000 to 2005 I created the new db in sql 2005 and then restored the backup from 2000.
To get the logins across I did a transfer logins task from 2005 to 2000
Both tasks went fine.

I have deleted 2 of the failed users, their logins/usernames/schemas and started them from scratch. Still no good.
What's happening with these few people?
Question by:QPR
    LVL 14

    Expert Comment

    i doubt that...since you say WEB really does not depend on WHO is connecting ...its always your web application that is conencting to the database....
    are you trying thru something else ?
    LVL 29

    Author Comment

    all different users all on the same domain - mixed results pass/fail
    all users are "public"
    all have logins created in 2005, usernames made in the appropriate DB. Schemas (which is an alien concept to me in SQL) created
    login name = domain/username
    mapped to username domain/username with a default schema named domain/username

    This is the pattern for all users, ones who can connect and those who can't
    My web.config has windows authentication and impersonation.
    IIS has anon turned off so it must be the user connecting to the DB (via IIS)
    LVL 29

    Accepted Solution

    turns out it was a setting in internet explorer under security (allow MTLM auth or something) once the box was ticked the affected users were able to connect without a problem - ho hum, lessons learnt!
    LVL 14

    Expert Comment

    great going !!!!
    LVL 1

    Expert Comment

    Closed, 500 points refunded.
    Community Support Moderator

    Featured Post

    PRTG Network Monitor: Intuitive Network Monitoring

    Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

    Join & Write a Comment

    Introduction: When running hybrid database environments, you often need to query some data from a remote db of any type, while being connected to your MS SQL Server database. Problems start when you try to combine that with some "user input" pass…
    Data architecture is an important aspect in Software as a Service (SaaS) delivery model. This article is a study on the database of a single-tenant application that could be extended to support multiple tenants. The application is web-based develope…
    Migrating to Microsoft Office 365 is becoming increasingly popular for organizations both large and small. If you have made the leap to Microsoft’s cloud platform, you know that you will need to create a corporate email signature for your Office 365…
    Illustrator's Shape Builder tool will let you combine shapes visually and interactively. This video shows the Mac version, but the tool works the same way in Windows. To follow along with this video, you can draw your own shapes or download the file…

    754 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    17 Experts available now in Live!

    Get 1:1 Help Now