Can't start Apache TomCat 6.0 on Windows 2003 Server

Hi guys,

I do need some help, been trying to debug this for sometime, looked at logs and all. I downloaded TomCat 6.0 and installed the .exe. Everything was smooth and i left most of the settings as default. I'm having problems starting my tomcat 6.0 service in "Configure" on my windows 2003 server. It was unable to start the service after install.

I'm using J2SE JRE 1.4.2_16, I tried 1.6, and same.

Anyone had the same problem or know anything based on these logs below. Thanks!

The error in the logs are:
[2007-10-12 19:46:34] [info] Starting service...
[2007-10-12 19:46:34] [443  javajni.c] [error] FindClass org/apache/catalina/startup/Bootstrap failed
[2007-10-12 19:46:34] [997  prunsrv.c] [error] Failed loading main org/apache/catalina/startup/Bootstrap class C:\Program Files\Apache Software Foundation\Tomcat 6.0\bin\bootstrap.jar
[2007-10-12 19:46:34] [1260 prunsrv.c] [error] ServiceStart returned 3
[2007-10-12 19:46:34] [info] Run service finished.
[2007-10-12 19:46:34] [info] Procrun finished.
[2007-10-12 19:46:41] [info] Procrun (2.0.3.0) started
[2007-10-12 19:46:41] [info] Running Service...
[2007-10-12 19:46:41] [info] Starting service...
[2007-10-12 19:46:41] [443  javajni.c] [error] FindClass org/apache/catalina/startup/Bootstrap failed
[2007-10-12 19:46:41] [997  prunsrv.c] [error] Failed loading main org/apache/catalina/startup/Bootstrap class C:\Program Files\Apache Software Foundation\Tomcat 6.0\bin\bootstrap.jar
[2007-10-12 19:46:41] [1260 prunsrv.c] [error] ServiceStart returned 3
[2007-10-12 19:46:41] [info] Run service finished.
[2007-10-12 19:46:41] [info] Procrun finished.
[2007-10-12 19:48:41] [443  javajni.c] [error] FindClass org/apache/catalina/startup/Bootstrap failed
[2007-10-12 19:48:41] [997  prunsrv.c] [error] Failed loading main org/apache/catalina/startup/Bootstrap class C:\Program Files\Apache Software Foundation\Tomcat 6.0\bin\bootstrap.jar
[2007-10-12 19:48:41] [1260 prunsrv.c] [error] ServiceStart returned 3
[2007-10-12 19:48:48] [443  javajni.c] [error] FindClass org/apache/catalina/startup/Bootstrap failed
[2007-10-12 19:48:48] [997  prunsrv.c] [error] Failed loading main org/apache/catalina/startup/Bootstrap class C:\Program Files\Apache Software Foundation\Tomcat 6.0\bin\bootstrap.jar
[2007-10-12 19:48:48] [1260 prunsrv.c] [error] ServiceStart returned 3
[2007-10-12 19:49:55] [443  javajni.c] [error] FindClass org/apache/catalina/startup/Bootstrap failed
[2007-10-12 19:49:55] [997  prunsrv.c] [error] Failed loading main org/apache/catalina/startup/Bootstrap class C:\Program Files\Apache Software Foundation\Tomcat 6.0\bin\bootstrap.jar
[2007-10-12 19:49:55] [1260 prunsrv.c] [error] ServiceStart returned 3
jedistarAsked:
Who is Participating?
 
IsisagateCommented:
You have java installed and the the Enviornmental variable "JAVAHOME" set?
0
 
jedistarAuthor Commented:
yep, JAVA_HOME is set to C:\Program Files\java\j2re1.4.2_16
0
 
jedistarAuthor Commented:
Sorry it is C:\Program Files\java\j2re1.4.2_16\bin
should i set it to C:\Program Files\TomCat 6.0\bin

tried doesnt work tho
0
 
jedistarAuthor Commented:
Tried setting it to C:\Program Files\java\j2re1.4.2_16
Doesnt work too
0
 
jedistarAuthor Commented:
should i use jdk or j2re?
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.