We help IT Professionals succeed at work.

How to Change NIC speed without restarting the Linux AS 3 server?????

2,201 Views
Last Modified: 2013-12-16
I would like to change the NIC settings from 100 to 1000, Auto_negotiation Yes without restarting the  Linux Machine. Please see the details below

# uname -r
2.4.21-37.ELsmp
# cat /etc/redhat-release
Red Hat Enterprise Linux AS release 3 (Taroon Update 6)
#ethtool eth0
Settings for eth0:
        Supported ports: [ TP ]
        Supported link modes:   10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Half 1000baseT/Full
        Supports auto-negotiation: Yes
        Advertised link modes:  Not reported
        Advertised auto-negotiation: No
        Speed: 100Mb/s
        Duplex: Full
        Port: Twisted Pair
        PHYAD: 0
        Transceiver: internal
        Auto-negotiation: off
        Supports Wake-on: g
        Wake-on: d
        Link detected: yes
# cat /etc/modules.conf
alias eth0 bcm5700
options eth0 line_speed=100 auto_speed=0 full_duplex=1
alias eth1 bcm5700
options eth1 line_speed=100 auto_speed=0 full_duplex=1
alias scsi_hostadapter cciss
alias usb-controller usb-ohci
options bond0 miimon=100 mode=active-backup
alias bond0 bonding
Comment
Watch Question

Kerem ERSOYPresident

Commented:
Hi,

You can use ethtool command for modifying speed:
ethtool -s eth0 speed 100 duplex full autoneg on

The resuls are immediate you don't need to reboot. But for the next boot you can either remove:
options eth0 line_speed=100 auto_speed=0 full_duplex=1
options eth1 line_speed=100 auto_speed=0 full_duplex=1

Lines from your /etc/modules conf thiswill force your adapter to autonegotiation od change the "line_speed=100" to "line_speed=1000" if you want to do it manually.

President
Commented:
Unlock this solution and get a sample of our free trial.
(No credit card required)
UNLOCK SOLUTION

Author

Commented:
How would i set as Auto Auto for this server
Kerem ERSOYPresident

Commented:
You want to set it back to auto ??

Then you'd issue:
ethtool -s eth0 autoneg on

Gain unlimited access to on-demand training courses with an Experts Exchange subscription.

Get Access
Why Experts Exchange?

Experts Exchange always has the answer, or at the least points me in the correct direction! It is like having another employee that is extremely experienced.

Jim Murphy
Programmer at Smart IT Solutions

When asked, what has been your best career decision?

Deciding to stick with EE.

Mohamed Asif
Technical Department Head

Being involved with EE helped me to grow personally and professionally.

Carl Webster
CTP, Sr Infrastructure Consultant
Empower Your Career
Did You Know?

We've partnered with two important charities to provide clean water and computer science education to those who need it most. READ MORE

Ask ANY Question

Connect with Certified Experts to gain insight and support on specific technology challenges including:

  • Troubleshooting
  • Research
  • Professional Opinions
Unlock the solution to this question.
Thanks for using Experts Exchange.

Please provide your email to receive a sample view!

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.