We help IT Professionals succeed at work.

Cannot recreat Full-text Index: RPC Server is unavailable

Mehrdad Michael Massumi
on
1,875 Views
Last Modified: 2008-08-15
I just found our Exchange Server 2003 (clustered EE, version 6.5, Build 7638.2, SP2) running on Windows Server 2003 (clustered EE, SP2) lost full-text index of Mailbox Store and Public Folder store (Index size: 0 KB). I wonder this happed after I installed a Exchange Hot Fix (for Exchange Cluster) last weekend. I tried to redo the populate. I got following error:

The project <ExchangeServer_MYEXCHANGE priv5E5E90AC> cannot be initialized. Error: 8004111e - The Indexer failed to update or access information because of a database error.  Stop and restart the Search service.  If errors continue, reset the catalog and rebuild the index.  In some cases, it may be necessary to delete and recreate the catalog.

After restarting the Microsoft Search service, I did population again but this time I got;

  The RPC Server is unavailable.
  Facility: Win32
  ID number: 800706ba
  Exchange System Manager

I deleted full-text index of Public Folder Store and tried to recreat it. Then I got same error message above.
I did netdiag test but did not find any error (all passed).
Any idea? Thanks!
Comment
Watch Question

Author

Commented:
Ok, I found my problem is exactly like this  "Event 494 on Exchange 2003, server 2003, clustered".
 Under the E:\EXCHSRVR\ExchangeServer_MYEXCHANGE folder, there is a .edf file but no .stm file. There are four log files and one .chk file. I tried to use eseutil /p /createstm to re-create .stm file but it did not create anything. The database file is ExchangeServer_MYEXCHANGE.edb, not information store data or public folder data file. Please help!

Author

Commented:
I found this article on the Internet "How to manually delete a Full-Text Index" (http://msexchangeteam.com/archive/2005/02/23/379032.aspx). After deleting full-text index and recreating the index, we are now able to search the mail box store and public folder store.
Please kindly close this question. Thanks.
Unlock this solution and get a sample of our free trial.
(No credit card required)
UNLOCK SOLUTION

Commented:
I discovered a step that was missing in the procedure for deleting and recreating the index as outlined in http://msexchangeteam.com/archive/2005/02/23/379032.aspx

At the point where I would attempt to recreate the new index it would fail with an error stating that "The Indexer failed to update or access information because of a database error...."

In order to resolve this I had to start over, and take the additional step of renaming the %ProgramFiles%\Exchsrvr\ExchangeServer_SERVERNAME\ExchangeServer_SERVERNAME.edb to .bak prior to restarting MSsearch and creating the index.

When I created the index, it built a new .edb file and had no errors. I was then able to populate the index successfully.
Unlock the solution to this question.
Thanks for using Experts Exchange.

Please provide your email to receive a sample view!

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.