[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

ExMerge cannot find my server

Posted on 2007-10-12
7
Medium Priority
?
1,147 Views
Last Modified: 2008-03-08
I've used ExMerge a few times to export some mailboxes in the past without any issues.  I went to use it today and got the following error.

The specified server "my server name" is inaccessible.  It is not an Exchange Server or a domain controller is unavailable or you do not have the necessary rights to access this server of the LDAP port specified is incorrect"

I know the server is accessible and running because I have 80 users on there right now.  The domain controllers are controlled by a larger group on campus and are definitely up and running.  I've tried specifying my DC and the LDAP port but it returns the same error.

I'm running exmerge within the \exchsrvr\bin directory and my AD account is definitely a member of a security group that has Exchange Admin permission on my OU.

Here is the exmerge.log error

****************************************************************
Microsoft Exchange Mailbox Merge Program, v6.5.7529.0
Start Logging:October 12, 2007   10:08:10
****************************************************************
[10:08:10] Logging Level: None
[10:08:10] Reading settings from file 'E:\Program Files\Exchsrvr\bin\EXMERGE.INI'.
[10:08:10] Reading list of subjects for messages to be selected from file ''
[10:08:10] Reading list of attachment names for messages to be selected from file ''
[10:08:10] List of folders to be ignored has been read. 0 folders in the list.
[10:08:10] Current machine locale ID is 0x409
[10:08:10] Operating System Version 5.2 (Build 3790)
[10:08:18] Error 8007203a opening an LDAP connection. ('LDAP://my server name/rootDSE')  (CADRoutines::GetNamingContextData)
[10:08:20] Error 8007054b opening an LDAP connection. ('LDAP://rootDSE')  (CADRoutines::GetNamingContextData)
[10:08:20] Error getting organization and site information from server 'my server name', using DAPI
[10:08:20] The specified server 'my server name' is inaccessible. It is not an Exchange Server or a domain controller is unavailable or you do not have the necessary rights to access this server or the LDAP port specified in incorrect.
0
Comment
Question by:tferro999
  • 4
  • 3
7 Comments
 
LVL 2

Expert Comment

by:SKTRN
ID: 20067735
Verify the user you are running exmerge as has Receive As and Send As permissions set to Allow.

This article may be of assistance as well:
http://support.microsoft.com/kb/323546
0
 

Author Comment

by:tferro999
ID: 20067864
I followed that document and it did yield some clues.

My personal AD account is listed under the security tab and does have Receive As and Send As permissions.  However, the admin security group that I am a member of, had both Allow and Deny checked for both items.  Both were greyed out as well.

I tried adding another account I use and setting the Receive As and Send As permissions to allow.  I then made it a member of the local admin group for this exchange box.  I thought this would fix it, but when I run Exmerge as this second user, I get the same error.  Now i'm really stumped.
0
 
LVL 2

Expert Comment

by:SKTRN
ID: 20068440
Is the user also listed as an exchange administrator?  If so then their permissions on the organization container is set to deny Receive-As.
0
VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

 

Author Comment

by:tferro999
ID: 20069458
When I delegate control to my OU, the group that is listed as Exchange Full Admininstrator does not include this second user account that I manually added the "Send As" "Receive As" permissions.

Is there somewhere else I should be looking?
0
 
LVL 2

Expert Comment

by:SKTRN
ID: 20070170
Can you post a log from the run as the second user.
0
 
LVL 2

Expert Comment

by:SKTRN
ID: 20070199
The account used for exmerge also needs service account permission and I am not sure but you may want to remove them from the administrator group.
0
 

Accepted Solution

by:
tferro999 earned 0 total points
ID: 20220140
Easy answer to my own stupid question.

You cant enter the FQDN for the exchange server using exmerge, it only works with the simple common name for the server.

server1.dummycorp.com didnt work
server1 worked.
0

Featured Post

Restore individual SQL databases with ease

Veeam Explorer for Microsoft SQL Server delivers an easy-to-use, wizard-driven interface for restoring your databases from a backup. No expert SQL background required. Web interface provides a complete view of all available SQL databases to simplify the recovery of lost database

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This month, Experts Exchange sat down with resident SQL expert, Jim Horn, for an in-depth look into the makings of a successful career in SQL.
Steps to fix error: “Couldn’t mount the database that you specified. Specified database: HU-DB; Error code: An Active Manager operation fail”
In this video we show how to create an Address List in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Organization >> Ad…
The basic steps you have just learned will be implemented in this video. The basic steps are shown to configure an Exchange DAG in a live working Exchange Server Environment and manage the same (Exchange Server 2010 Software is used in a Windows Ser…
Suggested Courses

873 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question