After failed reformat I'm getting a HDD password prompt?

Toshiba laptop quit running Windows XP after what I believe was either overheating or perhaps a virus. The OS would operate in Safe mode but would lock at the desktop whenever I tried to boot into normal XP. The system would not install any network cards load any devices. I just tried to reformat the HD and made it to 76% but then installation was aborted due to a HD format incomplete message. When retried the installation I am now receiving a HDD password prompt.
rmcgouhAsked:
Who is Participating?
 
jamietonerCommented:
Sounds like the electronics on the hdd are failing, it may be time for a replacement hdd.
0
 
johnb6767Commented:
Like a BIOS password? Sounds like something has gone wacky in the Board.....
0
 
souseranCommented:
Can you run system diagnostics? Also, can you try running DBAN, available from http://dban.sourceforge.net to completely wipe the drive and then reinstall the OS?
0
Improve Your Query Performance Tuning

In this FREE six-day email course, you'll learn from Janis Griffin, Database Performance Evangelist. She'll teach 12 steps that you can use to optimize your queries as much as possible and see measurable results in your work. Get started today!

 
ridCommented:
I'd recommend you examine the hard drive in another computer. Preferably a system which you can strip of any other hard drives. Hook up the HD to the controller directly, no USB casing (you may need an adapter for laptop HD to desktop computer if that's what you'll use). See if you can access the HD at all through BIOS (is it detected?). If you're asked for a PW even in that system, the HD indeed has a password set. If you don't know the password, and can't guess it, you're in a bad situation. If you're NOT asked for a password, boot the system wiht a Knoppix CD or use DBAN to examine and/or wipe the hard drive. Note that a wipe operation can't be executed on a PW-protected drive, unless you can unlock it with the correct PW and you can't take away the PW with a wipe operation.

If you can access the HD properly (no password is set) you should RESET the CMOS in the laptop BEFORE you put the HD back in. A new CMOS battery may be a good idea, too. Wiping the HD may not be necessary, unless you're set for a system reinstall or something.

/RID
0
 
rmcgouhAuthor Commented:
Turns out that it was a failed hard drive. Replacement of the HD solved the problem and everything went smoothly with the new OS install. Thank you all for your input.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.