We help IT Professionals succeed at work.

Notebook keyboard is crazy

1,799 Views
Last Modified: 2013-12-09
Hi,

I have a Dell Inspiron 1501 notebook. Something strange is happening with its keyboard.

The PAGE UP key doesn't work. And when I press any of the following keys - Q, W, E, R, U, I, O and P - then it's like page up was pressed many times.

For example, when I'm editing text, and I'm on page 10, if I press any of those keys, then it returns to the beginning of the document.

Any ideas what it is? Is it the keyboard that is defective? Or could it be a virus or something?

One more thing, can I deactivate the notebook's keyboard, so I can use an USB one?

Thanks in advance!
Comment
Watch Question

Commented:
Ooh, sounds like somebody spilled something all over the keyboard to me ;-)  If you do plug in a USB keyboard, it should just work.  If typing from that KB is OK, then ya, I'd see if there's anything sticky under there.

Commented:
Yes, you can use USB keyboard instead.

However, try this key combination:
- Start system, F2 to get bios page.
- Turn on Cap Lock, Num Lock, and Scroll Lock
- Type in sequence: Alt+E, Alt+F, and Alt+B
Post back when you can.

Author

Commented:
Hi, thanks for the quick responses.

PUNKY, I tried what you suggested. My notebook doesn't have scroll lock (or at least I couldn't find it, cause there is the LED telling when scroll lock is activated). So I plugged in my USB keyboard and activated scroll lock. I typed what you told, but I just heard three beeps (one for Alt+E, one for Alt+F, one for Alt+B).

However, it didn't solve the problem.

One more thing, I know I can use the USB keyboard. But I want to deactivate the other, cause sometimes page up is pressed by itself. It's so annoying!

Commented:
Are you able to take the keyboard out? could be dust, loosen cable, etc.
Commented:
Unlock this solution and get a sample of our free trial.
(No credit card required)
UNLOCK SOLUTION

Author

Commented:
Thanks. But removing the keyboard is my last option.

I just wanna try to deactivate the keyboard and use the USB one. Is it possible?

Commented:
In the page 73:
http://support.dell.com/support/edocs/systems/ins1501/en/om_en/pdf/HN926A01MR.pdf

Try see if you could fix the issue with internal keyboard.

Also, when you plug in the usb keyboard and use it as primary device, you should enable usb legacy (or usb keyboard) in bios first.

Author

Commented:
Didn't work.

I tried to remove the keyboard, but I do not have a small enough screwdriver!

I'm gonna take the notebook to a friend's house later. Apparently he has all the tools I need.

I'll get back here with some more news!

Author

Commented:
I opened the notebook and disconnected the internal keyboard for now. I'm using the USB one. I'll post back when I find out the cause of the problem.
Manager
CERTIFIED EXPERT
Commented:
Unlock this solution and get a sample of our free trial.
(No credit card required)
UNLOCK SOLUTION
Unlock the solution to this question.
Thanks for using Experts Exchange.

Please provide your email to receive a sample view!

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.