?
Solved

Local Security Settings Prevented Admin from Accessing Everything

Posted on 2007-10-12
6
Medium Priority
?
376 Views
Last Modified: 2008-08-26
I changed the 'Security Level' in 'Software Restriction Policy' in the 'Local Security Settings' to 'Disallowed', and deleted all the rules under the 'Additional Rules' folder. The result is that nothing can be run, and all system commands are now disabled!

I cannot run anything, including all control panel applications. The error output if i tried to run any system application is as follows:

"
C:\Windows\system32\rundll32.exe

Windows cannot open this program because it has been prevented by a software restriction policy. For more information, open Event Viewer or contact your system administrator.
"
and I am running as an administrator.

Is there a way to restore the default settings back from safe mode or anything?
0
Comment
Question by:saud82
  • 2
  • 2
5 Comments
 
LVL 32

Expert Comment

by:r-k
ID: 20070268
0
 

Author Comment

by:saud82
ID: 20072466
The problem is that all executalbe file formats are disabled, so I cannot run any exe file. I cannot login to my pc in the first place via the login screen, or Safe Mode. In the normal mode, or safe mode with VGA enabled, It rejects the admin after logging in, and returns the user back to the login screen. In the safe mode, it stucks in the driver/service screen and doesn't run the GUI.

I can only access my pc via recovery console using windows setup. Is there any way to disable the security policies from the console, e.g disableing the service if it runs as a service? Or probably edit the settings from the command prompt?
0
 

Author Comment

by:saud82
ID: 20072752
OK I fixed it!

1. I used Windows Setup CD, and run the Repair Console.
2. Logged in as Admin
3. cd to windows\system32\grouppolicy\Machine
4. renamed Registry.pol to Registry.sav
5. rebooted

This will reset many things in windows, but at least I am in! Thank r-k for your attempt to help.
0
 
LVL 32

Expert Comment

by:r-k
ID: 20072999
OK, I understand. Great that you got it to work. I somewhat misunderstood your original question and thought that you are able to run things in safe mode. Thanks and good luck.
0
 
LVL 1

Accepted Solution

by:
Computer101 earned 0 total points
ID: 22320309
PAQed with points refunded (500)

Computer101
EE Admin
0

Featured Post

[Webinar] Cloud and Mobile-First Strategy

Maybe you’ve fully adopted the cloud since the beginning. Or maybe you started with on-prem resources but are pursuing a “cloud and mobile first” strategy. Getting to that end state has its challenges. Discover how to build out a 100% cloud and mobile IT strategy in this webinar.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

It’s time for spooky stories and consuming way too much sugar, including the many treats we’ve whipped for you in the world of tech. Check it out!
It’s a season to be thankful, and we’re thankful for users like you who engage on site, solve technology problems, and network with others in the industry. What tech are we most thankful for? Keep reading.
We’ve all felt that sense of false security before—locking down external access to a database or component and feeling like we’ve done all we need to do to secure company data. But that feeling is fleeting. Attacks these days can happen in many w…
When cloud platforms entered the scene, users and companies jumped on board to take advantage of the many benefits, like the ability to work and connect with company information from various locations. What many didn't foresee was the increased risk…
Suggested Courses

830 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question