Peer to Peer XP Home network with switch not working.

Posted on 2007-10-13
Last Modified: 2013-11-21
Trying to network two laptops with a switch (peer to peer). Both computers have workgroup set to workgroup.  I set the IP address on laptop1 to be with mask For laptop2, I set the IP address to with mask   The swith shows connctivity and both comptuers show the windows icon as connected to the assigned static IP addresses. Cables work when connecting to the internet.

In My Network Places - View workgroup computers. On laptop1, I show both laptop1 and laptop2 icons. When choosing to open the laptop2 icon I get the error message.  On laptop2, I show only the laptop2 icon.  

Error Message: laptop2 is not accessible. You might not have persmission to use this network resource. Contact the administrator of this server to find out if you have permissions. The network path was not found.

Question by:trgarcia
    LVL 5

    Assisted Solution

    Each system needs it's own ip they can not be the same..     (     (    

    If you want them to get to the internet you will need to set the gateway on both of them to your outside router and make sure you set dns records or they will never resolve the internet.  When you try to access the other you can by typing \\ipaddress sometimes windows has issues resolving...

    Author Comment

    Thank you for you suggestion, however I am not trying to connect to the internet. I am trying to share files between two computers connected to a switch to share files peer to peer only.
    LVL 5

    Accepted Solution

    Correct you said you have both systems with the same ip address? you need to make sure they are different.  What os are you running on them.  For permission problems with XP or 2000 you just need to make sure the account name and password you are using on laptop1 is on laptop2 that is how Microsoft does permissions.  Just make sure both systems have the username and password on the other one and you will solve the permissions problems.
    LVL 2

    Assisted Solution

    Just to reiterate tkfast's point.  In IP communications, each computer _must_ have a different IP address.  Since you are using as the mask, the first 3 numbers (192.168.1) need to match and the number after the last dot (.) must be different.  Think of it this way, if you and tkfast lived at different houses but had the same phone number, how could you call him? -T

    Author Comment

    Sorry for the confusion.  I typed the IP address for computer 2 incorrectly in my original question.  I set the IP address on laptop1 to be with mask For laptop2, I set the IP address to with mask  I just checked my laptops to confirm I did not do the same typo in the IP address. They are corrrect with laptop1 as and laptop2 as  I am now reading the link that  tkfast provided so I can understand why each computer must have the same account name(s) on each computer for sharing.  

    Author Comment

    I read the Microsoft article that tkfast provided and tried adding the user accounts to each computer so they are the same. This did not work.  I added my desktop with XP pro to the hub with IP address and it worked (I was able to share files with laptop1 and the desktop).  It only has a user named desktop. Therefore the theory in the microsoft arcticle is just theory and not fact.

    I decided to ping each computer and found that laptop1 and desktop would properly ping both their IP addresses and the computer host names.  However when pinging laptop2, it would only properly ping to the IP address.  Pinging to the IP address of laptop2 gave an error stating it was not able to resolve the host name.

    I decided I should compare the desktop's local area connetion settings with the local area connection settings of the laptop.  Laptop1 and the desktop have the same settings.  However, laptop2 had an extra protocol in the This connection uses the following items: listing. The extra protocol listed was Microsoft TCP/IP version 6. I unchecked this item and a warning box stated that it would also have to remove Client for Microsoft Networks from the same list. This action removed the check in the check box for Client for Microsoft Networks. Next I rechecked Client for Microsoft Network.  Then I reviewed and list and found that Microsoft TCP/IP version 6 was now unchecked.

    I rebooted laptop2 and tried the connection again. I was then able to view all 3 computers in my network places - view workgroup computers. I was also able to click on each of the workgroup computers and use the shared folders.  

    Featured Post

    6 Surprising Benefits of Threat Intelligence

    All sorts of threat intelligence is available on the web. Intelligence you can learn from, and use to anticipate and prepare for future attacks.

    Join & Write a Comment

    The article explains the protocols and technology which is involved when two computers on different TCP/IP networks communicate with each other. In the diagram, a router is used to segregate two networks. The networks are and 192…
    With the withdrawal of support for Windows Server 2003 this summer, many clients face the issue of moving away from their 2003 installs. There are a few options out there that many people/companies are selling. But the clients I have, haven't wanted…
    Viewers will learn how to properly install and use Secure Shell (SSH) to work on projects or homework remotely. Download Secure Shell: Follow basic installation instructions: Open Secure Shell and use "Quick Connect" to enter credentials includi…
    After creating this article (, I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

    734 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    17 Experts available now in Live!

    Get 1:1 Help Now