Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 7563
  • Last Modified:

Exchange 2007 OWA Login Problem

When logging into Exchange 2007 OWA it comes up with a username and password box rather than the exchange OWA webpage. Any ideas why?

Screen shot of what it comes up with:

http://i225.photobucket.com/albums/dd3/daviex2259/1.jpg

Screen shot of what it should come up with but doesnt:

http://uksbsguy.com/blogs/doverton/WindowsLiveWriter/You.Youveseenaserverupdatewillfixitbutyo_8A0D/image_1.png

Can this be changed?
0
milltechtga
Asked:
milltechtga
  • 5
  • 5
1 Solution
 
scadieuxCommented:
I'm not sure about the behavior in OWA 2007 but in 2003 you get the password/username box if you connect to OWA without SSL (http://www.yourdomain.com/exchange). When you use SSL (httpS://www.yourdomain.com/echange), you get to the OWA webpage. I think this could be the issue you're having. Try opening OWA through a secure session and let me know.
0
 
milltechtgaAuthor Commented:
No change using SSL.
0
 
scadieuxCommented:
Ok. By default, forms-based authentication is not enabled for Outlook Web Access in Exchange2007. Forms-based authentication stores the users user name and password in a cookie instead of in the browser. When the user leaves an OWA session or after the expiration of the inactivity period, the cookie is cleared. As a result, the user must re-authenticate to use OWA again. This is a good security measure.To enable the Outlook Web Access logon page, do the following:

Open the Exchange Management Console.
Choose Server Configuration > Client Access.
Click the Owa (Default Web Site) entry.
From the Action pane, choose the Properties option.
From the Owa (Default Web Site) Properties page, click the Authentication tab.
Under the Use Forms-Based Authentication option there are three options for enforcing a particular logon format. The Domain\User Name option is self-explanatory and is useful if you have multiple domains. The User Principal Name (UPN) option, or e-mail address format, is probably the easiest for users to remember since they use it all the time. The User Name Only option is the last option, which is also self explanatory. If you choose the User Name Only format, you also need to choose a Logon Domain.
Click OK
Because this change affects IIS, you must restart IIS. From a command line on the Outlook Web Access server, issue the command iisreset /noforce.
0
Get your Conversational Ransomware Defense e‑book

This e-book gives you an insight into the ransomware threat and reviews the fundamentals of top-notch ransomware preparedness and recovery. To help you protect yourself and your organization. The initial infection may be inevitable, so the best protection is to be fully prepared.

 
milltechtgaAuthor Commented:
I have done as mentioned. (Using all 3 form types) Now when I browse to the site it comes up saying "There is a problem with this website's security certificate." I click "Continue to this website (not recommended)." and it then says "Internet Explorer cannot display the webpage" If I change the settings back it then comes back up with the username and password box.
0
 
scadieuxCommented:
I would try to generate a new certificate and apply it to OWA...
0
 
milltechtgaAuthor Commented:
I'm not sure how to do that sorry. Any instructions or links that I can follow.
0
 
scadieuxCommented:
Here's is a useful link. Procedure showed is for Exchange 2003 but i assume 2007 must be pretty similar:
http://www.msexchange.org/tutorials/SSL_Enabling_OWA_2003.html
0
 
milltechtgaAuthor Commented:
I can get to about half way through the guide up to "Getting the Pending Request accepted by our Certificate Authority" I type http://servername/certsrv, it asks me for the username and password then says "The website declined to show this webpage" and I cant finsh the guide.
0
 
scadieuxCommented:
Here is Microsoft's explanation of that error message, i hope it helps:

The website declined to show this webpage (HTTP 403)
      

Internet Explorer is able to connect to the website, but Internet Explorer does not have permission to display the webpage. This can happen for a variety of reasons; here are some of the most common:


The website's administrator has to give you permission to view the page or the web server does not accept public webpage requests. If this is a website that you should have access to, contact the website administrator.


The webpage you're trying to view is generated by a program, such as a shopping cart or search engine, and the folder on the server the program is contained in is not correctly configured by the website administrator.


You have typed a basic web address (for example, www.example.com), but the website does not have a default webpage (such as index.htm or default.html). Additionally, the website does not allow directory listing, which allows you to view files in a web folder.
0
 
milltechtgaAuthor Commented:
I have fixed the problem by uninstalling and reinstalling Exchange. Thanks for the help scadieux.
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 5
  • 5
Tackle projects and never again get stuck behind a technical roadblock.
Join Now