• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 208
  • Last Modified:

Keep on getting login dialog box when building asp.net app with IIS

I have an app that worked fine with forms authentication.  
I moved the asp.net website into the asp.net projects folder and amended the IIS virtual directory to point to this. (originally the website was as inetpub but I wanted to make it easier for sourcesafe).

Now when I run the app I keep on getting an IIS dialog login box?  What have I done wrong?  Here is my web.config

 <location path="~/Login.aspx">
    <system.web>
      <authorization>              
        <allow users="*"/>
      </authorization>
    </system.web>
  </location>

which has not changed

0
mugsey
Asked:
mugsey
1 Solution
 
Type25Commented:
Few things...

Make sure ISUR & ASPNET has read access to your new folder
Make sure integrated authentication is NOT ticked
Make sure anonoymous access IS ticked

See if that makes any difference.
0
 
surajgupthaCommented:
Make sure the same virtual directory setting are present even in this new vritual directory you created
0

Featured Post

Vote for the Most Valuable Expert

It’s time to recognize experts that go above and beyond with helpful solutions and engagement on site. Choose from the top experts in the Hall of Fame or on the right rail of your favorite topic page. Look for the blue “Nominate” button on their profile to vote.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now