passwordRecovery control sending email via gmail account problem

I have a PasswordRecovery control and I want to use my own personal gmail account to test that the emails are being sent out.

I've managed to send out a mail using the following code:

 'Build the message
        Dim msg As New System.Net.Mail.MailMessage()
        msg.To.Add("Destination email address goes here")
        msg.From = New MailAddress("myEmailAddress@gmail.com", "Mark", System.Text.Encoding.UTF8)

        msg.Subject = "Test mail using .net2.0"
        msg.SubjectEncoding = System.Text.Encoding.UTF8
        msg.Body = "This is my msg Body"
        msg.BodyEncoding = System.Text.Encoding.UTF8
        msg.IsBodyHtml = False
        msg.Priority = MailPriority.High

        'Add the Creddentials
        Dim Client As New SmtpClient
        Client.Credentials = New System.Net.NetworkCredential("myEmailAddress@gmail.com", "mypassword")

        Client.Port = 587      
        Client.Host = "smtp.gmail.com"
        Client.EnableSsl = True
        'Client.SendCompleted += New SendCompletedEventHandler(client_SendCompleted)
        ' object userState=msg;
        Try
            Client.Send(msg)


        Catch ex As Exception
       

        End Try

I've taken out my email address in the above but it works fine.  The problem is how do I put these settings in the config file rather than in code.  I've used the following:

<system.net>
  <mailSettings>
   <smtp from="myemail@gmail.com">
    <network host="smtp.gmail.com" password="myPassword" port="587"
     userName="myemail@gmail.com" />
   </smtp>
  </mailSettings>
 </system.net>

Again, i've removed my email and password and the username and password are correct but the above doesn't work with the PasswordRecovery control.  I think its because I need to enable SSL but how do i do this in the config file?
fizzer666Asked:
Who is Participating?
 
AutoeformsConnect With a Mentor Commented:
have you validated what your are reading in. that would be the first step.

i believe you may run into a problem at some point and be denied because relaying is not allowed.

i would look to using your current provider and not gmail.

greg
0
 
fizzer666Author Commented:
thanks for the advice.  I have now got it working with a different provider.  I have another question but I'll create a new post.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.