Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 267
  • Last Modified:

I need to configure a modem as a last resort failover on Cisco 2500

I have a question.  I have two WAN connections on my router. 1. A frame relay to corporate. 2. a T1 that goes from a remote site which in turn connects to a frame relay to corporate.  I also have a dial up modem as a failover.  How can I "weight" the modem connection to only be used if both of the high speed circuits are down?

Running config
version 12.2
service timestamps debug uptime
service timestamps log uptime
service password-encryption
service udp-small-servers
service tcp-small-servers
!
hostname STKPERF_R1
!
enable secret 5 $1$alvH$5HfvvXCv1Gangx1cVU5Xv0
enable password 7 00273A352774
!
username MDVBACKUP password 7 13081304095D
ip subnet-zero
no ip domain-lookup
!
ipx routing 0000.0c47.8597
chat-script dialit "" "ATH" TIMEOUT 10 OK "ATDT\T" TIMEOUT 60 CONNECT
chat-script rusr "" "ATV1E0&Q1" TIMEOUT "OK" ""
!
!
!
interface Ethernet0
 description Lan in Stockton Performance Drive
 ip address 128.7.250.0 255.255.0.0
 ip helper-address 128.1.0.29
 ip helper-address 128.1.0.26
 no ip route-cache
 no ip mroute-cache
 ipx network 7
 ipx type-20-propagation
 no mop enabled
!
interface Serial0
 description WAN Link To CalPac (T1)
 ip address 128.206.0.1 255.255.0.0
 no ip mroute-cache
 ipx network 206
 ipx type-20-propagation
 no fair-queue
!
interface Serial1
 description MDV-CPF MCI Frame Relay ZABHTJRV0001 DLCI 120
 no ip address
 encapsulation frame-relay
 no ip route-cache
 no ip mroute-cache
!
interface Serial1.1 point-to-point
 description wan link to Norfolk MCI ZABHNPG40001 DLCI 100
 backup delay 30 30
 backup interface Async1
 ip address 128.207.0.2 255.255.0.0
 no ip route-cache
 no ip mroute-cache
 ipx network 107
 ipx type-20-propagation
 frame-relay class vcperf
 frame-relay interface-dlci 100
!
interface Serial1.2 point-to-point
 description WAN Connection to Chester MCI
 ip address 128.107.0.2 255.255.0.0
 no ip route-cache
 no ip mroute-cache
 ipx network 207
 frame-relay interface-dlci 225
!
interface Async1
 ip address 128.200.0.6 255.255.0.0
 encapsulation ppp
 no ip route-cache
 no ip mroute-cache
 keepalive 10
 dialer in-band
 dialer idle-timeout 300
 dialer wait-for-carrier-time 120
 dialer map ip 128.200.0.1 name MDVBACKUP modem-script dialit broadcast 17578536
852
 dialer map ipx BAC0001.0004.2714.dbc0 name MDVBACKUP modem-script dialit broadc
ast 17578536852
 dialer-group 1
 async default routing
 async dynamic address
 async dynamic routing
 async mode dedicated
 ipx network BAC0001
 no ipx route-cache
 ipx type-20-propagation
 ipx watchdog-spoof
 ppp authentication chap
!
router eigrp 500
 redistribute connected
 network 128.7.0.0
 network 128.107.0.0
 network 128.200.0.0
 network 128.206.0.0
 network 128.207.0.0
 no auto-summary
 no eigrp log-neighbor-changes
!
no ip classless
ip route 0.0.0.0 0.0.0.0 128.207.0.1
no ip http server
!
!
map-class frame-relay vcperf
 frame-relay end-to-end keepalive mode request
 no frame-relay adaptive-shaping
dialer-list 1 protocol ip permit
dialer-list 1 protocol ipx permit
!
!
ipx router eigrp 500
 network BAC0001
 network 7
 network 107
 network 207
 network 206
 log-neighbor-changes
!
!
!
snmp-server engineID local 00000009020000000C8D5DD3
snmp-server community public RO
snmp-server enable traps tty
banner motd ^CC
This system is to be accessed by authorized personnel. Any unauthorized
use of the system is unlawful, and may be subject to civil and/or
criminal penalties. Use of the system may be logged or monitored
without further notice, and the resulting logs may be used as evidence
in court.^C
!
line con 0
line aux 0
 script reset rusr
 modem InOut
 transport input all
 speed 38400
 flowcontrol hardware
line vty 0 4
 password 7 06575D7265603A3A2C
 login
!
end

Thanks
Rich
0
redcell5
Asked:
redcell5
  • 4
  • 2
1 Solution
 
Jan SpringerCommented:
ip route 0.0.0.0 0.0.0.0 128.200.0.6 250
0
 
Jan SpringerCommented:
cancel that:

if the remote end of the dialup is .1:

ip route 0.0.0.0 0 0.0.0.0 128.200.0.1 250
0
 
redcell5Author Commented:
does the 250 at the end make it the last possible interface?
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
redcell5Author Commented:
also jesper_: Do I put that part of the config here:
interface Async1
 ip address 128.200.0.6 255.255.0.0
 encapsulation ppp
 no ip route-cache
 no ip mroute-cache
 keepalive 10
 dialer in-band
 dialer idle-timeout 300
 dialer wait-for-carrier-time 120
 dialer map ip 128.200.0.1 name MDVBACKUP modem-script dialit broadcast 17578536
852
 dialer map ipx BAC0001.0004.2714.dbc0 name MDVBACKUP modem-script dialit broadc
ast 17578536852
 dialer-group 1
 async default routing
 async dynamic address
 async dynamic routing
 async mode dedicated
 ipx network BAC0001
 no ipx route-cache
 ipx type-20-propagation
 ipx watchdog-spoof
 ppp authentication chap
0
 
Jan SpringerCommented:
config t

ip route 0.0.0.0 0 0.0.0.0 128.200.0.1 250
end

wr mem

This gives you two static routes.  The weight of 250 means deprefer this route over any other default static route (like the one in your configt) or interior routing protocol.  Use it as a last resort.
0
 
Jan SpringerCommented:
An additional comment:  During a maintenance window (low-peak time), go on-site to where the router is located and shutdown your primary default route to verify that the traffic is, indeed, failing over to the dialup.
0

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 4
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now