[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 5541
  • Last Modified:

Can't register MAPI32.dll DllRegisterServer entry point was not found

I work for the Society for the Prevention of Cruelty to Animals.  We don't have the money to have someone set this up for us so I've attempted it.  I've set up a Blackberry Enterprise Server and we have only one user.  The Blackberry can receive fine but won't send.  In the logs on the Server it states that the MAPIMailbox Send failed.  When I try to run regsvr32 c:\windows\system32\mapi32.dll, it gets the message DllRegisterServer entry point was not found, This file can not be registered.  This is critical because our President leaves tomorrow for Sacramento and she must take it with her.  Any help would be appreciated.

0
J.R. Sitman
Asked:
J.R. Sitman
1 Solution
 
duffman76Commented:
This relates to the other question which I answered wrong on the mapi.  You cannot register this file manually it is registered when you install the exchange system tools.  As was proved by your original problem getting solved wihout this.  

Glad it is working.
0
 
BlackBerryLinks_comCommented:
The problem with not sending is a rights problem. Look if the BESadmin has Send As rights on the blackberry users mailbox.

http://blackberry.com/sendas
Regards,
Bob
0

Featured Post

Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

Tackle projects and never again get stuck behind a technical roadblock.
Join Now