• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 9447
  • Last Modified:

iSCSI configuration problem on Windows XP

I can't add a target portal using Microsoft iSCSI initiator on Windows XP.  I've installed the MS initiator (version 2.05)on an XP (SP2) desktop and I'm attempting to add the target. I've entered the IP address of the iSCSI target and accepted the default Port of 3260.  I'm getting an error "Connection Failed" in a small dialog and the application log shows an Event ID 1 for iScsiPrt [Initiator failed to connect to the target]  and Event ID 113 in MSiSCSI [iSCSI discovery via SendTargets failed 0xefff0003 to target portal].

I've confirmed that the Windows firewall is not enabled, and I have confirmed that I can send ICMP (pings & traceroute) to the Target address.  This doesn't look complicated, but it isn't working.  What else should I try?  
0
david_reaves
Asked:
david_reaves
  • 2
1 Solution
 
kkransCommented:
Simply, the communication does not happen. I would guess that there is an issue with the target. What kind of target you are using?

Check the port is same on the target as well as there is no iSNS server configured (unless you want one)

I have worked with iSCSI a lot last few years, the MS initiator hardly fail so I would guess the problem is at the target. Try also to connect with a crossover cable to see if there might be some kind of issue between the target and initiator
0
 
david_reavesAuthor Commented:
The system is a linux-based storage appliance for disk-to-tape backup. It's a beta, so it isn't really well documented. The target as the problem would have been my thought, but a system that one of our test engineers uses that has an initiator installed already was able to connect easily.  Can you suggest anything else I should try besides checking the ports?

0
 
david_reavesAuthor Commented:
The issue is the hardware port on the target device.  It's odd, because it does ping correctly.  When I connected the second target port (which hadn't been connected to the network), I was able to configure the iSCSI initiator for that port without issue.
0

Featured Post

New feature and membership benefit!

New feature! Upgrade and increase expert visibility of your issues with Priority Questions.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now