Optimizing MTU for NFS

I have been configuring a site to site VPN using a cisco router (with the help of some experst on EE)

I now have the vpn tunnel functioning and stable, the networks are also routing fine. I have had to lower the MTU settings to get the data trasfer to work.

My quiestion is that is there a way of optimising this especially for NFS transfer? or is it more trial and error.

I have been changing MTU and MSS values and the trasfer does work, however it appears to stall and then retry, so the amount of data jumps in big blocks. It seems as if the retry time gets larger and larger untill it hangs completely.

We have found that at different MTU settings the data only writes the file header and hangs, other times it stops at 800k?

I can ping the down the VPN with packet sizes of upto 1472. I am using a cisco 878 on an SDSL line, to a Netgear router. We are copying from a Redhat server to a Ready NAS device.
Paul BrooksAsked:
Who is Participating?
 
lausengdnCommented:
Redhat calls "BlackHole Discovery"  "Path MTU discovery" they say it's configured automatically.
see this info:
http://kbase.redhat.com/faq/FAQ_40_4378.shtm

You said you were changing your MTU so you may know the following info already.
http://kbase.redhat.com/faq/FAQ_45_4380.shtm

I would look at replacing the network cards involved.
If this problem is happening across many pc's the server network card is probably the problem.
If it's only happening on a test pc your using the network card in that pc might be the problem.

I have not had as much success with this problem configuring firewalls or routers as I have had configuring the MTU settings on workstations and servers themselves.
0
 
lausengdnCommented:
You may want to also set black hole detection with the following registry settings.
I have found this helps the situation.
There may be a router on the internet between your workstation and your network causing problems.

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters]
"EnablePMTUBHDetect"=dword:00000001

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters]
"EnablePMTUDiscovery"=dword:00000001
0
 
Paul BrooksAuthor Commented:
can this help? we are using redhat? to a linux based NAS box?
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

 
nedvisCommented:
How do I set the MTU for my network interface? ( RedHat )
http://www.redhat.com/magazine/002dec04/departments/tips_tricks/
0
 
Paul BrooksAuthor Commented:
this is not answering the question i am asking! why the file appears to write in blocks of data, and hangs at 800k?
0
 
lausengdnCommented:
If your packets encounter a router that has it's mtu set very low your packets will become fragmented to the point the VPN no longer can reassemble them. Some VPN's handle it better than others.
You may not always encounter this router so when you do ping tests they frequently go un-detected.
Black hole detection works to discover these routers and drops the packet MTU size dynamically to get past this router.
Another thing you might try is replacing the network cards involved on the server/workstation.
I have seen this as the cause of the problem also.
VPN connections are very picky and having a file stop or fail at a particular size like 800k is a classic symptom of this problem.
0
 
Paul BrooksAuthor Commented:
what i mean is you have given my registry vaules for windows? i am wokring in a linux environment, it there a wat to either set this on the router (cisco 878) or linux server?
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.