• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 4515
  • Last Modified:

IIS - Click Once The remote server returned an error: (404) Not Found.

I use IIS to deploy my click once application. It first diplayed an error that a file of type isl couldnt be found. I add that extension to the mime headers and it let that file download. But now it is stuck at a file with extension EXE. No matter what MIME header i add, it still says the 404 not found.
I even tried * to indicate that all file extensions can be downloaded.
0
surajguptha
Asked:
surajguptha
  • 3
  • 2
1 Solution
 
jsakhtarCommented:
Have it add the ".deploy" extenstion in the click-once settings of your project.

Publish/Options/Use Deploy Extension = checked
0
 
surajgupthaAuthor Commented:
Why do we need to check this?
0
 
jsakhtarCommented:
So it puts a .deploy extension at the end of all the files which allows web servers to handle otherwise restricted file types like exe.
0
 
surajgupthaAuthor Commented:
coool. Thanks. You are sure of this?
0
 
jsakhtarCommented:
That is it's purpose yes.
0

Featured Post

Free recovery tool for Microsoft Active Directory

Veeam Explorer for Microsoft Active Directory provides fast and reliable object-level recovery for Active Directory from a single-pass, agentless backup or storage snapshot — without the need to restore an entire virtual machine or use third-party tools.

  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now