?
Solved

Pix 501 - can't pass traffic when Static statements are on

Posted on 2007-10-16
2
Medium Priority
?
239 Views
Last Modified: 2010-04-09
We had a Cisco send us a replacement Pix 501, version 6.3(5) as our old unit with version 6.3(4) had a faulty power connector.

I pretty much copied and pasted the config from the old unit to the new one.  However with the new Pix the mail server (at 192.168.1.20) can't pass traffic to the outside when the static (inside,outside) statement is on.
As soon as I take out the static statement it passes traffic fine.

When I put the old pix back, the mail server can reach the internet with the static statement on.  

Am I missing something or is there a difference between 6.3(4) and 6.3(5).  I have a feeling I'm missing something really simple but I can't see it.  

Thanks in advance!

Here are pix configs:

New Pix (not working with static statement on):

PIX Version 6.3(5)
interface ethernet0 10baset
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password y29VkzYz9FM7Kxs1 encrypted
passwd y29VkzYz9FM7Kxs1 encrypted
hostname balapx1
domain-name HOME.com
no fixup protocol dns
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
no fixup protocol http 80
fixup protocol ils 389
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
no fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list 101 permit ip 192.168.1.0 255.255.255.0 192.168.10.0 255.255.255.0
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside AA.BB.CC.146 255.255.255.0
ip address inside 192.168.1.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool bavpnip 192.168.10.1-192.168.10.254
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list 101
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
static (inside,outside) AA.BB.CC.147 192.168.1.20 netmask 255.255.255.255 0 0
static (inside,outside) AA.BB.CC.148 192.168.1.165 netmask 255.255.255.255 0 0
conduit permit icmp any any
conduit permit tcp host AA.BB.CC.147 eq smtp any
conduit permit tcp host AA.BB.CC.147 eq www any
conduit permit tcp host AA.BB.CC.147 eq 9611 any
conduit permit tcp host AA.BB.CC.147 eq ftp any
conduit permit tcp host AA.BB.CC.148 gt 1 any
conduit permit udp host AA.BB.CC.148 gt 1 any
route outside 0.0.0.0 0.0.0.0 AA.BB.CC.1 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout sip-disconnect 0:02:00 sip-invite 0:03:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
http server enable
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set batrans esp-des esp-md5-hmac
crypto dynamic-map badyn 10 set transform-set batrans
crypto map ba 10 ipsec-isakmp dynamic badyn
crypto map ba interface outside
isakmp enable outside
isakmp identity address
isakmp policy 10 authentication pre-share
isakmp policy 10 encryption des
isakmp policy 10 hash md5
isakmp policy 10 group 2
isakmp policy 10 lifetime 86400
vpngroup BAVPN address-pool bavpnip
vpngroup BAVPN dns-server 192.168.1.20
vpngroup BAVPN wins-server 192.168.1.20
vpngroup BAVPN default-domain HOME.com
vpngroup BAVPN split-tunnel 101
vpngroup BAVPN idle-time 1800
vpngroup BAVPN password ********
telnet 192.168.1.0 255.255.255.0 inside
telnet timeout 60
ssh 0.0.0.0 0.0.0.0 outside
ssh timeout 5
console timeout 0
dhcpd address 192.168.1.100-192.168.1.131 inside
dhcpd dns 192.168.1.20
dhcpd wins 192.168.1.20
dhcpd lease 3600
dhcpd ping_timeout 750
dhcpd auto_config outside
dhcpd enable inside

Old pix (working with static statement)

PIX Version 6.3(4)
interface ethernet0 10baset
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password y29VkzYz9FM7Kxs1 encrypted
passwd y29VkzYz9FM7Kxs1 encrypted
hostname balapx1
domain-name HOME.com
no fixup protocol dns
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
no fixup protocol http 80
fixup protocol ils 389
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
no fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list 101 permit ip 192.168.1.0 255.255.255.0 192.168.10.0

255.255.255.0
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside AA.BB.CC.146 255.255.255.0
ip address inside 192.168.1.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool bavpnip 192.168.10.1-192.168.10.254
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list 101
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
static (inside,outside) AA.BB.CC.147 192.168.1.20 netmask

255.255.255.255 0 0
static (inside,outside) AA.BB.CC.148 192.168.1.165 netmask

255.255.255.255 0 0
conduit permit icmp any any
conduit permit tcp host AA.BB.CC.147 eq smtp any
conduit permit tcp host AA.BB.CC.147 eq www any
conduit permit tcp host AA.BB.CC.147 eq 9611 any
conduit permit tcp host AA.BB.CC.147 eq ftp any
conduit permit tcp host AA.BB.CC.148 gt 1 any
conduit permit udp host AA.BB.CC.148 gt 1 any
route outside 0.0.0.0 0.0.0.0 AA.BB.CC.1 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225

1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set batrans esp-des esp-md5-hmac
crypto dynamic-map badyn 10 set transform-set batrans
crypto map ba 10 ipsec-isakmp dynamic badyn
crypto map ba interface outside
isakmp enable outside
isakmp identity address
isakmp policy 10 authentication pre-share
isakmp policy 10 encryption des
isakmp policy 10 hash md5
isakmp policy 10 group 2
isakmp policy 10 lifetime 86400
vpngroup BAVPN address-pool bavpnip
vpngroup BAVPN dns-server 192.168.1.20
vpngroup BAVPN wins-server 192.168.1.20
vpngroup BAVPN default-domain HOME.com
vpngroup BAVPN split-tunnel 101
vpngroup BAVPN idle-time 1800
vpngroup BAVPN password ********
telnet 192.168.1.0 255.255.255.0 inside
telnet timeout 60
ssh 0.0.0.0 0.0.0.0 outside
ssh timeout 5
console timeout 0
dhcpd address 192.168.1.100-192.168.1.131 inside
dhcpd dns 192.168.1.20
dhcpd wins 192.168.1.20
dhcpd lease 3600
dhcpd ping_timeout 750
dhcpd enable inside
terminal width 80

0
Comment
Question by:smocohiba
2 Comments
 
LVL 5

Assisted Solution

by:Darkstriker69
Darkstriker69 earned 1000 total points
ID: 20089719
Wow, havent seen conduits in a while.

You might try

static (inside,outside) tcp AA.BB.CC.147 smtp 192.168.1.20 smtp netmask 255.255.255.255 0 0

as long as you only need mail comming in, you might have to make additional static statements as I see your conduits allow www, ftp and other traffic. Eventually you might want to replace conduits with access lists.
0
 

Accepted Solution

by:
smocohiba earned 0 total points
ID: 21287749
Holy cow - didn't realize this question was still open!

The 'new' replacement pix (it was a refurb from Cisco) ended up being a lemon - we tested it at several different sites and it could never pass traffic.   We put in a third pix 501 and it worked fine.  Thanks for the help though!

0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Many of the companies I’ve worked with have embraced cloud solutions due to their desire to “get out of the datacenter business.” The ability to achieve better security and availability, and the speed with which they are able to deploy, is far grea…
During and after that shift to cloud, one area that still poses a struggle for many organizations is what to do with their department file shares.
As a trusted technology advisor to your customers you are likely getting the daily question of, ‘should I put this in the cloud?’ As customer demands for cloud services increases, companies will see a shift from traditional buying patterns to new…
Both in life and business – not all partnerships are created equal. Spend 30 short minutes with us to learn:   • Key questions to ask when considering a partnership to accelerate your business into the cloud • Pitfalls and mistakes other partners…
Suggested Courses
Course of the Month16 days, 6 hours left to enroll

850 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question