Problems with LAN connection, limited internet access

Hi,
i am having a problem with internet connection on some computers on our local domain.  They are both laptops.  The configuration is as follows:
SBS Server 2003 2 NIC, workstations connected to switch which is connected to server LAN with DHCP enabled on server.  The desktops are getting full connections, the laptops however are only able to access google.  Any other sites will not load.  They are getting IP addresses in the correct range.  Also if I disable the LAN on the laptop and connect directly to the router using wireless internet works like a dream.  I am running out of ideas, any suggestions?

Thanks.
kathharrisAsked:
Who is Participating?
 
chaferConnect With a Mentor Commented:
Ok, I vote for throwing the laptops out the window - just kidding - I think!

As a test, try setting the DNS server manually on the laptops to 4.2.2.1.  This is a reliable AT&T DNS server that works from virtually any network.  If the problems go away, you know that it is DNS resolution issues.  If they are still there, it points elsewhere.

By the way, the diagnostics you mentioned are expected if there are problems getting to the Internet.
0
 
chaferCommented:
Are the DNS servers on the laptops set manually?  This can override DHCP settings and you may find that the DNS servers on the laptop are slow to respond from your network.  Just make sure that the DNS server addresses are being dispersed to the laptops as well.  You can always do an IPCONFIG /ALL to verify what DNS servers are being passed out.
0
 
chaferCommented:
One thing I should have added is that you may get to Google only because the address is cached either on the laptop or a specific DNS server.  Since it is such a popular site, it is likely that it is in the caches.  The point is that for other sites, resolution may be slow enough that it is causing problems for non-cached sites.
0
Protect Your Employees from Wi-Fi Threats

As Wi-Fi growth and popularity continues to climb, not everyone understands the risks that come with connecting to public Wi-Fi or even offering Wi-Fi to employees, visitors and guests. Download the resource kit to make sure your safe wherever business takes you!

 
illuzianCommented:
You may also want to attempt to manually set a DNS address(you probably know how to do this):

Under TCP/IP properties of the NIC leave IP to auto and set DNS to manually:
Try something like the DNS address 203.0.178.191 and see if it can browse.

If you have no internal DNS server and don't need to resolve LAN addresses just leave it standard, if you do have an internal resolver set the primary to the resolver.

If this still isn't working run:
ipconfig /flushdns
netsh i i r log.txt (or netsh int ip reset log.txt)
Also check your windows hosts file on the machine located at: C:\WINDOWS\SYSTEM32\DRIVERS\ETC
0
 
kathharrisAuthor Commented:
Thanks for the help but still no joy.

The IP config matches the desktops.  I have checked the hosts file and it is the same as on the desktops.  It also won't browse ant better with a different DNS server. Any other suggestions other than throught he laptop through the window?

Kath.
0
 
chaferCommented:
You mentioned that the laptops have wireless connections as well.  Have you tried disabling the wireless and then seeing if things work.  If the wireless ends up on the same subnet as the wired, that could cause problems.  Also, if the laptops are trying to use the wireless as the gateway, that could also cause problems.
0
 
illuzianCommented:
I know it sounds stupid but try with a different network cable, sometimes this can work wonders. Otherwise:
-Try manually setting the IPs for DNS, IP, and Gateway as a test(not just DNS)
-Disable firewalls on the machine
-Obvious checks for spyware and malware
-Check default route type: route print

          0.0.0.0          0.0.0.0    gateway    interface      20

And make sure the gateway is the IP of the router.
0
 
kathharrisAuthor Commented:
The wireless is disabled.  I checked it connected by disbaling the LAN.  Wireless connects straight to the router and works fine, it is only the LAN connection thru the SBS that I am having problems with.  

I ran the network adapter diagnostic in IE and got the following warnings and errors if this helps:

warn HTTPS:Error 12037 connecting to www.passport.net: The date in the certificate is invalid or has expired

warn HTTPS: Error 12002 connecting to www.microsoft.com: The operation timed out

error Could not make an HTTPS connection
0
 
kathharrisAuthor Commented:
Ok, have tried changing cables and ports in the switch, manually setting IP etc.  The route print matches the desktops and I also tried the 4.2.2.1 DNS server still no joy.  I think I might reformat and reinstall XP!
0
 
illuzianConnect With a Mentor Commented:
Do you have a spare PMCIA NIC for the laptop to ensure its not the NIC?
0
 
kathharrisAuthor Commented:
Thats an idea.  I don't have one here but I do at home so I'll bring it in tomorrow.. For know I am going to replace the main laptop that's causing problems with a spare desktop. Thanks for your help guys.  I'll let you know if the other NIC works.
0
 
kathharrisAuthor Commented:
OK put in a USB NIC and no difference which makes me thing it is something to do with SBS 2003.  Any clues?
0
 
illuzianCommented:
Could it be to do with the licensing in SMB ie: http://www.flexbeta.net/forums/lofiversion/index.php/t3050.html 
0
 
kathharrisAuthor Commented:
Thanks Illuzian. I had a look at the article and it sounds like my problem exactly.  I don't understand how to change those licencing options or if it is applicable to SBS 2003.  We only have the one server and 5 workstations so I would have thought we should be within in our licence.
0
 
illuzianCommented:
From what I can see you can try:

On the server:
Going to license manager in control panel
set licensing server
Set the client count to 99999.
Go to start then run type in services.msc -> find licensing service and disable.(leave to start on auto_

If this resolves the issue maybe the licenses aren't being released?

0
 
kathharrisAuthor Commented:
Back again.  I can't change those licence settings in SBS 2003.

I've had a little think and am wondering if it has anything to do with the fact that the laptops both have wireless connections as well as LAN.  I have tried disabling the wireless while connected to the LAN but it doesn't seem to make any difference.  This is the only thing I can think of that is different to the desktops.
0
 
kathharrisAuthor Commented:
Hi guys,
I thought it time I closed this question.  The problem was never solved.  i replaced the server though and it likes laptops.  Go figure.  I think it must have been some sad obscure problem.  So in thanks for your efforts I have split the points evenly.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.