?
Solved

How to diagnose errors on serial ports of a cisco router?

Posted on 2007-10-16
4
Medium Priority
?
646 Views
Last Modified: 2012-08-13
Hi,
We have two cisco 2800 routers connecting two locations through a point to point line.  The remote location uses the router for both an inter-tel phone system and internet through the main location.  The internet at the remote works fine for a few days then gets very slow until I reload the routers then it works fine for a few more days.  I did a sho int on both routers and there are a lot of errors on the serial ports.  What do I need to do to see what is causing the errors?  Here are the config files from both routers and the sho int from both routers.  Thanks for any help.


Building configuration...

Current configuration : 4075 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Brown
!
boot-start-marker
boot-end-marker
!
logging buffered 51200 warnings
!
no aaa new-model
!
resource policy
!
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
ip subnet-zero
ip cef
!
!
no ip dhcp use vrf connected
!
ip dhcp pool brown
   network 192.168.2.0 255.255.255.0
   default-router 192.168.2.1
   dns-server 209.63.0.6 207.173.86.6
   lease 0 4
!
!
!
voice-card 0
!
!
!
!
!
!
!
!
!
!
!
!
!
crypto pki trustpoint TP-self-signed-945358262
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-945358262
 revocation-check none
 rsakeypair TP-self-signed-945358262
!
!
crypto pki certificate chain TP-self-signed-945358262
 certificate self-signed 01
  30820242 308201AB A0030201 02020101 300D0609 2A864886 F70D0101 04050030
  30312E30 2C060355 04031325 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 39343533 35383236 32301E17 0D303730 36323531 39343631
  355A170D 32303031 30313030 30303030 5A303031 2E302C06 03550403 1325494F
  532D5365 6C662D53 69676E65 642D4365 72746966 69636174 652D3934 35333538
  32363230 819F300D 06092A86 4886F70D 01010105 0003818D 00308189 02818100
  F868A5FA 1FEA748E C41BE5BD 48BA8B5D D40146E0 1E7D2193 FBC3CA08 D99DF860
  B2E81802 F6F04919 5DD3E722 DBF33E17 C5397F02 5F01D2F1 6EB639E8 47EA8DD7
  31A235E6 C2798771 85367FD8 616C388D C2E81CA4 49E264C4 7E6CA13E D564EA20
  D67F32B4 D8EDDFD2 5D1BCA79 FB557EFE 9F22425A 4F273926 7A65D40D D4CA37C1
  02030100 01A36C30 6A300F06 03551D13 0101FF04 05300301 01FF3017 0603551D
  11041030 0E820C42 726F776E 4F666669 63652E30 1F060355 1D230418 30168014
  B4DB3518 5ECF21B7 1393C598 AC5A0194 4BB4EDB2 301D0603 551D0E04 160414B4
  DB35185E CF21B713 93C598AC 5A01944B B4EDB230 0D06092A 864886F7 0D010104
  05000381 810087E1 EFD0816D DDA5B5CA 2F993F91 5AA3608D 8F323837 DB6A36F5
  FCA6A15E 92D291EB FDFE1FEF C94D7BB7 F8B64F55 5C07DA95 A9284295 4DADCD8C
  C9CBC026 88C46036 EDE1039B FFCBC51A FD27E7FA F4921ED0 499616D2 ABE44162
  5838A747 73BCDD45 6DF38C5F 6E3AFB4C 34F14A69 F718F994 030AE64E D1C33F90
  0EF9CEEF BAC2
  quit
username redbrick privilege 15 secret 5 $1$S9wv$XkVobaHgLQ0Iik39zWi6s.
!
!
class-map match-any AutoQoS-VoIP-control
class-map match-all intertel_VoIP_servers
 match any
class-map match-all phone-policy
 match ip dscp af41
class-map match-all intertel_VoIP
 match ip dscp ef
class-map match-any AutoQos-VoIP-RTP-Trust
 match ip dscp ef
class-map match-any AutoQos-VoIP-control-trust
 match ip dscp cs3
 match ip dscp af31
!
!
policy-map AutoQoS-Policy-Trust
 class AutoQoS-VoIP-control
  bandwidth percent 5
 class AutoQos-VoIP-RTP-Trust
  priority percent 70
 class AutoQos-VoIP-control-trust
  bandwidth percent 5
 class class-default
  fair-queue
policy-map intertel_VoIP_servers
 class intertel_VoIP_servers
  set ip dscp ef
policy-map phone-policy
 class phone-policy
  priority 1382 90000
 class intertel_VoIP
  priority 410
 class class-default
  fair-queue
!
!
!
!
interface FastEthernet0/0
 description Connected to LAN
 ip address 192.168.2.1 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 192.168.3.1 255.255.255.0
 speed 100
 full-duplex
 service-policy output phone-policy
!
interface Serial0/1/0
 bandwidth 1800
 ip address 10.0.0.2 255.255.255.0
 max-reserved-bandwidth 100
 service-policy output phone-policy
!
router rip
 version 2
 network 10.0.0.0
 network 192.168.2.0
 network 192.168.3.0
!
ip classless
ip route 0.0.0.0 0.0.0.0 10.0.0.1
!
!
no ip http server
ip http access-class 23
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
 access-class 23 in
 privilege level 15
 login local
line aux 0
line vty 0 4
 access-class 23 in
 privilege level 15
 login local
 transport input telnet ssh
line vty 5 15
 access-class 23 in
 privilege level 15
 login local
 transport input telnet ssh
!
end

South#sho run
Building configuration...

Current configuration : 4067 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname South
!
boot-start-marker
boot-end-marker
!
logging buffered 51200 warnings
enable secret 5 $1$Es9w$ENT7ffVr6xBrMsfCUAVeE/
!
no aaa new-model
!
resource policy
!
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
ip subnet-zero
ip cef
!
!
!
!
ip domain name yourdomain.com
ip name-server 205.171.2.65
ip name-server 205.171.3.65
!
voice-card 0
!
!
!
!
!
!
!
!
!
!
!
!
!
crypto pki trustpoint TP-self-signed-1272863612
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-1272863612
 revocation-check none
 rsakeypair TP-self-signed-1272863612
!
!
crypto pki certificate chain TP-self-signed-1272863612
 certificate self-signed 01
  30820255 308201BE A0030201 02020101 300D0609 2A864886 F70D0101 04050030
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 31323732 38363336 3132301E 170D3036 30363230 32313438
  30355A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D31 32373238
  36333631 3230819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
  8100BBB7 EC8932EE 59CB98D6 08ABFC37 0B18104F AD3A7B88 21147879 4D303D22
  F5913FA1 47B34492 C3E03882 BAB2FC1C 92771FBB 05911A41 A0A950E0 60B4A76F
  E760AA81 765B485C 020F0F94 259987EA 0AFF4251 E0F67329 6A2F6F2B BF08C9EC
  BB626EC3 DDE6F83A 324A7338 2AAF8269 522076A8 7121E4A4 4FCC6F97 1A9C212D
  4ACD0203 010001A3 7D307B30 0F060355 1D130101 FF040530 030101FF 30280603
  551D1104 21301F82 1D536F75 74686572 6E4F6666 6963652E 796F7572 646F6D61
  696E2E63 6F6D301F 0603551D 23041830 168014D9 51D3E69B 186F0AB5 FA409D5A
  CC0E1CBF A199A930 1D060355 1D0E0416 0414D951 D3E69B18 6F0AB5FA 409D5ACC
  0E1CBFA1 99A9300D 06092A86 4886F70D 01010405 00038181 00AC4070 C0C523C5
  06DDC4DC C1961A51 ED8E3A36 9E889094 0BA0459B 83F45440 C5930CE1 7C7A97F2
  9FD7AE1B F8A1A5CB 4E561BDB 1AE8B1AC 132CA52E A3FDD1E5 B8E70BD9 DDDE44AF
  E7798735 E5D3EE98 ED453C6C 7841118A A13D861F 614BB756 8C670A92 674AF25E
  9DF891E2 C30B5798 F752E820 53474454 426886B3 0D82ED16 1C
  quit
username redbrick privilege 15 secret 5 $1$.SRu$9mssid.0/szwnZdzNiWBl/
!
!
class-map match-any AutoQoS-VoIP-control
class-map match-all intertel_VoIP_servers
 match any
class-map match-all phone-policy
 match ip dscp af41
class-map match-all intertel_VoIP
 match ip dscp ef
class-map match-any AutoQos-VoIP-RTP-Trust
 match ip dscp ef
class-map match-any AutoQos-VoIP-control-trust
 match ip dscp cs3
 match ip dscp af31
!
!
policy-map AutoQoS-Policy-Trust
 class AutoQoS-VoIP-control
  bandwidth percent 5
 class class-default
  fair-queue
policy-map Intertel_VoIP_Servers
policy-map phone-policy
 class phone-policy
  priority 1382 90000
 class intertel_VoIP
  priority 410
 class class-default
  fair-queue
!
!
!
!
interface FastEthernet0/0
 description Connection to LAN
 ip address 192.168.0.3 255.255.255.0
 speed 100
 full-duplex
!
interface FastEthernet0/1
 ip address 192.168.1.1 255.255.255.0
 speed 100
 full-duplex
 service-policy output phone-policy
!
interface Serial0/1/0
 bandwidth 1800
 ip address 10.0.0.1 255.255.255.0
 max-reserved-bandwidth 100
 service-policy output phone-policy
!
router rip
 version 2
 network 10.0.0.0
 network 192.168.0.0
 network 192.168.1.0
 network 192.168.2.0
 network 192.168.3.0
!
ip classless
ip route 0.0.0.0 0.0.0.0 FastEthernet0/0
!
!
no ip http server
ip http access-class 23
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
access-list 1 permit 192.168.0.0 0.0.255.255
access-list 23 permit 10.0.0.0 0.0.0.7
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
 access-class 23 in
 privilege level 15
 login local
line aux 0
line vty 0 4
 access-class 23 in
 privilege level 15
 login local
 transport input telnet ssh
line vty 5 15
 access-class 23 in
 privilege level 15
 login local
 transport input telnet ssh
!
end

South#



FastEthernet0/0 is up, line protocol is up
  Hardware is Gt96k FE, address is 0018.1876.5c0e (bia 0018.1876.5c0e)
  Description: Connected to LAN
  Internet address is 192.168.2.1/24
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 100Mb/s, 100BaseTX/FX
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:02, output 00:00:01, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 3000 bits/sec, 3 packets/sec
  5 minute output rate 11000 bits/sec, 2 packets/sec
     2875176 packets input, 390095383 bytes
     Received 660963 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog
     0 input packets with dribble condition detected
     3313776 packets output, 3721571039 bytes, 0 underruns
     0 output errors, 0 collisions, 3 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out
FastEthernet0/1 is up, line protocol is up
  Hardware is Gt96k FE, address is 0018.1876.5c0f (bia 0018.1876.5c0f)
  Internet address is 192.168.3.1/24
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 100Mb/s, 100BaseTX/FX
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:10:42, output 00:00:01, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: Class-based queueing
  Output queue: 0/1000/64/0 (size/max total/threshold/drops)
     Conversations  0/2/256 (active/max active/max total)
     Reserved Conversations 0/0 (allocated/max allocated)
     Available Bandwidth 73208 kilobits/sec
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     2675815 packets input, 915800405 bytes
     Received 463 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog
     0 input packets with dribble condition detected
     2789280 packets output, 937729736 bytes, 0 underruns
     0 output errors, 0 collisions, 5 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out
Serial0/1/0 is up, line protocol is up
  Hardware is GT96K with integrated T1 CSU/DSU
  Internet address is 10.0.0.2/24
  MTU 1500 bytes, BW 1800 Kbit, DLY 20000 usec,
     reliability 202/255, txload 1/255, rxload 1/255
  Encapsulation HDLC, loopback not set
  Keepalive set (10 sec)
  Last input 00:00:00, output 00:00:00, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: Class-based queueing
  Output queue: 0/1000/64/0 (size/max total/threshold/drops)
     Conversations  0/19/256 (active/max active/max total)
     Reserved Conversations 0/0 (allocated/max allocated)
     Available Bandwidth 8 kilobits/sec
  5 minute input rate 12000 bits/sec, 2 packets/sec
  5 minute output rate 3000 bits/sec, 2 packets/sec
     6001095 packets input, 291556085 bytes, 0 no buffer
     Received 60666 broadcasts, 0 runts, 63042 giants, 0 throttles
     8076691 input errors, 8076686 CRC, 4153304 frame, 1404251 overrun, 0 ignored, 3349858 abort
     4961607 packets output, 1187180723 bytes, 0 underruns
     0 output errors, 0 collisions, 5 interface resets
     0 output buffer failures, 0 output buffers swapped out
     1 carrier transitions
     DCD=up  DSR=up  DTR=up  RTS=up  CTS=up

Brown#telnet 10.0.0.1
Trying 10.0.0.1 ... Open


User Access Verification

South#sho int
FastEthernet0/0 is up, line protocol is up
  Hardware is Gt96k FE, address is 0017.e083.b17c (bia 0017.e083.b17c)
  Description: Connection to LAN
  Internet address is 192.168.0.3/24
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 100Mb/s, 100BaseTX/FX
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:00, output 00:00:01, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 11000 bits/sec, 5 packets/sec
  5 minute output rate 1000 bits/sec, 3 packets/sec
     133919850 packets input, 3305313966 bytes
     Received 15839557 broadcasts, 0 runts, 0 giants, 0 throttles
     20717 input errors, 20717 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog
     0 input packets with dribble condition detected
     159229858 packets output, 300553715 bytes, 0 underruns
     0 output errors, 0 collisions, 57 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out
FastEthernet0/1 is up, line protocol is up
  Hardware is Gt96k FE, address is 0017.e083.b17d (bia 0017.e083.b17d)
  Internet address is 192.168.1.1/24
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 100Mb/s, 100BaseTX/FX
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:09:32, output 00:00:03, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: Class-based queueing
  Output queue: 0/1000/64/0 (size/max total/threshold/drops)
     Conversations  0/2/256 (active/max active/max total)
     Reserved Conversations 0/0 (allocated/max allocated)
     Available Bandwidth 73208 kilobits/sec
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 1 packets/sec
     55452220 packets input, 1534448505 bytes
     Received 8715 broadcasts, 0 runts, 0 giants, 0 throttles
     53312 input errors, 53312 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog
     0 input packets with dribble condition detected
     55381386 packets output, 1077205467 bytes, 0 underruns
     0 output errors, 0 collisions, 162 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out
Serial0/1/0 is up, line protocol is up
  Hardware is GT96K with integrated T1 CSU/DSU
  Internet address is 10.0.0.1/24
  MTU 1500 bytes, BW 1800 Kbit, DLY 20000 usec,
     reliability 181/255, txload 1/255, rxload 1/255
  Encapsulation HDLC, loopback not set
  Keepalive set (10 sec)
  Last input 00:00:00, output 00:00:00, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 154
  Queueing strategy: Class-based queueing
  Output queue: 0/1000/64/91 (size/max total/threshold/drops)
     Conversations  0/20/256 (active/max active/max total)
     Reserved Conversations 0/0 (allocated/max allocated)
     Available Bandwidth 8 kilobits/sec
  5 minute input rate 2000 bits/sec, 4 packets/sec
  5 minute output rate 10000 bits/sec, 5 packets/sec
     211127336 packets input, 3277482634 bytes, 0 no buffer
     Received 1241277 broadcasts, 1 runts, 340733 giants, 0 throttles
     169028502 input errors, 169028159 CRC, 122313629 frame, 82216431 overrun, 0 ignored, 91257981 abort
     173230838 packets output, 1188782537 bytes, 0 underruns
     0 output errors, 0 collisions, 599 interface resets
     0 output buffer failures, 0 output buffers swapped out
     69 carrier transitions
     DCD=up  DSR=up  DTR=up  RTS=up  CTS=up

South#


0
Comment
Question by:pcsonwheels
  • 2
4 Comments
 
LVL 7

Expert Comment

by:chafer
ID: 20090789
If you are getting a lot of errors on the serial ports, I'd first have the line provider run some tests on the point-to-point line.  You may be ping through hoops when you don't have too.  If they can't find anything, then I'd troubleshoot further, but only after they cleared the lines.
0
 
LVL 7

Expert Comment

by:chafer
ID: 20090803
Looking at the specific errors listed, I would suspect a carrier problem.  The router is finally becomiing overwhelmed with the errors and is probably locking up the router RAM.  Take a look at these errors and you can see that the packets are not crossing the line properly -

Received 1241277 broadcasts, 1 runts, 340733 giants, 0 throttles
     169028502 input errors, 169028159 CRC, 122313629 frame, 82216431 overrun, 0 ignored, 1257981

While it could be hardware, this many errors makes me think that there is noise on the line.
0
 
LVL 14

Accepted Solution

by:
bfason earned 2000 total points
ID: 20090918
The Max-reserved bandwidth 100 statement is probably starving out control packets and BE packets. Cisco recommends you reserve only 75 percent of a line(default) to allow for l2 overhead and control messaging on the line. If you are pretty sure of the overhead requirements you could possibly bump that up to 80 or 85.

If that didn't do it then I would next look at the timing on the line. Some carriers don't provide timing on point to point circuits and both of your routers are using the line for timing. You may need to set one of them to internal.

Hope this helps
B
0
 

Author Comment

by:pcsonwheels
ID: 20105248
I had the lines checked and the tech said that he sees no reason why the errors are there.  The lines are falling within specs but he will test them again tonight.  He also said that they do not provide timing but the errors that are appearing usually aren't caused by a timing issue.  I will let you know what I find out tonight and I will set up one of the routers to inter and one to be external.
Thanks
0

Featured Post

Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

It happens many times that access list (ACL) have to be applied to outgoing router interface in order to limit some traffic.This article is about how to test ACL from the router which is not very intuitive for everyone. Below scenario shows simple s…
Getting hacked is no longer a matter or "if you get hacked" — the 2016 cyber threat landscape is now titled "when you get hacked." When it happens — will you be proactive, or reactive?
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

809 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question