owa http to https redirection not working using owahttps.asp

I have a problem with a newly installed exchange server. Have installed an ssl certificate for secure access to owa, this is working fine - i can type in https://domain/exchange and access the mailbox fine. When i type in http i get a 403.4 error stating you need to type in https - this is as it should be.

I then follow the microsoft knowledgebase article (http://support.microsoft.com/kb/839357). This states how to redirect requests from http to https by using owahttps.asp. Have done this and i now get a webpapage stating error 404 "This error (HTTP 404 Not Found) means that Internet Explorer was able to connect to the website, but the page you wanted was not found. It's possible that the webpage is temporarily unavailable. Alternatively, the website might have changed or removed the webpage".

Any ideas why this might be happening?

Many Thanks
Nick

kellyr05Asked:
Who is Participating?
 
LeeDerbyshireCommented:
In IIS Manager, in the Web Service Extensions container, check that the Active Server Pages extension is set to Allow.  Having this disabled produces a misleading 404 error.
0
 
archang3lCommented:
Hello kellyr05,

It seems you have correctly changed the custom error handler for the 403.4 error code (SSL required), but the URL you typed in pointing to owahttps.asp is not valid.
Double-check the URL by entering it directly into the internet explorer address bar to confirm the file is there, if that works make sure the setting in the custom application path is the same.

You can also check the IIS logs to see where it tries looking for the file so you can make sure its in the right place.

Regards,

archang3l
0
How do you know if your security is working?

Protecting your business doesn’t have to mean sifting through endless alerts and notifications. With WatchGuard Total Security Suite, you can feel confident that your business is secure, meaning you can get back to the things that have been sitting on your to-do list.

 
kellyr05Author Commented:
Hi, thanks for the quick response

I've tryied typing in the full url eg http://domain/exchange/owahttps.asp and i get the same '404 - page cannot be found error'  - this is definatly set as the default content page for the site.

The logfiles do say exchange/owahttps.asp, so it looks like it is trying the file, but it seems not to be reading it...
0
 
kellyr05Author Commented:
The ASP extensions are set to allow in IIS manager  - not sure why this error is occuring, have taken this back to scratch several times and coming up with the same error everytime.

Exchange is installed on a DC, don't know if this makes any difference.
0
 
LeeDerbyshireCommented:
You'll need to show us the IIS log file entries generated by the redirection attempt.  The relevant lines will have a 404 near the end.  Note that the logged times are in GMT.
0
 
kellyr05Author Commented:
Here is a line from the log file stating the 404 error:

2007-10-17 19:46:07 W3SVC1 192.168.50.8 GET /exchange - 80 - 192.168.50.182 Mozilla/4.0+(compatible;+MSIE+7.0;+Windows+NT+5.1;+.NET+CLR+1.1.4322;+.NET+CLR+2.0.50727;+.NET+CLR+3.0.04506.30) 404 2 5

0
 
LeeDerbyshireCommented:
404;2 means 'Not found - Denied due to lockdown policy'.  Something else is preventing it from working.  Can you view /any/ .asp pages on the server?  Do you have a default.asp page in the Default Web Site?  If so, try going to http://server/default.asp .
0
 
kellyr05Author Commented:
Hi

I don't have a default .asp page on the website, but added one, moved it to the top of the list and still couldn't view it....have checked in web extensions and ASP is definately set to allow, is there something else i have to enable?
0
 
kellyr05Author Commented:
I'm an idiot, asp.net extensions were allowed in web extensions and NOT Active server pages (as you stated earlier), have added this in add/remove programs and everythings working as it should do! many thanks for your time and paitence Lee! Enjoy the well deserved points!!!
0
 
LeeDerbyshireCommented:
You're welcome.  The default OWA setup doesn't need ASP installed and enabled, but a simple thing like enabling Forms-based Authentication (which uses an .asp page) or adding this redirection page will produce a really confusing 404 error.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.