• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 549
  • Last Modified:

Cisco ASA 5505 and PIX 501 site-to-site-to-site browsing with VPN Client

Hi Experts,

i have a Cisco ASA 5505 configured with 2x site-to-site connection with Pix501 firewalls...everything is working fine.

From my understanding before, that pix501 firewalls, when configure as site-to-site-to-site configuration, that when using the VPN Client, you can only contact the direct network and not able to connect to the other networks, i.e. Vpn Client connecting to site1, but is not able to ping/browse the other 2 sites...is that true?

if so, with the ASA 5505, can that be accomplished?  if so, what's correct configuration?

thanks!

0
jetli87
Asked:
jetli87
  • 4
  • 4
  • 4
  • +1
3 Solutions
 
grbladesCommented:
Yes starting with version 7 of the IOS operating system (available for PIX515 and above and the ASA) this is possible.
All you need to do is add the following configuration line to the ASA config:-
same-security-traffic permit intra-interface
0
 
Pete LongConsultantCommented:
>>not able to connect to the other networks,

This is completely normal - to do what you require you need version 7.0 (so that discounts the PIX which can only go to 6.3(5)) - its called "Hairpinning" and can only be done if you client CPN into the ASA 5500 firewall (which will be 7.0(0) or above)   :)

Pete
0
 
Pete LongConsultantCommented:
typing at the same time :)
0
 The Evil-ution of Network Security Threats

What are the hacks that forever changed the security industry? To answer that question, we created an exciting new eBook that takes you on a trip through hacking history. It explores the top hacks from the 80s to 2010s, why they mattered, and how the security industry responded.

 
grbladesCommented:
0
 
jetli87Author Commented:
i see.

so it is possible to use the VPN Client to connect to the ASA (which is running 7.2) and then ping/browse the 2 remote networks connected via pix501 vpn tunnel?
0
 
grbladesCommented:
Yes thats correct.
0
 
jetli87Author Commented:
i tried the command, but no luck.

here's my config:
ASA Version 7.2(2)
!
hostname 5starASA
domain-name 5star-appraisal.com
enable password ShKXNuHUUuf8QjmQ encrypted
names
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 10.20.100.1 255.255.255.0
!
interface Vlan2
 nameif outside
 security-level 0
 ip address xxx.xxx.xxx.215 255.255.255.0
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
passwd ShKXNuHUUuf8QjmQ encrypted
ftp mode passive
clock timezone PST -8
clock summer-time PDT recurring
dns server-group DefaultDNS
 domain-name 5star-appraisal.com
same-security-traffic permit intra-interface
access-list inbound extended permit tcp any host xxx.xxx.xxx.214 eq https
access-list inbound extended permit tcp any host xxx.xxx.xxx..213 eq smtp
access-list outside_20_cryptomap extended permit ip 10.20.100.0 255.255.255.0 192.168.168.0 255.255.255.0
access-list inside_nat0_outbound extended permit ip 10.20.100.0 255.255.255.0 192.168.168.0 255.255.255.0
access-list inside_nat0_outbound extended permit ip 10.20.100.0 255.255.255.0 192.170.168.0 255.255.255.0
access-list inside_nat0_outbound extended permit ip any 10.20.98.0 255.255.255.240
access-list outside_40_cryptomap extended permit ip 10.20.100.0 255.255.255.0 192.170.168.0 255.255.255.0
access-list 5star-vpn_splitTunnelAcl_1 standard permit 10.20.100.0 255.255.255.0
access-list 5star-vpn_splitTunnelAcl_1 standard permit 192.168.168.0 255.255.255.0
pager lines 24
logging enable
logging asdm informational
mtu inside 1500
mtu outside 1500
ip local pool SSLusers 10.20.99.5-10.20.99.7 mask 255.255.255.0
ip local pool ipsec-users 10.20.98.5-10.20.98.10 mask 255.255.255.0
ip verify reverse-path interface outside
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-522.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 1 0.0.0.0 0.0.0.0
access-group inbound in interface outside
route outside 0.0.0.0 0.0.0.0 xxx.xxx.xxx.200 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout uauth 0:05:00 absolute
group-policy DfltGrpPolicy attributes
 banner none
 wins-server none
 dns-server none
 dhcp-network-scope none
 vpn-access-hours none
 vpn-simultaneous-logins 3
 vpn-idle-timeout 30
 vpn-session-timeout none
 vpn-filter none
 vpn-tunnel-protocol IPSec l2tp-ipsec webvpn
 password-storage disable
 ip-comp disable
 re-xauth disable
 group-lock none
 pfs disable
 ipsec-udp disable
 ipsec-udp-port 10000
 split-tunnel-policy tunnelall
 split-tunnel-network-list none
 default-domain none
 split-dns none
 intercept-dhcp 255.255.255.255 disable
 secure-unit-authentication disable
 user-authentication disable
 user-authentication-idle-timeout 30
 ip-phone-bypass disable
 leap-bypass disable
 nem disable
 backup-servers keep-client-config
 msie-proxy server none
 msie-proxy method no-modify
 msie-proxy except-list none
 msie-proxy local-bypass disable
 nac disable
 nac-sq-period 300
 nac-reval-period 36000
 nac-default-acl none
 address-pools none
 client-firewall none
 client-access-rule none
 webvpn
  functions url-entry
  html-content-filter none
  homepage none
  keep-alive-ignore 4
  http-comp gzip
  filter none
  url-list none
  customization value DfltCustomization
  port-forward none
  port-forward-name value Application Access
  sso-server none
  deny-message value Login was successful, but because certain criteria have not been met or due to some specific group policy, you do not have permission to use any of the VPN features. Contact your IT administrator for more information
  svc enable
  svc keep-installer none
  svc keepalive none
  svc rekey time 60
  svc rekey method ssl
  svc dpd-interval client none
  svc dpd-interval gateway none
  svc compression deflate
group-policy 5star-vpn_1 internal
group-policy 5star-vpn_1 attributes
 dns-server value 10.20.100.5 10.20.100.6
 vpn-tunnel-protocol IPSec
 split-tunnel-policy tunnelspecified
 split-tunnel-network-list value 5star-vpn_splitTunnelAcl_1
 default-domain value 5star-appraisal.com
group-policy 5star-vpn internal
group-policy 5star-vpn attributes
 dns-server value 10.20.100.5 10.20.100.6
 vpn-tunnel-protocol IPSec
 split-tunnel-policy tunnelspecified
 split-tunnel-network-list value 5star-vpn_splitTunnelAcl_1
 default-domain value 5star-appraisal.com
username 5star password 72.pnle8cWjl/FKe encrypted privilege 0
username 5star attributes
 vpn-group-policy 5star-client
username chris password BBWoUhQwyM8K6MEL encrypted privilege 0
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
crypto dynamic-map outside_dyn_map 20 set pfs
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-AES-256-SHA
crypto dynamic-map outside_dyn_map 40 set pfs
crypto dynamic-map outside_dyn_map 40 set transform-set ESP-AES-256-SHA
crypto dynamic-map outside_dyn_map 60 set pfs
crypto dynamic-map outside_dyn_map 60 set transform-set ESP-AES-256-SHA
crypto map outside_map 20 match address outside_20_cryptomap
crypto map outside_map 20 set pfs
crypto map outside_map 20 set peer xxx.xxx.xxx.100 (site 1)
crypto map outside_map 20 set transform-set ESP-AES-256-SHA
crypto map outside_map 40 match address outside_40_cryptomap
crypto map outside_map 40 set pfs
crypto map outside_map 40 set peer xxx.xxx.xxx.150 (site2)
crypto map outside_map 40 set transform-set ESP-AES-256-SHA
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map interface outside
crypto isakmp enable outside
crypto isakmp policy 10
 authentication pre-share
 encryption aes-256
 hash sha
 group 5
 lifetime 86400
crypto isakmp policy 30
 authentication pre-share
 encryption aes-256
 hash sha
 group 2
 lifetime 86400
tunnel-group DefaultWEBVPNGroup general-attributes
 address-pool SSLusers
tunnel-group 5star-vpn type ipsec-ra
tunnel-group 5star-vpn general-attributes
 address-pool ipsec-users
 default-group-policy 5star-vpn_1
tunnel-group 5star-vpn ipsec-attributes
 pre-shared-key *
tunnel-group 66.245.244.215 type ipsec-l2l
tunnel-group 66.245.244.215 ipsec-attributes
 pre-shared-key *
tunnel-group 71.243.214.70 type ipsec-l2l
tunnel-group 71.243.214.70 ipsec-attributes
 pre-shared-key *
tunnel-group-map default-group 5star-vpn
telnet 10.20.100.0 255.255.255.0 inside
telnet timeout 15
console timeout 0

!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny
  inspect sunrpc
  inspect xdmcp
  inspect sip
  inspect netbios
  inspect tftp
!
service-policy global_policy global
webvpn
 enable outside
 csd image disk0:/securedesktop-asa-3.1.1.29-k9.pkg
 svc image disk0:/ssl-win-1.1.4.pkg 1
 svc enable
prompt hostname context
Cryptochecksum:f325ae159cfd776cc281d09d45bc48ce
: end
asdm image disk0:/asdm-522.bin
no asdm history enable
0
 
jetli87Author Commented:
so in a nutshell and to reiterate:

Main site:  asa 5505 network = 10.20.100.x
site 1:       pix501 network = 192.168.168.0
site 2:       pix501 network = 192.170.168.0

VPN client that connects to ASA 5505 network @ 10.20.98.0

thanks!!!!!!

i want to get the VPN Client to access site1&site2 network from the ASA5505.


0
 
grbladesCommented:
I think you need to add a few entries to your ACLs as currently only traffic between your internal LAN is permitted to go over the site-site VPN. You need to add the client IP pool to the list aswell :-

access-list outside_20_cryptomap extended permit ip 10.20.99.0 255.255.255.0 192.168.168.0 255.255.255.0
access-list outside_20_cryptomap extended permit ip 10.20.98.0 255.255.255.0 192.168.168.0 255.255.255.0
access-list outside_40_cryptomap extended permit ip 10.20.99.0 255.255.255.0 192.170.168.0 255.255.255.0
access-list outside_40_cryptomap extended permit ip 10.20.98.0 255.255.255.0 192.170.168.0 255.255.255.0
0
 
lrmooreCommented:
Don't forget that you also have to modify the remote 501's to include the 10.20.98.0/24 subnet in their nat0 and cryptomap acl entries.
0
 
jetli87Author Commented:
worked like a charm...thanks!

just to be clear though,  even with the aboe commands, the configuration woudln't without:

same-security-traffic permit intra-interface

correct?
0
 
Pete LongConsultantCommented:
Yes :)
0
 
Pete LongConsultantCommented:
And ThanQ
0

Featured Post

The IT Degree for Career Advancement

Earn your B.S. in Network Operations and Security and become a network and IT security expert. This WGU degree program curriculum was designed with tech-savvy, self-motivated students in mind – allowing you to use your technical expertise, to address real-world business problems.

  • 4
  • 4
  • 4
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now