• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 401
  • Last Modified:

ACPID on Kubuntu Desktop

I installed ubuntu on my desktop.  I installed KDE, making it kubuntu.

After a period of inactivity screensaver starts.  Some time after that the system seems to hibernate.  Don't know if it hibernates or suspends.  All I know is that the screen goes dark and you have to hit a key to bring the monitor back.

I tried the kubutu forum but "hibernate" and "suspend" topics all relate to laptops..

How do I get my desktop to "suspend" suspend or hibernate?

What would happend if I unistall ACPID?

Not a big problem, just anoying..

Thanks for your help.
0
KenSpeedie
Asked:
KenSpeedie
  • 4
  • 3
1 Solution
 
WizRd-LinuxCommented:
Uninstalling ACPID would stop reactions to certain events, to find out what would happen check the /etc/acpi/events/ directory.

In these files includes the action required to trigger the event.  As for the monitor going black, this is normal for most linux boxes, it is the same as windows turning the monitor off after 15 minutes by default.
0
 
KenSpeedieAuthor Commented:
I ran RH9 for years.  Never had the screen go black.

Screensaver comes on in Kubutu and than the screen goes black (Have not timed it but 15 minutes seems right).

Too many events that I don't understand in /etc/acpi/events/ directory for me to go messing with ACPID by turning it off..

If the default is for the screen to go black after 15 minutes how do I change that default?  Can I change the 15 minute default in ACPID?  Is there some other place besides ACPID to tell the monitor not to go dark?

Thanks
0
 
WizRd-LinuxCommented:
edit your Xorg.conf file and in the monitor section comment out the line relating to Option "dpms"

If you have other options on this line, comment out the full line and create a new line minus the dpms bit.
0
Never miss a deadline with monday.com

The revolutionary project management tool is here!   Plan visually with a single glance and make sure your projects get done.

 
WizRd-LinuxCommented:
and then restart X (forgot to mention this in the previous post)
0
 
KenSpeedieAuthor Commented:
I commented out the line with DPMS.  I rebooted.  It not only kept the monitor from going dark, it killed the screen saver.

Any other suggestions?

Looks like I should up the points for this one.

Thanks
0
 
KenSpeedieAuthor Commented:
I forgot to mention that DPMS was the only thing on that line.

0
 
KenSpeedieAuthor Commented:
I googled xorg.conf.  Under the monitor section I found a thing called xset.  Xset allows you to do all kinds of neat things, including setting the standby, suspend and off times.

I set all three to "0".  Problem solved!  Screensaver works and monitor does not go dark.

Thanks for pointing me in the right direction.

Ken
0

Featured Post

The new generation of project management tools

With monday.com’s project management tool, you can see what everyone on your team is working in a single glance. Its intuitive dashboards are customizable, so you can create systems that work for you.

  • 4
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now