DFS2 Replication - Conflicted and Deleted - a new file keeps going to this folder.

I have DFS2 replication setup and I am replicating a folder to 5 other servers in different regions.  One of the engineers placed a file to be replicated into one of the directires today and it keeps going into the Conflicted and Deleted folder under DFSPrivate.

I have gone to each server and deleted the file and the XML document.  I copied the file off to a PC so that while I was doing that it wouldn't be on the server.  After I removed all of the references to it under conflicted and deleted on all of the servers I copied the file back onto the HQ server where it belongs.  Within seconds it was moved to teh Conflicted and Deleted folder.

We don't know what it is conflicing with since there isn't a file with that name in there.  Opening the XML says it saw itself and renamed itself the same thing in the Conflicted and Deleted folder.

In the past when I have had conflicted files I have been able to delete the files on the servers and just place the file back but this particular file refuses.  I have tested replication of other files and replication is working just fine.

Any ideas?
LVL 2
EnclosAdminAsked:
Who is Participating?
 
EnclosAdminAuthor Commented:
The truth comes out.

The reason this problem occurred was that an impatient person could not wait for the very small file to 'replicate' so they copied the file simultaniously to the main replication drive AND to one of the other drives.  Of course both servers now had that file and both servers alerted the replication topology that they had this file [filex] and that caused the problem.  They were the same file to AD and of course it caused a conflict with two files of the exact same name placed onto the replication topology at different sites at the same time.

He would have had to wait no more than about 12 seconds if he had copied it into the proper directory and just let replication take care of it.

0
 
George SasIT EngineerCommented:
Tried to restart the service ?
Or try to rename the file. Is it any particular extension or size ?
0
 
EnclosAdminAuthor Commented:
Restarting the service had no result.

It is definitely something hung with the file name.  If I take the correct file, rename it to something else then place it into the proper directory it stays.  Then I try to rename it and withing seconds it reverts to the name I copied it into the folder as.

It is a simple .arx file, nothig special about it.  All of our Autocad users need this reference file and their clients are programmed to look for it.  So we can't just rename the file permanently,  all of the clients would have to change their configuration settings.

I am rebooting the main replication server.  I'll let you know if that has any affect.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

 
George SasIT EngineerCommented:
Yeah , that sounds very strange indeed if the issue is only with that filename.
Restarted the service on all replica partners ?
0
 
EnclosAdminAuthor Commented:
It needed to have the server re-booted.  After that I was able to rename the file and after that it replicated properly.  I did have to go through the other servers and delete the Conflicted file after the fact but the correct file now is replicated.

I should not have had to reboot the server according to what I could find from Microsoft but that was the case.  Rebooting did clear the registry cache but a service such as DFS2 should not need a full reboot. I will bring it up to the guys at Technet and let them know I had this problem.

Thank you for your ideas GeoSs and your prompt response.
0
 
George SasIT EngineerCommented:
Hehe :)
Glad you solved the problem .... users kill admins:)
0
 
Vee_ModCommented:
Closed, 500 points refunded.
Vee_Mod
Community Support Moderator
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.