Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

CISCO Switch IOS configuration catalyst 2950

Posted on 2007-10-17
14
Medium Priority
?
10,253 Views
Last Modified: 2008-12-11
Howdy,
I have a CISCO catalyst 2950. I need a step-by-step configuration to setup it up to act like a dumb switch. A simple unmaned switch. I tried this one
http://www.experts-exchange.com/Networking/Misc/Q_22114441.html . But I could not even get that answer  to work. I am about ready to buy a normal auto sensing 24 port switch. I reset the switch write erase, reload about a million times. I tried all the step in the Q_2211441 CISCO Switch IOS configuration catalyst 2950 articule. I must be just dense?  like is the ! a command? Anyhow is there someone who can give an old dense irishman a step-by-step instuctions on how to make this thing work like a simple dumb switch? Or is it even possible?
this didn't work;
enable
conf t
int range fa 0/1 - 23
  speed 10
  duplex half
  no spanning-tree
int fa 0/24
  speed auto
  duplex auto
exit

copy run start

I received this error:
There is something wrong with "no spanning-tree" command
This is the error screen:
%Incomplete command%

Tried this:
Here is it

config t

interface fastethernet 0/1
speed 10
duplex half


interface fastethernet 0/2
speed 10
duplex half

interface fastethernet 0/3
speed 10
duplex half

and so on for all the interfaces u need 10 MB hald duplex

as far as uplink port is concerned

interface fastethernet 0/24
speed auto
duplex auto

Then I would plug a uplink cable into 0/24 it would light green.
but when i tried to connect anything to it no link lights.
0
Comment
Question by:shawn_flynn
  • 5
  • 5
  • 3
  • +1
14 Comments
 
LVL 11

Expert Comment

by:tvman_od
ID: 20098592
1. Cisco 2950 doesn't have a dedicated uplink ports, so if you are trying to cascade multiple switches, you need a cross-over cable

pin1 - pin3
pin2 - pin6

For normal switch - host connection you use a straight cable
pin1 - pin1
pin2 - pin2
.....
pin8 - pin8

If have to leave spanning-tree protocol on for the ports connected to other switches.
For the rest of ports use

spanning-tree portfast

instead of "no spanning-tree"
Regarding speed and duplex I'd recommend to put auto. If It cannot necotiate it will fall to 10/half anyway.

0
 
LVL 79

Accepted Solution

by:
lrmoore earned 750 total points
ID: 20099925
What you want is a bare bones default configuration.

Try this:
switch#write erase
 save config? NO
switch#reload

Done. Don't configure anything at all. It works right out of the box as a pure L2 switch, all ports on the same vlan, no IP address for managment. All ports auto/auto for speed/duplex. All ports in same VLAN1.



0
 
LVL 11

Expert Comment

by:tvman_od
ID: 20100422
lrmoore, that's right, but 2950 STP portfast feature disabled by default and there is sort of annoying delay before it changes blocking state of a port to forwarding.

0
Free Backup Tool for VMware and Hyper-V

Restore full virtual machine or individual guest files from 19 common file systems directly from the backup file. Schedule VM backups with PowerShell scripts. Set desired time, lean back and let the script to notify you via email upon completion.  

 

Author Comment

by:shawn_flynn
ID: 20102296
I forgot to mention, I tied that first. My uplink light is yellow, my link light to a device is green. I have tried a crossover and and regular cable. I have attached my hyper terminal session. I know I am doing something wrong.

  Half-duplex, 10Mb/sration Dialog ---                                      
  input flow-control is off, output flow-control is off to enter the initial configuration                                                                                          
  ARP type: ARPA, ARP Timeout 04:00:00                                      

At any      
  Last input never, output 1d00h, output hang never                                                  
  Last clearing of "show interface" counters never prompt.                                                          
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0                                                                      


Basic management setup configures on                                    
  Queueing strategy: fifoK bytes of                                  
  Output queue :0/40 (size/max)                              
for m    
  5 minute input rate 0 bits/sec, 0 packets/sec you 6 sec                                                        
  5 minute output rate 0 bits/sec, 0 packets/sec                                                

  5 minute input rate 0 bits/sec, 0 p                                    

Switch#show int briefyes' or 'n                            
                ^                

  privilege          
% Invalid input detected at '^' marker.sword, after                                                  

Switch#show vlan                

VLAN Name                             Status    Portsypted in the configuration.                                                                                
---- -------------------------------- -------                                            

  The enable passwo                  
1    default                          active    Fa0/1, Fa0/2, Fa0/3, Fa0/4                                                                          
  enable secret password, with some older software vers                                                      
                                                Fa0/5, Fa0/6, Fa0/7, Fa0/8                                                                          
  some boot images.bjec                      
                                                Fa0/9, Fa0er enable password: hello#e                                                                                    
2    VLAN0002                         active                                            
  Configure SNMP Network Managem                                
1002 fddi-default                     active                                            

Current interface summaryOWN: L                              
1003 token-ring-default                      

Any interface list                  
1004 fddinet-default                  activeconfigurationforth in subparagra                                                                            
1005 trnet-default                    active                                            

Inte    

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp                                                      






























Switch con0 is now available                            





Press RETURN to get started.                            










C2950 Boot Loader (C2950-HBOOT-M) Version 12.1(6)EA2c, RELEASE SOFTWARE (fc1)                                                                            
Compiled Thu 28-Feb-02 14:59 by antonino                                        
WS-C2950-24 starting...                      
Base ethernet MAC Address: 00:09:e8:0f:d1:40                                            
Xmodem file system is available.                                
Initializing F              
flashfs[0]: 17 files, 2 directories                                  
flashfs[0]: 0 orphaned files, 0 orphaned directories                                                    
flashfs[0]: Total bytes: 7741440                                
flashfs[0]: Bytes used: 3977216                              
flashfs[0]: Bytes available: 3764224                                    
flashfs[0]: flashfs fsck took 6 seconds.                                        
...done initializ              
Boot Sector Filesystem (bs:) installed, fsid: 3                                              
Parameter Block Filesystem (pb:) installed, fsid: 4                                                  
Loading "flash:c2950-i6q4l2-mz.121-6.EA2c.bin"...###############################                                                                                
############################################################################                                                                            
#######################################################################                                                                      

File "flash:c2950-i6q4l2-mz.121-6.EA2c.bin" uncompressed and installed, entry po                                                                                
int: 0x80010000              
executing...            

              Restricted Rights Legend                                      

Use, duplication, or disclosure by t                                  
subject to restrictions as set forth in subparagraph                                                    
(c) of the Commercial Computer Software - Restricted                                                    
Rights clause at FAR sec. 52.227-19 and subparagraph                                                    
(c) (1) (ii) of the Rights in Technical Data and Computer                                                        
Software clause at DFARS                        

           cisco Systems, Inc.                              
           170 West Tasman Drive                                
           San Jose, California 95134-1706                                          



Cisco Internetwork Operating System Software                                            
IOS (tm) C2950 Software (C2950-I6Q4L2-M), Version 12.1(6)EA2c, RELEASE SOFTWARE                                                                              
(fc1)    
Copyright (c) 1986-2002 by cisco Sys                                  
Compiled Thu 28-Feb-02 14:44 by antonino                                        
Image text-base: 0x80010000, data-base: 0x8042C000                                                  


Initializing flashfs...                      
flashfs[1]: 17 files, 2 directories                                  
flashfs[1]: 0 orphaned files, 0 orphaned directories                                                    
flashfs[1]: Total bytes:                        
flashfs[1]: Bytes used: 3977216                              
flashfs[1]: Bytes available: 3764224                                    
flashfs[1]: flashfs fsck took 6 seconds.                                        
flashfs[1]: Initialization complete.                                    
Done initializing flashfs.                          
POST: System Board Test : Passed                                
POST: Ethernet Controller Test : Passed                                      
ASIC Initialization Passed                          

POST: FRONT-END LOOPBACK TEST : Passed                                      
cisco WS-C2950-24 (RC32300) processor (revision D0) with 21295K bytes of memory.                                                                                

Processor board ID FHK0622W0JM                              
Last reset from system-reset                            
Running Standard Image                      
24 FastEthernet/IEEE 802.3 interface(s)                                      

32K bytes of flash-simulated non-volatile configuration memory.                                                              
Base ethernet MAC Address: 00:09:E8:0F:D1:40                                            
Motherboard assembly number: 73-5781-10                                      
Power supply part number: 34-0965-01                                    
Motherboard serial number: FOC062202MV                                      
Power supply serial number: PHI062000JB                                      
Model revision number: D0                        
Motherboard revision number: B0                              
Model number: WS-C2950-24                        
System serial number: FHK0622W0JM                                


Press RETURN to get started!                            


00:00:18: %SYS-5-CONFIG_I: Configured from memory by console                                                            
00:00:18: %LINK-5-CHANGED: Interface Vlan1,                                          
wn  
00:00:18: %SYS-5-RESTART: System restarted --                                            
Cisco Internetwork Operating System Software                                            
IOS (tm) C2950 Software (C2950-I6Q4L2-M), Version 12.1(6)EA2c, RELEASE SOFTWARE                                                                              
(fc1)    
Copyright (c) 1986-2002 by cisco Systems, Inc.                                              
Compiled Thu 28-Feb-02 14:44 by antoni                                    
00:00:19: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, changed state t                                                                                
o down      
Switch>ena          
Switch#write erase                  
Erasing the nvram filesystem will remove all files! Continue? [confirm]y[OK]                                                                            
Erase of nvram: complete                        
Switch#reload            
Proceed with relo                
00:02:07: %SYS-5-RELOAD: Reload requested                                        

C2950 Boot Loader (C2950-HBOOT-M) Version 12.1(6)EA2c, RELEASE SOFTWARE (fc1)                                                                            
Compiled Thu 28-Feb-02 14:59 by antonino                                        
WS-C2950-24 starting...                      
Base ethernet MAC Address: 00:09:e8:0f:d1:40                                            
Xmodem file system is available.                                
Initializing Flash...                    
flashfs[0]: 16 files, 2 directories                                  
flashfs[0]: 0 orphaned files, 0 orphaned directories                                                    
flashfs[0]: Total bytes: 7741440                                
flashfs[0]: Bytes used: 3975680                              
flashfs[0]: Bytes available: 3765760                                    
flashfs[0]: flashfs fsck took 6 seconds.                                        
...done initializing flash.                          
Boot Sector Filesystem (bs:) installed, fsid: 3                                              
Parameter Block Filesystem (pb:) installed, fsid: 4                                                  
Loading "flash:c2950-i6q4l2-mz.121-6.EA2c.bin"...###############################                                                                                
#######################################################                                                    
#######################################################################                                                                      

File "flash:c2950-i6q4l2-mz.121-6.EA2c.bin" uncompressed and installed, entry po                                                                                
int: 0x80010000              
executing...            

              Restricted Rights Legend                                      

Use, duplication, or disclosure by the Government is                                                    
subject to restrictions as set forth in subparagraph                                                    
(c) of the Commercial Computer Software - Restricted                                                    
Rights clause at FAR sec. 52.227-19 and subparagraph                                                    
(c) (1) (ii) of the Rights in Technical Data and Computer                                                        
Software clause at DFARS                        

           cisco Systems, Inc.                              
           170 West Tasman Drive                                
           San Jose, California 95134-1706                                          



Cisco Internetwork Operating System Software                                            
IOS (tm) C2950 Software (C2950-I6Q4L2-M), Version                                                
(fc1)    
Copyright (c) 1986-2002 by cisco Systems, Inc.                                              
Compiled Thu 28-Feb-02 14:44 by antonino                                        
Image text-base: 0x80010000, data-base: 0x8042C000                                                  


Initializing flashfs...                      
flashfs[1]: 16 files, 2 directories                                  
flashfs[1]: 0 orphaned files, 0 orphaned directories                                                    
flashfs[1]: Total bytes: 7741440                                
flashfs[1]: Bytes used:                    
flashfs[1]: Bytes available: 3765760                                    
flashfs[1]: flashfs fsck took 6 seconds.                                        
flashfs[1]: Initialization complete.                                    
Done initializing flashfs.                          
POST: System Board Test : Passed                                
POST: Ethernet Contr                    
ASIC Initialization Passed                          

POST: FRONT-END LOOPBACK TEST : Passed                                      
cisco WS-C2950-24 (RC32300) processor (revision D0) with 21295K bytes of memory.                                                                                

Processor board ID FHK0622W0JM                              
Last reset from system-reset                            
Running Standard Image                      
24 FastEthernet/IEEE 802.3 interface(s)                                      

32K bytes of flash-simulated non-volatile configura                                                  
Base ethernet MAC Address: 00:09:E8:0F:D1:40                                            
Motherboard assembly number: 73-5781-10                                      
Power supply part number: 34-0965-01                                    
Motherboard serial number: FOC062202MV                                      
Power supply serial nu                      
Model revision number: D0                        
Motherboard revision number: B0                              
Model number: WS-C2950-24                        
System serial number: FHK0622W0JM                                


         --- System Configuration Dialog ---                                            

Would you like to enter the initial configuration dialog? [yes/no]: n                                                                    



Press RETURN to get started!                            


00:00:18: %SYS-5-RESTART: System restarted --                                            
Cisco Internetwork Oper                    
IOS (tm) C2950 Software (C2950-I6Q4L2-M), Version 12.1(6)EA2c, RELEASE SOFTWARE                                                                              
(fc1)    
Copyright (c) 1986-2002 by cisco Systems, Inc.                                              
Compiled Thu 28-Feb-02 14:44 by antonino                                        
00:00:25: %LINK-5-CHANGED: Interface Vlan1, changed state to administratively do                                                                                
wn  
00:00:26: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, changed state t                                                                                
o down      
Switch>      
00:01:51: %LINK-3-UPDOWN: Interface FastEthernet0/24, changed state to up                                                                        
00:01:52: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/24, chan                                                                                
ged state to down                
00:01:52: %SPANTREE-7-RECV_1Q_NON_TRUNK: Received 802.1Q BPDU on non trunk FastE                                                                                
thernet0/24 VLAN1.                  
00:01:52: %SPANTREE-7-BLOCK_PORT_TYPE: Blocking FastEthernet0/24 on VLAN1. Incon                                                                                
sistent port type.                  
00:01:53: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/24, chan                                                                                
ged state to up              
00:02:02: %LINK-3-UPDOWN: Interface FastEthernet0/1, changed state to up                                                                        
00:02:03: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, chang                                                                                
ed state to down                
00:02:04: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, chang                                                                                
ed state to up              


C2950 Boot Loader (C2950-HBOOT-M) Version 12.1(6)EA2c, RELEASE SOFTWARE (fc1)                                                                            
Compiled Thu 28-Feb-02 14:59 by antonino                                        
WS-C2950-24 starting...                      
Base ethernet MAC Address: 00:09:e8:0f:d1:40                                            
Xmodem file system is available.                                
Initializing Flash...                    
flashfs[0]: 16 files, 2 directories                                  
flashfs[0]: 0 orphaned files, 0 orphaned directories                                                    
flashfs[0]: Total bytes: 7741440                                
flashfs[0]: Bytes used: 3975680                              
flashfs[0]: Bytes availa                      
flashfs[0]: flashfs fsck took 6 seconds.                                        
...done initializing flash.                          
Boot Sector Filesystem (bs:) installed, fsid: 3                                              
Parameter Block Filesystem (pb:) installed, fsid: 4                                                  
Loading "flash:c2950-i6q4l2-mz.121-6.EA2c.bin"...###############################                                                                                
################################################################################                                                                                
#######################################################################                                                                      

File "flash:c2950-i6q4l2-mz.121-6.EA2c.bin" uncompressed and installed, entry po                                                                                
int: 0x80010000              
executing...            

              Restricted Rights Legend                                      

Use, duplication, or disclosure by the Government is                                                    
subject to restrictions as set forth in subparagraph                                                    
(c) of the Commercial Computer Software - Restricted                                                    
Rights clause at FAR sec. 52.227-19 and subparagraph                                                    
(c) (1) (ii) of the Rights in Technical Data and Computer                                                        
Software clause at DFARS sec. 252.227-7013.                                          

           cisco Systems, Inc.                              
           170 West Tasman Drive                                
           San Jose, California 95134-1706                                          



Cisco Internetwork Operating System Software                                            
IOS (tm) C2950 Software (C2950-I6Q4L2-M), Version 12.1(6)EA2c, RELEASE SOFTWARE                                                                              
(fc1)    
Copyright (c) 1986-2002 by cisco Systems, Inc.                                              
Compiled Thu 28-Feb-02 14:44 by antonino                                        
Image text-base: 0x80010000, data-base: 0x8042C000                                                  


Initializing flashfs...                      
flashfs[1]: 16 files, 2 directories                                  
flashfs[1]: 0 orphaned files, 0 orphaned directories                                                    
flashfs[1]: Total bytes: 7741440                                
flashfs[1]: Bytes used: 3975680                              
flashfs[1]: Bytes available: 3765760                                    
flashfs[1]: flashfs fsck took 6 seconds.                                        
flashfs[1]: Initialization complete.                                  
Done initializing flashfs.                          
POST: System Board Test : Passed                                
POST: Ethernet Controller Test : Passed                                      
ASIC Initialization Passed                          

POST: FRONT-END LOOPBACK TEST : Passed                                      
cisco WS-C2950-24 (RC32300) processor (revision D0) with 21295K bytes of memory.                                                                                

Processor board ID FHK0622W0JM                              
Last reset from system-reset                            
Running Standard Image                      
24 FastEthernet/IEEE 802.3 interface(s)                                      

32K bytes of flash-simulated non-volatile configuration memory.                                                              
Base ethernet MAC Address: 00:09:E8:0F:D1:40                                            
Motherboard assembly number: 73-5781-1                                    
Power supply part number: 34-0965-01                                    
Motherboard serial number: FOC062202MV                                      
Power supply serial number: PHI062000JB                                      
Model revision number: D0                        
Motherboard revision number: B0                              
Model number: WS-C2950-24                        
System serial number: FHK0622W0JM                                


         --- System Configuration Dialog ---                                            

Would you like to enter the initial configuration dialog? [yes/no]:                                                                  
00:00:18: %SYS-5-RESTART: System restarted --                                            
Cisco Internetwork Operating System Software                                            
IOS (tm) C2950 Software (C2950-I6Q4L2-M), Version 12.1(6)EA2c, RELEASE SOFTWAR                                                                            
(fc1)    
Copyright (c) 1986-2002 by cisco Systems, Inc.                                              
Compiled Thu 28-Feb-02 14:44 by antonino                                        
% Please answer 'yes' or 'no'.                              
Would you like to enter the initial configuration dialog? [yes/no]: n                                                                    



Press RETURN to get started!                            


Switch>      
00:01:37: %LINK-5-CHANGED: Interface Vlan1, changed state to administratively do                                                                                
wn  
00:01:38: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, changed state t                                                                                
o down      
Switch>ena          
Switch#write erase                  
Erasing the nvram filesystem will remove all files! Continue? [confirm]y[OK]                                                                            
Erase of nvram: complete                        
Switch#reload            
Proceed with reload? [confirm]y                              
00:02:29: %SYS-5-RELOAD: Reload requested                                        

C2950 Boot Loader (C2950-HBOOT-M) Version 12.1(6)EA2c, RELEASE SOFTWARE (fc1)                                                                            
Compiled Thu 28-Feb-02 14:59 by antonino                                        
WS-C2950-24 starting...                      
Base ethernet MAC Address: 00:09:e8:0f:d1:40                                            
Xmodem file system is available.                                
Initializing Flash...                    
flashfs[0]: 16 files, 2 directories                                  
flashfs[0]: 0 orphaned files, 0 orphaned directories                                                    
flashfs[0]: Total bytes: 7741440                                
flashfs[0]: Bytes used: 3975680                              
flashfs[0]: Bytes available: 3765760                                    
flashfs[0]: flashfs fsck took 6 seconds.                                        
...done initializing flash.                          
Boot Sector Filesystem (bs:) installed, fsid: 3                                              
Parameter Block Filesystem (pb:) installed, fsid: 4                                                  
Loading "flash:c2950-i6q4l2-mz.121-6.EA2c.bin"...###############################                                                                                
################################################################################                                                                                
#######################################################################                                                                      

File "flash:c2950-i6q4l2-mz.121-6.EA2c.bin" uncompressed and installed, entr                                                                          
int: 0x80010000ommand or      
executing...    
!o  
!

              Restricted Rights Legend                  
interface FastEthe

Use, duplication, or disclosure by the Government is                            
 duplex halfOK]        
subject to restrictions as set forth in subparagraph/3                        
Erase    
 duplex halfm
(c) of the Commercial Computer Software - Restrictedrface FastEthernet0/4ing "cls                      
Rights clause at FAR sec. 52.227-19 and subparagraph10        
!
interface FastEthernet0/5nknown comma
(c) (1) (ii) of the Rights in Technical Data and Computer    
 duplex halfable to find                        
 s
Software clause at DFARS sec. 252.227-7013.FastEthernet0/6                        
 d

           cisco Systems, Inc.    
 speed 10ch#conf t      
           170 West Tasman Driveernet0/7tion commands, one per l
           San Jose, California 95134-1706        
 duplex half CNTL/Z.            



Cisco Internetwork Operatiinterface Fas            


Initializing flashfs...      
!
interface Fa
flashfs[1]: 16 files, 2 directories                                  
flashfs[1]: 0 orphaned files, 0 orphaned directories                  
!.  
interface FastEthernet0/15hf
flashfs[1]: Total bytes: 7741440                                
flashfs[1]: Bytes used: 3975680    
 speed 10        
fla  

flashfs[1]: Bytes available: 3765760d directories                      
flashfs[1]: flashfs fsck took 6 seconds.      
 speed 10        
!f  
interface
flashfs[1]: Initialization complete.              
                   
Power supply serial number: PHI062000JBput none                    

File    
Model revision number: D01                        


         --- System Configuration Dialog ---

Would you like to enter the initial configuration dialog? [yes/no]:
00:00:18: %SYS-5-RESTART: System restarted --
Cisco Internetwork Operating System Software
IOS (tm) C2950 Software (C2950-I6Q4L2-M), Version 12.1(6)EA2c, RELEASE SOFTWARE
(fc1)
Copyright (c) 1986-2002 by cisco Systems, Inc.
Compiled Thu 28-Feb-02 14:44 by antonino
% Please answer 'yes' or 'no'.
Would you like to enter the initial configuration dialog? [yes/no]: n



Press RETURN to get started!


00:01:07: %LINK-5-CHANGED: Interface Vlan1, changed state to administratively do
wn
00:01:08: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, changed state t
o down
Switch>

-Shawn
0
 
LVL 11

Expert Comment

by:tvman_od
ID: 20102749
check "show run"

all the interfaces have shutdown directive now.

setup script normally will activate all the ports, but you decided not to run it.
0
 

Author Comment

by:shawn_flynn
ID: 20103715
Tvman_od,
I am feeling like a complete idiot. But I did see that nothing is activated. So how do I remedy the situation?
Is there another command I need to add?
All the command line attempts (above) always says nothing is activated.
I tried the suggestion:
Switch#write erase
Save config no
Switch#reload

Is there something else I should add? Please... Its driving me crazy...
0
 

Author Comment

by:shawn_flynn
ID: 20105008
This is what I have now and it still does not work?
I did this:
config t
int range fa 0/1 - 24
no shut
int vlan1
no shut
exit
copy run start
now I have this:
Switch#reload            
Proceed with reload? [confirm]y                              
00:09:45: %SYS-5-RELOAD: Reload requested                                        

C2950 Boot Loader (C2950-HBOOT-M) Version 12.1(6)EA2c, RELEASE SOFTWARE (fc1)                                                                            
Compiled Thu 28-Feb-02 14:59 by antonino                                        
WS-C2950-24 starting...                      
Base ethernet MAC Address: 00:09:b7:f5:47:00                                            
Xmodem file system is available.                                
Initializing Flash...                    
flashfs[0]: 19 files, 2 directories                                  
flashfs[0]: 0 orphaned files, 0 orphaned directories                                                    
flashfs[0]: Total bytes: 7741440                                
flashfs[0]: Bytes used: 3980288                              
flashfs[0]: Bytes available: 3761152                                    
flashfs[0]: flashfs fsck took 6 seconds.                                        
...done initializing flash.                          
Boot Sector Filesystem (bs:) installed, fsid: 3                                              
Parameter Block Filesystem (pb:) installed, fsid: 4                                                  
Loading "flash:c2950-i6q4l2-mz.121-6.EA2c.bin"...###############################                                                                                
################################################################################                                                                                
#######################################################################                                                                      

File "flash:c2950-i6q4l2-mz.121-6.EA2c.bin" uncompressed and installed, entry po                                                                                
int: 0x80010000              
executing...            

              Restricted Rights Legend                                      

Use, duplication, or disclosure by the Government is                                                    
subject to restrictions as set forth in subparagraph                                                    
(c) of the Commercial Computer Software - Restricted                                                    
Rights clause at FAR sec. 52.227-19 and subparagraph                                                    
(c) (1) (ii) of the Rights in Technical Data and Computer                                                        
Software clause at DFARS sec. 252.227-7013.                                          

           cisco Systems, Inc.                              
           170 West Tasman Drive                                
           San Jose, California 95134-1706                                          



Cisco Internetwork Operating System Software                                            
IOS (tm) C2950 Software (C2950-I6Q4L2-M), Version 12.1(6)EA2c, RELEASE SOFTWARE                                                                              
(fc1)    
Copyright (c) 1986-2002 by cisco Systems, Inc.                                              
Compiled Thu 28-Feb-02 14:44 by antonino                                        
Image text-base: 0x80010000, data-base: 0x8042C000                                                  


Initializing flashfs...                      
flashfs[1]: 19 files, 2 directories                                  
flashfs[1]: 0 orphaned files, 0 orphaned directories                                                    
flashfs[1]: Total bytes: 7741440                                
flashfs[1]: Bytes used: 3980288                              
flashfs[1]: Bytes available: 3761152                                    
flashfs[1]: flashfs fsck took 6 seconds.                                        
flashfs[1]: Initialization complete.                                  
Done initializing flashfs.                          
POST: System Board Test : Passed                                
POST: Ethernet Controller Test : Passed                                      
ASIC Initialization Passed                          

POST: FRONT-END LOOPBACK TEST : Passed                                      
cisco WS-C2950-24 (RC32300) processor (revision D0) with 21295K bytes of memory.                                                                                

Processor board ID FHK0622X0C7                              
Last reset from system-reset                            
Running Standard Image                      
24 FastEthernet/IEEE 802.3 interface(s)                                      

32K bytes of flash-simulated non-volatile configuration memory.                                                              
Base ethernet MAC Address: 00:09:B7:F5:47:00                                            
Motherboard assembly number: 73-5781-1                                    
Power supply part number: 34-0965-01                                    
Motherboard serial number: FOC06210DDT                                      
Power supply serial number: PHI061807K9                                      
Model revision number: D0                        
Motherboard revision number: B0                              
Model number: WS-C2950-24                        
System serial number: FHK0622X0C7                                


Press RETURN to get started!                            


00:00:17: %SYS-5-CONFIG_I: Configured from memory by console                                                            
00:00:17: %SYS-5-RESTART: System restarted --                                            
Cisco Internetwork Operating System Software                                            
IOS (tm) C2950 Software (C2950-I6Q4L2-M), Version 12.1(6)EA2c, RELEASE SOFTWARE                                                                              
(fc1)    
Copyright (c) 1986-2002 by cisco Systems, Inc.              
sistent por          

Compile
Compiled Thu 28-Feb-02 14:44 by antoninoN: Line pro                            
Switch>ena          
Switch#show ip int briefJose,                  
Interface                  IP-Address      OK? Method Status                Prot:b7:f5:47:00ting System Softwareo up                                            
ocol    
Vlan1                      unassigned      YES NVRAM  up                    down2-M), Ve                                                                
Initial

FastEthernet0/1            unassigned      YES unset  up                    down, 2 directories                                  
wn  

cisco WS-C2          


FastEthernet0/2            unassigned      YES unset  up                    down                                                                              


FastEthernet0/3            unassigned      YES unset  up                                                      

Proces    

FastEthernet0/9            unassigned      YES unset  up                    down part number: 34                            
                                   

FastEthernet0/11           unassigned      YES unset  up                    down      
IOS (tm) C2950 Software (C2950-I6Q4L2-M), Version 12.1(6)EA2c, RELEASE SO

FastEthernet0/12           unassigned      YES unset  up                    down                                              
service timestamps debug uptime

FastEthernet0/13           unassigned      YES unset  up                    down by cisco Systems, Inc.                                              
no serv  

FastEthernet0/14           unassigned      YES unset  up                    downame Switch                                                      
!
IOS (tm)    

FastEthernet0/15           unassigned      YES unset  up                    downnet0/1                                                                          

FastEthernet0/17           unassigned      YES unset  up                    down                                

flashfs[1]: Total bytes: 'yes'              

FastEthernet0/18           unassigned      YES unset  up                    downn  
00:00:35: %LINEPROTO-5-UP                        
POST: Ethernet Controller

FastEthernet0/19           unassigned      YES unset  up                    down                  
ASIC Initialization PassedstEthernet0/16                    

FastEthernet0/20           unassigned      YES unset  up                    down                        
Switch#copy run startinte                        
cisc

FastEthernet0/21           unassigned      YES unset  up                    down                                                                          
%Erro


Switch#      
Switch#show run              
Building configuration...system ha                

Current configuration : 1016 bytes6q4l2-mz.121-6.EA                
!
version 12.1            
no service pad              
service timestamps debug uptimetus                Protwing com
service timestamps log uptime                            
no service password-encryption                              
!
hostname Switch80010000      
!
!
ip subnet-zerocol..th      
no ip finger            
!
!
!
interface Fast            
!
interface FastEthernet0/5, or disclosure by the Go
!r
interface FastEthernet0/6                        
!
interface FastEthernet0/7      

FastEthernet0/1  
!
interface FastEthernet0/8 unset  up              
!
interface FastEthernet0/9vech: flash_init        
!
interface FastEthernet0/10                          
!
interface FastEthernet0/11                    
I


!
interface FastEthernet0/12.   -        -    -      
!0
interface FastEthernet0/13                          
!
interface FastEthernet0/14         unassigned      Y
!
interface FastEthernet0/15  downrnia 95134-170600  -
!
interface FastEthernet0/16      0                  
!
interface FastEthernet0/17                          
!
interface FastEthernet0/18                          
!
interface FastEthernet0/19                

       
!
interface FastE            
interface FastEthernet0/24                          
!
interface Vlan1              
 no ip address              
 no ip route-cache            

Fas
!t
ip http server      unassign
!
line con 0set  up  
 transport input noneight (c) 1986-2002 by
line vty 0 4s, Inc.2    
 login      
line vty 5 15            
 login      
!
end  


VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa0/1, Fa0/2, Fa0/3, Fa0/4
                                                Fa0/5, Fa0/6, Fa0/7, Fa0/8
                                                Fa0/9, Fa0/10, Fa0/11, Fa0/12
                                                Fa0/13, Fa0/14, Fa0/15, Fa0/16
                                                Fa0/17, Fa0/18, Fa0/19, Fa0/20
                                                Fa0/21, Fa0/22, Fa0/23, Fa0/24
2    Sub105                           active
1002 fddi-default                     active
1003 token-ring-default               active
1004 fddinet-default                  active
1005 trnet-default                    active

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1    enet  100001     1500  -      -      -        -    -        1002   1003
2    enet  100002     1500  -      -      -        -    -        0      0
1002 fddi  101002     1500  -      0      -        -    -        1      1003
1003 tr    101003     1500  1005   0      -        -    srb      1      1002
1004 fdnet 101004     1500  -      -      1        ibm  -        0      0
1005 trnet 101005     1500  -      -      1        ibm  -        0      0
Switch#

0
 

Author Comment

by:shawn_flynn
ID: 20105056
As lrmoore stated above I want just a barebones pure l2 switch. I can't beleive I have spent days on this? It should be simple Right?
Tried this:
switch#write erase
 save config? NO
switch#reload

Done. Don't configure anything at all. It works right out of the box as a pure L2 switch, all ports on the same vlan, no IP address for managment. All ports auto/auto for speed/duplex. All ports in same VLAN1.

But I had no ports so I tried this too
config t
int range fa 0/01 - 24
no shut
int vlan1
no shut
exit
copy run start

still no work

-shawn

0
 
LVL 11

Assisted Solution

by:tvman_od
tvman_od earned 750 total points
ID: 20110600
when you on the console it should issue messages about up/down state changes.
Thake a good straight cable (look at wires color, it should be the same on both ends)
connect to port 2
conf t
int fa0/2
shu
(wait a little bit)
no shu

You should get admin and operational status changed.

As another option, the switch has burned out interfaces. I have few routers and switches damaged in construction trailers after lightning storms. Visually the box will work, but it may display permanent link light or nothing. Management console and configuration look as usual, port diagnostic looks good as well, but doesn't fly...


0
 
LVL 79

Expert Comment

by:lrmoore
ID: 20111024
Th obvious next question is - where did you get this switch? Is it new? Did you buy it from a Cisco authorized reseller? The switch carries a limited lifetime warranty if you did. If you bought second hand, buyer beware and you probably bought yourself a lemon.
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 20111048
The other issue is that no port will be up/up until something is actually plugged into it with a proper cat5 cable and operating network interface card.
0
 

Author Comment

by:shawn_flynn
ID: 20113468
Both LRMoore and Tvman forced me to think this thru... so I just divided up the points. Lrmoore knew what I wanted to do, so I was new it was at least possible.
I did this:
Try this:
switch#write erase
 save config? NO
switch#reload

Done. Don't configure anything at all. It works right out of the box as a pure L2 switch, all ports on the same vlan, no IP address for managment. All ports auto/auto for speed/duplex. All ports in same VLAN1.

then this
config t
int range fa 0/01 - 24
no shut
int vlan1
no shut
exit
copy run start

THen I took in home plug it into my network and it works like a charm.
Its all auto. No crossover cables I am in love.
My network at work is now taken over by a third party vendor. We have Voip and some kinda nightmare vlan from hell. Voip is horrible. My network is a @^&$% mess now. Sound quality is worse than two cans and string.
And I more or less locked out of confg. So I have to beg to get a couple of ports to connect the real working network.
So I have all these 2950 I worked so hard to configure. Replaced with POE switches to power the phones. Oh and they just figured out we have to spend a fortune on battery backup now. And thats all I gota say about that.
But thanks guys for making me have to THINK again, I needed it.
-Shawn

0
 
LVL 11

Expert Comment

by:tvman_od
ID: 20115323
There are much cheaper solutions out there. Let's say Netgear offers pretty decent 48 ports PoE switch for 5 times cheaper then Cisco. We use them if budget is really limited. Why don't use just a standard UPS instead of battery backup and a generator if it's really critical to have uninterrupted phone service. For small offices there are MITEL CXi controllers with embedded 16 ports PoE switches. You get everything out of the box, 16 phones, connectivity for 16 computers through the phone, Internet gateway. It can be expanded up to 64 station using external PoE switches or external PoE injectors ($15 each)
0
 

Expert Comment

by:sector7
ID: 21922707
How is it possible you stated the resolution not working for you multiple times above?
0

Featured Post

Vote for the Most Valuable Expert

It’s time to recognize experts that go above and beyond with helpful solutions and engagement on site. Choose from the top experts in the Hall of Fame or on the right rail of your favorite topic page. Look for the blue “Nominate” button on their profile to vote.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This month, Experts Exchange’s free Course of the Month is focused on CompTIA IT Fundamentals.
Unable to change the program that handles the scan event from a network attached Canon/Brother printer/scanner. This means you'll always have to choose which program handles this action, e.g. ControlCenter4 (in the case of a Brother).
Viewers will learn how to connect to a wireless network using the network security key. They will also learn how to access the IP address and DNS server for connections that must be done manually. After setting up a router, find the network security…
Monitoring a network: how to monitor network services and why? Michael Kulchisky, MCSE, MCSA, MCP, VTSP, VSP, CCSP outlines the philosophy behind service monitoring and why a handshake validation is critical in network monitoring. Software utilized …

810 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question