Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1780
  • Last Modified:

DoubleClick on any drive gives access denied

Hello  Gurus,
machine winxp sp2
Problem : when I double click on any disk drive I get access denied.
But If I right click and explore , works fine.
Same pb when I insert a flash disk...I can double click on it...have to right click..
I have NOD32 updated,...no virus seems to be there...
All I know is that the user messed with the file open properties...but I couldn't get it back to its original
state...but not sure that this is the pb...
he says he tried there when he got the pb ??
thanks.
0
ammounpierre
Asked:
ammounpierre
  • 10
  • 7
  • 4
  • +3
1 Solution
 
illuzianCommented:
Do you have any AV installed, if you have installed Norton see http://service1.symantec.com/support/nsw.nsf/docid/2001122707472207
0
 
Crash2100Commented:
Does this happen in safe mode?
0
 
ammounpierreAuthor Commented:
YES IN SAFE MODE TOO..
I do have an anivirus NOD32 .
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
devil_himselfCommented:
0
 
nobusCommented:
if it is recent, try a system restore to a previous date
0
 
VorenusCommented:
Can you get to the drives using a command prompt (cmd.exe) ?
Does the user has admin rights on the machine ?

Check that you have no autorun.inf on these drives (using the dir /a command from the command prompt at the root of these drives)
0
 
ammounpierreAuthor Commented:
I tried both and none worked...
0
 
VorenusCommented:
Hi Pierre,

If you can't access the drive, it seems to be a permission issue.
What was the error returned on the command prompt ?
What is the ACL on the drive (right click on the drive in explorer, go to properties and click the Security tab.
0
 
ammounpierreAuthor Commented:
IT IS NOT A SECURITY ISSUE.
because when I right click on it and explore it , I can access anything without any pb.
0
 
VorenusCommented:
> I tried both and none worked...
Were you referring to my suggestion of trying accessing the drive from cmd or something else ?
0
 
Crash2100Commented:
When you right-click the drive, what option is bolded?  Is it anything besides "Open"?

Try this:

drive wont open or access
http://www.annoyances.org/exec/forum/winxp/1192303800

Go to Start then Run, type "regsvr32 /i shell32.dll" and press Enter or click OK

See if that fixes the problem. If not do the following:

1.  Start Registry Editor (Start then Run, type regedit and press Enter of click OK)
2.  Locate and then click the Default value under the following keys in the registry if this problem occurs with folders:

HKEY_CLASSES_ROOT\Directory\shell
 
If this problem occurs with drives:
HKEY_CLASSES_ROOT\Drive\shell

3.  Click Modify on the Edit menu.
4.  Type none in the Value data box, and then click OK.
5.  Quit Registry Editor.
0
 
nobusCommented:
did you try a system restore ?
0
 
ammounpierreAuthor Commented:
System Restore did not help.
from cmd there is no problem at all.
0
 
nobusCommented:
you can try a repair install :  
 http://www.michaelstevenstech.com/XPrepairinstall.htm

but it can be you need a fresh install of XP
0
 
VorenusCommented:
Hi Pierre,

Could you sée a autorun.inf at the root of the drive ?

Do a

cd\
dir /a *.inf

from the cmd.
0
 
ammounpierreAuthor Commented:
there is no autorun.inf
0
 
Crash2100Commented:
Did you try what I posted above?
0
 
ammounpierreAuthor Commented:
Sorry for being late... Yes I did , and it did not work..
In safe mode , there is no pb though...
0
 
nobusCommented:
try running sfc /scannow from the run box
0
 
devil_himselfCommented:
Try this

Open My Computer > Tools > Folder Options  > 'File Types' Tab > Select 'Drive' > Advanced > Set Default  
0
 
ammounpierreAuthor Commented:
Im sorry for my earlier post...
in safe mode also I do have that pb.
But I detected an autorun.inf file on C:\ that I deleted...
but still not working...
and devil... this is also not working... when I go to
My Computer > Tools > Folder Options  > 'File Types' Tab > Select 'Drive' > Advanced > Set Default  
I find the following commands : find - explorer..
0
 
nobusCommented:
i would try if you can access the drive from a live cd :
ftp://ftp.uni-kl.de/pub/linux/knoppix/KNOPPIX_V5.1.0CD-2006-12-30-EN.iso      Knoppix      
www.nu2.nu/pebuilder/                                     BartPe
0
 
ammounpierreAuthor Commented:
I can access the drive if I right click and explore !!!!!
0
 
ammounpierreAuthor Commented:
the problem is not with accessing the drives... but with doubleclicking on them !!
0
 
nobusCommented:
ok -sorry
DID you try the repair install i suggested?
0
 
ammounpierreAuthor Commented:
yes and not working..
0
 
nobusCommented:
it seems your OS is corrupt; maybe a fresh install is the only answer, sorry
0

Featured Post

Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 10
  • 7
  • 4
  • +3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now