An error occurred on the server when processing the URL. Please contact the system administrator

Hi, Im new to web design and Im using Dreamweaver MX 2004.  I recently started to learn the basics of building a dynamic web page with a "Dreamweaver MX2004: The Missing Manual".  I recently upgraded my Op system from XP Home to Vista to access IIS.  

Following the books tutorial, I successfully set up a connection to a MS Access database.  The next chapter in the book involved the creation of a web page with dynamic data.  Again, following the book's instructions, I loaded up a page with four or five dynamic fields.

The next step in the process involved a "Preview in IE".  However, I received the following error message when I tried to view the page:

http://localhost/nationalex_root/TMPqs6jfq3th7.asp
An error occurred on the server when processing the URL. Please contact the system administrator

This is the error message w/ "Show Friendly Error Messages" unchecked.  Any help will be greatly appreciated.

Thanks
efurholeAsked:
Who is Participating?
 
efurholeConnect With a Mentor Author Commented:
Copied and pasted from another EE exchange - credit to the community.

The answer is in IIS 7.0 there is a button called 'authentication' and under this setting you will see 'Anonymous Authentification' which by default is 'Enabled'. Right click and select edit. By default the user identity will be iuser - this is the core of the problem! Change this to 'Application pool identity' and it works fine!

IIS doesn't need applications set on a folder as previously because it is more like a webserver. You create a website and can have multiple websites. The application is automatically assigned to it. So i was going about it completely the wrong way.
0
 
SysExpertCommented:
1) Try to reduce security in IE.

2) Try to turn off UAC.

I hope this helps !
0
 
Jason C. LevineNo oneCommented:
Hi efurhole,

Have you tested http://localhost/ to make sure IIS is working properly?
0
The 14th Annual Expert Award Winners

The results are in! Meet the top members of our 2017 Expert Awards. Congratulations to all who qualified!

 
efurholeAuthor Commented:
2) Try to turn off UAC.

What is UAC and where would I find this setting??

Thanks
0
 
SysExpertCommented:
User access control
Disable Vista Security Center
1. Start -> Run -> "services.msc" (no quotes)
2. Continue at UAC prompt
3. Scroll down to "Security Center"
4. Right click and select properties
5. Change "Startup Type:" to "Disabled"
6. Click OK
0
 
SysExpertCommented:
0
 
efurholeAuthor Commented:
UAC changes made.  Same error message.

Have you tested http://localhost/ to make sure IIS is working properly?  Yes.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.