[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 389
  • Last Modified:

How can I minimize resources used by Vista for indexing?

Occasionally, Vista gets very busy -- I think that it's indexing files for searching because the disk in-use light flashes. I've tried to minimize this (e.g., removed default files and folders from indexing list) but at least once each day I can't do any other work for several minutes while it's busy. How can I confirm what is causing the problem and how can I make indexing use fewer resources?
0
mcglincym
Asked:
mcglincym
2 Solutions
 
Brad GrouxCommented:
First thing I would do is verify that your machine is free of any Spyware by updating and running a Windows Defender scan. I would also run a third party scan like Spybot Search & Destroy to double-check if there are any problems. If those come back clean then you can try a few different options to help speed up performance.

First thing I'd do is run MSCONFIG and disable all the unneeded startup applications, check out this link for details...
http://www.netsquirrel.com/msconfig/msconfig_vista.html

I'd disable just about everything from the startup tab except those things used by Windows. Disable QuickTime, Adobe Acrobat, Messenger, etc. Unless it says Microsoft or Windows I'd disable it.
http://blogs.msdn.com/tims/archive/2006/09/28/windows-vista-secret-9-kill-the-startup-monsters.aspx

There are a couple of ways to disable indexing...

To turn off indexing for a specific drive:
Go to My Computer, right click on a drive, open the System Properties dialog box. Towards the bottom of the page is a check box for "Allow Indexing Service to index this disk for fast file searching" uncheck the box.

To completely turn off the indexing service go to services (start-->run-->services.msc) find the Indexing Service and change it's start up option to manual or disabled.
0
 
SysExpertCommented:
Also, you can use the taks manager - performance and processes TAb to see what is eating up the CPU during the time it is slow.

I hope this helps !
0
 
mcglincymAuthor Commented:
I scan for viruses and spyware every Friday with Norton Internet Security with nothing detected. I ran a Windows Defender scan and found nothing. I turned off indexing for C: (this took a while) but did not solve the problem. The CPU is not being stressed when this happens. Resource Monitor (under Task Manager) shows CPU about 10%, Disk at "100% highest active time", and physical memory at 44% used. I sorted images listed under Disk and saw that one of the svchost processes apparently was accessing Outlook.pst at high B/Min. I closed Outlook and the problem went away. Because the problem only occurs for several minutes at a time, I don't know if it went away on its own or because I closed Outlook -- I thought I had turned off Vista indexing for Outlook.
0
 
Computer101Commented:
Forced accept.

Computer101
EE Admin
0

Featured Post

How to Use the Help Bell

Need to boost the visibility of your question for solutions? Use the Experts Exchange Help Bell to confirm priority levels and contact subject-matter experts for question attention.  Check out this how-to article for more information.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now