• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 593
  • Last Modified:

ODBC error connecting to SQL Server 2005 database on remote machine

Hi,

I'm having a problem when adding a DSN via ODBC to connect to a SQL Server 2005 database. The exact error is:

Connection failed:
SQL State:'01000'
SQL Server Error: 233
[Microsoft][ODBC SQL Server Driver][DBNETLIB] ConnectionOpen(Connect()).
Connection failed:
SQL State: '08001'
SQL Server Error: 17
[Microsoft][ODBC SQL Server Driver][DBNETLIB] SQL Server does not exist or access denied.

I have variously tried checking the Client Configuration is set to TCP/IP and that the username/password pair is correct (I set up these ODBC connections quite often and it's usually very simple). Setting up the ODBC from the Server itself machine is fine.

Having looked at various similar problems that people are having a lot of the Q's on EE for this particular problem just get left hanging in mid-air or just abandoned.

I really need to sort this out quickly and am at the 'tearing my hair out' stage. You may have to walk me through it step by step....but if it gets solved this may be the one appropriate answer to this quite common question here on EE!


Thanks in advance
Iain
0
iaing1000
Asked:
iaing1000
  • 2
  • 2
1 Solution
 
Chris MangusDatabase AdministratorCommented:
Have you configured the server to allow remote connections?  You would do this with SQL Server Configuration Manager.
0
 
iaing1000Author Commented:
Hi,

Thanks for the quick response! No, I haven't actually tried yet, what exactly do I do to make that work?

Cheers
Iain
0
 
Chris MangusDatabase AdministratorCommented:
Actually, I misspoke.  It's SQL Server Surface Area Configuration Manager for Services and Connections.  Check the Local and Remote connections radio button, if it's not checked already.
0
 
iaing1000Author Commented:
Hi,

Yes, that radio button is ticked...but..

....inadvertently your initial comment led me to the answer. From the SQL Server Configuration Manager I went to SQL Server 2005 Network Configuration --> Protocols for MSSQLServer --> TCP/IP and then selected the IP Addresses tab. The LAN address of the server 192.168.1.11, and the 127.0.0.1 localhost, both had enabled set to FALSE. I've set these to TRUE and after a SQL Server restart everything now works fine!

Thanks loads
Iain
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: Microsoft Azure 2017

Azure has a changed a lot since it was originally introduce by adding new services and features. Do you know everything you need to about Azure? This course will teach you about the Azure App Service, monitoring and application insights, DevOps, and Team Services.

  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now