• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1723
  • Last Modified:

DNS record in "_msdcs" missing

I have a cluster with active directory (windows 2003 R2)

all event viewer are good, no errors, no warnings... so everyting is good... but..
When I look in the DNS, forward lookup zones, domain.com, _msdcs, I only see one of my DC. cluster1, but nothing about cluster2....

I try to find out on google and I found the command netdiag /fix and I have errors...
I try to add manually the record in _msdcs and ran the netdiag /fix again... same errors
here is the resualt:

C:\Documents and Settings\Administrator.DOMAIN>netdiag /fix

....................................

    Computer Name: PAIN-CLUSTER2
    DNS Host Name: pain-cluster2.domain.com
    System info : Microsoft Windows Server 2003 R2 (Build 3790)
    Processor : x86 Family 6 Model 15 Stepping 6, GenuineIntel
    List of installed hotfixes :
        KB921503
        KB924667-v2
        KB925398_WMP64
        KB925876
        KB925902
        KB926122
        KB927891
        KB929123
        KB929969
        KB930178
        KB931768-IE7
        KB931784
        KB931836
        KB932168
        KB933360
        KB933566-IE7
        KB933729
        KB933854
        KB935839
        KB935840
        KB935966
        KB936021
        KB936357
        KB936782
        KB938127-IE7
        KB939653-IE7
        KB941202
        Q147222


Netcard queries test . . . . . . . : Passed



Per interface results:

    Adapter : PRIVATE

        Netcard queries test . . . : Passed

        Host Name. . . . . . . . . : pain-cluster2
        IP Address . . . . . . . . : 10.1.10.21
        Subnet Mask. . . . . . . . : 255.255.0.0
        Default Gateway. . . . . . : 10.1.10.2
        Dns Servers. . . . . . . . : 10.1.10.21
                                     10.1.10.20


        AutoConfiguration results. . . . . . : Passed

        Default gateway test . . . : Passed

        NetBT name test. . . . . . : Passed
        [WARNING] At least one of the <00> 'WorkStation Service', <03> 'Messenge
r Service', <20> 'WINS' names is missing.

        WINS service test. . . . . : Skipped
            There are no WINS servers configured for this interface.

    Adapter : HEARTBEAT

        Netcard queries test . . . : Passed

        Host Name. . . . . . . . . : pain-cluster2
        IP Address . . . . . . . . : 172.25.0.2
        Subnet Mask. . . . . . . . : 255.255.255.0
        Default Gateway. . . . . . :
        NetBIOS over Tcpip . . . . : Disabled
        Dns Servers. . . . . . . . :

        AutoConfiguration results. . . . . . : Passed

        Default gateway test . . . : Skipped
            [WARNING] No gateways defined for this adapter.

        NetBT name test. . . . . . : Skipped
            NetBT is disabled on this interface. [Test skipped]

        WINS service test. . . . . : Skipped
            NetBT is disable on this interface. [Test skipped].


Global results:


Domain membership test . . . . . . : Passed


NetBT transports test. . . . . . . : Passed
    List of NetBt transports currently configured:
        NetBT_Tcpip_{19FCD08A-A383-4D45-8FFC-8B658604141E}
    1 NetBt transport currently configured.


Autonet address test . . . . . . . : Passed


IP loopback ping test. . . . . . . : Passed


Default gateway test . . . . . . . : Passed


NetBT name test. . . . . . . . . . : Passed
    [WARNING] You don't have a single interface with the <00> 'WorkStation Servi
ce', <03> 'Messenger Service', <20> 'WINS' names defined.


Winsock test . . . . . . . . . . . : Passed


DNS test . . . . . . . . . . . . . : Passed
          [WARNING] Cannot find a primary authoritative DNS server for the name
            'pain-cluster2.domain.com.'. [ERROR_TIMEOUT]
            The name 'pain-cluster2.domain.com.' may not be registered in DN
S.
    PASS - All the DNS entries for DC are registered on DNS server '10.1.10.21'
and other DCs also have some of the names registered.


Redir and Browser test . . . . . . : Passed
    List of NetBt transports currently bound to the Redir
        NetBT_Tcpip_{19FCD08A-A383-4D45-8FFC-8B658604141E}
    The redir is bound to 1 NetBt transport.

    List of NetBt transports currently bound to the browser
        NetBT_Tcpip_{19FCD08A-A383-4D45-8FFC-8B658604141E}
    The browser is bound to 1 NetBt transport.


DC discovery test. . . . . . . . . : Passed


DC list test . . . . . . . . . . . : Passed


Trust relationship test. . . . . . : Passed
    Secure channel for domain 'DOMAIN' is to '\\pain-cluster1.domain.com
'.


Kerberos test. . . . . . . . . . . : Passed


LDAP test. . . . . . . . . . . . . : Passed


Bindings test. . . . . . . . . . . : Passed


WAN configuration test . . . . . . : Skipped
    No active remote access connections.


Modem diagnostics test . . . . . . : Passed

IP Security test . . . . . . . . . : Skipped

    Note: run "netsh ipsec dynamic show /?" for more detailed information


The command completed successfully

-----------------------------------------------------------------------------------------------------------------

since those 2 servers are in cluster, I can not demote the DC, can not uninstall DNS....

what can I do to solve that issue?
0
Jean-Pier
Asked:
Jean-Pier
  • 2
  • 2
1 Solution
 
thenoneCommented:
I would try rebuilding dns on that server. Point dns to the good server. Go to start run cmd. Type in ipconfig/flushdns and then ipconfig/registerdns. This should rebuild dns from active directory . Wait about 15 minutes then have dns point to itself.
0
 
Jean-PierAuthor Commented:
I recently open a support case at microsoft for something else and I ask the MS tech what should I do to fix this. (since it has nothing to do with the case I open I just dont what to ask im to many questions...)

here is his answer:
A domain controller should reregister service records when rebooted. You can also try restarting netlogon service on that server. That should also reregister service records. Once you restart netlogon, check event viewers for any errors. There is no single kb article about this as this could be caused by a lot of different things.

Things to check:
- dns suffix on Cluster2
- FQDN name, make sure it matches zone name
- make sure that dynamic updates are enabled on DNS server

Kbs:
http://support.microsoft.com/kb/241505
http://technet.microsoft.com/en-us/library/aa996973.aspx


-----------------------------
I tried rebooting, does not work
restard netloging service, does not work
checking dns sufix ?? dns sufix is what goes after le server name: cluster2.domain.com. since its a domain controler it should be fine.... (replication is working, every thing. I dont have a single error in event viewer)
FQDN name, make sure it matches zone name. I know what is a FQDN and what it a zone name... but how do i make sure they match ?

0
 
thenoneCommented:
Look in domain dns zones and forest domain zones and make sure that the old server is not listed in those.
0
 
Jean-PierAuthor Commented:
I changed the DNS on the server for:
dns1: 127.0.0.1
dns: "other internal dns server"

and it works
0

Featured Post

Vote for the Most Valuable Expert

It’s time to recognize experts that go above and beyond with helpful solutions and engagement on site. Choose from the top experts in the Hall of Fame or on the right rail of your favorite topic page. Look for the blue “Nominate” button on their profile to vote.

  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now