?
Solved

"New transaction cannot enlist in the specified transaction coordinator" Error When Using COM+ on Win 2003

Posted on 2007-10-18
5
Medium Priority
?
705 Views
Last Modified: 2013-12-04
Hello,
I'm getting an error when running some simple VB6 code that accesses a COM+ application which attempts to connect to SQL 2000.   The error is...

"New transaction cannot enlist in the specified transaction coordinator."

The error occurs on the ADODB.Connection open statement.

In the event log, I get the following:

Event Type: Failure Audit
Event Source: Security
Event Category: Logon/Logoff
Event Id: 529
User: NT Authority\System

Logon Failure:  
   Reason:  Unknown user name or password
   UserName:  xxxxxx$

where xxxxx is the name of the sql server to which I'm trying to connect.

The simple test application is VB6 and COM+.  The COM+ piece was written in version 1.0 and loaded in COM+ 2.0 under Win 2003.  The application is running under Win 2003 std SP2, NTLMV2 only.

I'm using MS DTC, DCOM to DCOM.  DTC service is turned on for both servers. The target server is a Win 2003 server with SQL 2000 sp3a.

This works fine on Windows 2000.

Can you please offer any advise?
Thanks!





0
Comment
Question by:reed1989a
  • 3
  • 2
5 Comments
 
LVL 17

Accepted Solution

by:
Chris Mangus earned 1500 total points
ID: 20104497
You need to set your DTC on the Win2003 machine to allow no authentication.
0
 

Author Comment

by:reed1989a
ID: 20107966
Thanks for the suggestion.  The current requirement that I have is to use authentication.   That said, are there other configuration settings you can recommend for COM+ or DTC?
0
 
LVL 17

Expert Comment

by:Chris Mangus
ID: 20109457
The solution I posted is what Microsoft will tell you on their website.  We have a requirement to use authentication too but according to Microsoft it can't be done between a 2000 and a 2003 server so we have to use their workaround and document it.

I don't know of any other config that will get around this.
0
 

Author Comment

by:reed1989a
ID: 20111657
Thanks for the posting.  I have a solution.  Sorry I wasn't clearer about the two servers being Windows 2003.  

I fixed the problem by adding a local security policy setting of LAN Manager Authentication Level, with local setting "Send NTLMv2 Response Only\refuse LM & NTLM".   This was done on the target server. This resolved the error.



0
 

Author Comment

by:reed1989a
ID: 20111708
Thanks for the help.  Your advice was factual and helpful, but not quite what was needed to solve the problem.  I'm giving you the points anyway because I appreciate your time and effort in assisting me to find the full solution.
0

Featured Post

A Cyber Security RX to Protect Your Organization

Join us on December 13th for a webinar to learn how medical providers can defend against malware with a cyber security "Rx" that supports a healthy technology adoption plan for every healthcare organization.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Recently we ran in to an issue while running some SQL jobs where we were trying to process the cubes.  We got an error saying failure stating 'NT SERVICE\SQLSERVERAGENT does not have access to Analysis Services. So this is a way to automate that wit…
MSSQL DB-maintenance also needs implementation of multiple activities. However, unprecedented errors can hamper the database management. In that case, deploying Stellar SQL Database Toolkit ensures fast and accurate database and backup repair as wel…
Via a live example, show how to backup a database, simulate a failure backup the tail of the database transaction log and perform the restore.
Viewers will learn how to use the INSERT statement to insert data into their tables. It will also introduce the NULL statement, to show them what happens when no value is giving for any given column.
Suggested Courses

807 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question