why does turning off snmp disable printing?

Hi

we have about 12 printers on a print server.  i was turning off unused protocols today (appletalk, netbios, etc.) and also turned off snmp.  I noticed that 7 printers were "offline" even tho i could ping them.  the only way i could get these back online was tu enable snmp.

can someone explain why this occured?  i researched it here on EE and found that some people actually had to turn OFF snmp to print.  we dont use snmp traps here nor do we monitor it, so why cant i disable it?

thanks
LVL 2
phrea84Asked:
Who is Participating?
 
hdhondtCommented:
If the info in 65td's article is correct (i.e. port 9100 uses snmp), then you should be able to print again by changing the Standard TCP/IP ports from RAW to LPR.

Note that LPR requires a "remote queue name" which is printer dependant. Some printers will only accept data via the correct queue name, others expect different data on different queues, still others don't care.
0
 
phrea84Author Commented:
thanks for the quick reply.  one thing i dont understand is this. http://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Server/SBS_Small_Business_Server/Q_22469378.html?sfQueryTermInfo=1+printer+snmp
 i had the same sitution after i disabled snmp.  he had to turn snmp off to be able to print.  was he doing what hdhondt suggested?
0
Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

 
phrea84Author Commented:
also, prior to turning snmp back off, if i restarted the print spooler, all the printer went to ready for about a minute before going back offline.  any idea why?
0
 
hdhondtConnect With a Mentor Commented:
In the earlier question a JetDirect was used. As it talks to the printer over the parallel port it can't give any info to the server about the printer. Maybe that's why turning snmp helped in that case - although I can't think of any instance where I've had to do that, with or without external printservers.

Your minute's delay may be the time it takes before port 9100 checks the printer (using snmp) and discovers it can't talk to it. I'm guessing here.

On another issue, why disable snmp in the first place? It's not as if it generates huge amounts of network traffic.

0
 
phrea84Author Commented:
i was just trying to minimize as much traffic as possible.  im trying to pinpoint alot of network trafic and i figure the less traffic i have going out, the less i have to look at.

thanks for the info.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.