AutoRun Feature is not working. When CD is inserted, it doesn't open the contents automatically

Hi friends !

I have a problem with AutoRun feature. I am using a laptop. The following are the specifications...

Model Name: DELL INSPIRON 1501
DVD/CD-ROM drives: TSSTcorp CDRW/DVD TSL462D
Operating System installed: On C: drive Windows XP is installed
                                             On D: drive Windows Vista is installed

Please see that when I insert a CD that supports AutoRun Feature or I use Flash Disk, I find that the CD is detected by CD Drive and the Flash is also detected as removable media. BUT...

They are not opening automatically. In other PCs, they open automatically with AutoRun Feature.

What I did is... I went in the properties of the DVD/CD ROM---> AutoPlay Tab----In select a content type, I selected Mixed Contents and then in Action to perform--->I selected Open Folder to view files.

But it didn't worked. I still have to insert the CD and when the CD is detected, I have to open it manually to see the contents.

The following devices in Device Manager are not installed...

1. Base System Device
2. Network Controller
3. SM Bus Controller
4. Video Controller (VGA Compatibles)
 
Does it cause the problem ?

Please tell me how and where can I enable the AutoRun Feature ?

Waiting for your reply...

Regards,

Hemant
JatinHemantAsked:
Who is Participating?
 
dreamyguyCommented:
You can also use TWEAKUI to enable the autorun feature in xp.
It can be downloaded from http://download.microsoft.com/download/f/c/a/fca6767b-9ed9-45a6-b352-839afb2a2679/TweakUiPowertoySetup.exe

After installing TWEAKUI, do the following steps

1. Go to Start -> All Programs -> Powertoys for Windows XP -> TweakUI.
2. Expand the "My Computer" branch and expand the "Autoplay".
3. Click on "Drives" and make sure your CDROM drive is selected in the "Enable Autoplay on Drives" list.
4. Click on "Type" and make sure both "Enable Autoplay for CD and DVD drives" and
"Enable Autoplay for removable drives" are selected and then click on OK.
5. Restart your computer and test to see if the issue re-occurs.
0
 
Brian PiercePhotographerCommented:
Te artilcle at http://www.moonvalley.com/products/rwavdc/enable.htm provides details of how to enable Autorun for differerent OSs and Media
0
 
and235100Commented:
Firstly - autoplay should work without the driver support.Try the AutoPlay repair wizard:
http://www.microsoft.com/downloads/details.aspx?familyid=C680A7B6-E8FA-45C4-A171-1B389CFACDAD

As to the drivers that are missing - this looks to be a nvidia-based chipset - download drivers from:
http://www.nvidia.com/page/drivers.html
0
Introducing Cloud Class® training courses

Tech changes fast. You can learn faster. That’s why we’re bringing professional training courses to Experts Exchange. With a subscription, you can access all the Cloud Class® courses to expand your education, prep for certifications, and get top-notch instructions.

 
MereteCommented:
What I did is... I went in the properties of the DVD/CD ROM---> AutoPlay Tab----In select a content type, I selected Mixed Contents and then in Action to perform--->I selected Open Folder to view files.

R/click the main rom drive again  properties
check thru all the settings Pictures Music video dvd blank cd etc  
set  " everyone to the same >> auto prompt is selected in each"
In general nothing
Auto play  Music files
and prompt me  each time at the bottom
then set it to always ask
then it auto opens to choices panel  you choose ( folders as is the case)
AND dont have a cd in there when you do this, reboot to ensure save settings
why would  that be difficult to put these back?

0
 
dreamyguyCommented:
OR, you could also use the AUTOPLAY REPAIR WIZARD by MICROSOFT

Description as per microsoft: The Microsoft AutoPlay Repair Wizard scans your computer devices to find defective AutoPlay settings, and attempts to fix those it finds.

http://www.microsoft.com/downloads/details.aspx?FamilyID=c680a7b6-e8fa-45c4-a171-1b389cfacdad&DisplayLang=en

0
 
JatinHemantAuthor Commented:
Thanks to all of you...

I download the tool and it worked.

Thanks again

Hemant
0
 
MereteCommented:
Thats great to hear we were running  out of ideas.
thanks Hemant  :)
0
 
and235100Commented:
"Thats great to hear we were running  out of ideas"

Were "we" ?
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.