• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 535
  • Last Modified:

IIS PHP 5.2 not working

IIS PHP 5.2 not working I ran the installer all looks goo when I run test.php in the wwwroot i get a 404
0
PrivateParts
Asked:
PrivateParts
  • 2
1 Solution
 
PrivatePartsAuthor Commented:
OK,

I have solved the problem of the 404 for php under IIS

I ran the msi installer to Run and installed CGI mode.

Now I could get in command line php -m --ini etc  to run

but in the webserver extensions the path was

C:\Program Files\PHP\   -- get rid of the space like below.

C:\PROGRA~1\PHP\PHP5IS~1.DLL. or php-cgi.exe

AND don't forget to set All Known CGI Extensions to ALLOWED in the Web Service Extensions under IIS

and you should be right to go.
0
 
str_kaniCommented:
i would prefer not to install using the installer and follow the steps here...

http://in.php.net/install.windows


Anyway, for me it looks like you do not have the document root setup properly?

0
 
str_kaniCommented:
I would prefer you work with the manual steps and install this manullay. or install something like http://www.wampserver.com/ to get started very easily...
0

Featured Post

Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now