Disk Quota issues

I am running Windows Server 2003 and have enabled disk quotas on all the users in AD.  I created a test user and when I log into the domain and click on the shared drive \\Servername\Home\%username%, its
showing me the whole disk size instead of the alloted space available from the disk quota.

I added files to the drive and noticed that it doesn't change my quota, but adds on to the builtin/administrators quota, which is of course unlimited.

I'm not sure what to do at this point,  I've changed the appropriate permissions, owners, etc.  but I still end up seeing the whole disk space and quotas is not working for any user.


Any help would be great.
LVL 13
cshepfamAsked:
Who is Participating?
 
DenisCooperCommented:
quotos look at the owner of a file / folder - check who the owner of those files is...it's likely the administrator...
0
 
Ahmed Abdel SalamPh.D. CandidateCommented:
0
 
cshepfamAuthor Commented:
That showed me nothing.  I already did that.  
0
Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

 
thenoneCommented:
What Group Policy did you apply this to?
0
 
cshepfamAuthor Commented:
Edit Default Domain Policy > Administrative Templates > System > Disk Quotas




and honestly, that shouldn't really make a difference about the policy.  I mean, lets say I left it unconfigured but just applied it to the shared drive in itself, the quota should still take place.  I believe I'm missing one simple step but not quite sure what it is.

Earlier I was having a problem accessing the drive itself, I was getting "Access is denied", so I added the Authenticated Users to the share permissions, giving them full control of the shared Home folder.  That fixed that problem.


I beat my head over and over about this issue I'm currently having.  I've done this so many times but this is the first time I ran into this.
0
 
thenoneCommented:
On that shared drive the everyone group should have read access and then inside you should set the permissions but that is another thing.

As far as the disk quota I wouldn't set it up on the domain level. I would create lower group policies and apply disk quotas according to groups inside the domain. Setting that up should work. Also make sure that

Group policies are taking affect on the machine
Go to command prompt do a gpudate/force

then go to command prompt and do a gpresult > c:\gpresult.txt

Open the text file to see if the group policies for that particular user has been applied.
0
 
cshepfamAuthor Commented:
The Everyone group does have read access to the shared drive and the appropriate permissions are set.


Group policies are taking affect on the machine.  I can create a lower group policy for those particular groups and give it a try, but I don't see how that would affect anything.  Setting it up on the domain is actually the correct way to do it, but I'll give your idea a try and let you know the outcome.


Thanks for the help.
0
 
cshepfamAuthor Commented:
The owner is the administrators group.


I can change that (which I did) and it has no effect.  For instance, I tried changing the owner to Authenticated Users and i still see the whole drive.  I changed it to Test user...same thing.  This is crazy.  I know that when i figure this out, it will be something so simple.  It always is.
0
 
thenoneCommented:
Did you try what I suggested?
0
 
cshepfamAuthor Commented:
not yet.



when you say lower group policies, you kinda lost me on that for a second.  if i create lower ones, the ones i previously have in place on the domain would override it.

i would have to temporarily create a new policy, make that higher up, and test it.

i will try it though like i said with one user to see if it effects anything.  i'll let you know how that turns out.
0
 
thenoneCommented:
ok you have default domain policy
default domain controller policy
then you have group policies next
then you have local group policies
0
 
cshepfamAuthor Commented:
sorry took awhile to respond.



anyways, when i set the policy for local accounts, it works.  it enables the quota on all the drives on their computer.  BUT..when the network is up and running, the users will NOT be able to log on locally anyways.  I'm removing that option and setting it so they can only log on to the domain.


So I still have the problem.  So far here's what I know



-All users on the domain has a home folder in which they can access but they see the whole available amount of the drive.  Quotas are enforced through the Default Domain Policy and users have been added and space assigned to them, but still doesn't work.

-When adding files into a mapped home folder, it does NOT affect their quota but adds on to the Builtin/Administrators.

-Administrators groups is the current owner, but even when changing the owner to the user for their home folder, it doesn't make a difference.

-Enabling quotas through a local group policy works on the local drives, but users will NOT be able to log on locally regardless.



This is turning into a headache.
0
 
cshepfamAuthor Commented:
Problem was resolved.  It came down to taking ownership and setting permissions for each appropriate folder structure.


Thanks for the help though.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.