[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2717
  • Last Modified:

Server does not allow remote connections

under the default settings SQL Server does not allow remote connections. (provider: Named Pipes Provider, error: 40 - Could not open a connection to SQL Server)

What causes this and how can I troubleshoot it?

ASP .NET -- I get this when trying to run a Web User Control with some Infragistics controls.  We are using SQL Server 2005
0
Tom Knowlton
Asked:
Tom Knowlton
  • 3
  • 3
  • 2
  • +1
4 Solutions
 
surajgupthaCommented:
Has the ports for named pipes been openned up by the firewall? Is there any port blocking software installed?

Is this problem only for this web control or happens for all the calls to the SQL server?
0
 
REA_ANDREWCommented:
Go into the Sql Server 2005 Surface Area Configuration, under the Database engine check out the config there as it defaults to what you are experiencing.

Also Configuration Manager, you can enable TCP/IP.

Andrew
0
 
Bob LearnedCommented:
This is such a generic error that doesn't explain any reasons, so it can be sooo many things.  I have seen where it was because the connection string is case-sensitive, couldn't reach the server, remote connections aren't turned on by default, authentication problems, server problems, etc.

Bob
0
Granular recovery for Microsoft Exchange

With Veeam Explorer for Microsoft Exchange you can choose the Exchange Servers and restore points you’re interested in, and Veeam Explorer will present the contents of those mailbox stores for browsing, searching and exporting.

 
Tom KnowltonWeb developerAuthor Commented:
I have other Web User Controls that use connections to the same SQL Server (different database, though) and they work just fine.

The connection string is virtually identical except I connect to a different catalog:

from my web config:

//WORKS FINE
<add name="UWinAuthenConnectionString" connectionString="Data Source=UWINDB01\SQLEXPRESS;Initial Catalog=UWinAuthen;User ID=xxx;Password=xxx" providerName="System.Data.SqlClient"/>

//GETS THE ERROR
    <add name="UWinWebScheduleConnectionString" connectionString="Data Source=UWINDB01\SQLEXPRESS;Initial Catalog=WebSchedule;User ID=xxx;Password=xxx" providerName="System.Data.SqlClient"/>


I am leaning towards this being a SQL Server configuration issue.

0
 
Tom KnowltonWeb developerAuthor Commented:
Go into the Sql Server 2005 Surface Area Configuration, under the Database engine check out the config there as it defaults to what you are experiencing.

HUH?

Also Configuration Manager, you can enable TCP/IP.

HUH?

SQL Server dummy, here!!!!!
0
 
surajgupthaCommented:
>>The connection string is virtually identical except I connect to a different catalog:

Can you try and make sure that this is a valid catalog. If you are able to connect to the catalog using some SQL client manually?
0
 
Bob LearnedCommented:
Tom,

If you have 2005 Express Edition, then you can download the free tools, like Surface Area Configuration and Management Studio.  When you install them, there will be a new SQL Server 2005 start menu with those programs listed.

Bob
0
 
Tom KnowltonWeb developerAuthor Commented:
We are running the Express Edition.
0
 
Bob LearnedCommented:
Tom,

What you need to do is download and install the Advanced edition from here:

SQL Server 2005 Express Edition
http://msdn2.microsoft.com/en-us/express/bb410792.aspx

along with the Microsoft SQL Server 2005 Express Edition Toolkit below the Advanced edition.

Bob
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 3
  • 3
  • 2
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now