• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 508
  • Last Modified:

autostart works in gnome, but not in KDE

I am running Kubuntu.

I have a couple of commands that I need to run at the end of the  bootup sequence.

I created and installed /etc/init.d/local, containing the following:

     #!/bin/sh
      sudo /usr/bin/xset +dpms
      sudo /usr/bin/xset dpms 0 0 0

After KDE bootup "xset q" gives me:

DPMS (Energy Star):
  Standby: 1200    Suspend: 1800    Off: 2400
  DPMS is Disabled
 
After GNOME
 bootup "xset q" gives me:

DPMS (Energy Star):
  Standby: 0    Suspend: 0    Off: 0
  DPMS is Enabled
  Monitor is On

Commands run on bootup in GNOME,  but not in KDE.  Is it possible tha the commands are being executed in KDE, but defaults are loaded after commands are executed?

How do I tell what commands are executed in KDE at bootup and in what order?.

If commands are running out of sequence, how do I cnage the order in which lthey run?

Any suggestions as to how I get autostart to work in KDE.would be appreciated.

0
KenSpeedie
Asked:
KenSpeedie
1 Solution
 
4dimachCommented:
Hi,

If its system sctipt, put it at the end of /etc/rc.local, before exit 0. And you don't need sudo in it.

If it is for your kde session, put it in ~/.kde/Autostart.

You can configure Autostart folder location in KDE settings.

Thanks.
0

Featured Post

Vote for the Most Valuable Expert

It’s time to recognize experts that go above and beyond with helpful solutions and engagement on site. Choose from the top experts in the Hall of Fame or on the right rail of your favorite topic page. Look for the blue “Nominate” button on their profile to vote.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now